Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge dialog problems
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
pszczola3mk
n00b
n00b


Joined: 31 Jul 2005
Posts: 21

PostPosted: Sun Aug 21, 2005 7:33 pm    Post subject: emerge dialog problems Reply with quote

i tried to emerge dialog and i got mistake :
configure: error: Cannot link ncursesw library
what should i do to repair that ??? thanks for all help
Back to top
View user's profile Send private message
Raftysworld
Apprentice
Apprentice


Joined: 27 Feb 2005
Posts: 236
Location: Snohomish, WA

PostPosted: Mon Aug 22, 2005 12:12 am    Post subject: Reply with quote

See if running

Code:
USE=-unicode emerge dialog


solves the problem. If it does, add 'app-(something)/dialog -unicode' to /etc/portage/package.use.
_________________
emerge --info
Portage 2.1.4 (default-linux/x86/dev/2007.1, gcc-4.2.2, glibc-2.7-r1, 2.6.24-gentoo i686)
Back to top
View user's profile Send private message
SinoTech
Advocate
Advocate


Joined: 20 Mar 2004
Posts: 2579
Location: Neunkirchen / Saarland / Germany

PostPosted: Mon Aug 22, 2005 8:14 am    Post subject: Reply with quote

Or re-compile "ncurses" with the "unicode" flag set. Think that'll bring you the requested library.

Mfg

Sino
Back to top
View user's profile Send private message
uprooter
n00b
n00b


Joined: 06 Mar 2005
Posts: 70

PostPosted: Mon Aug 22, 2005 6:22 pm    Post subject: Reply with quote

Strange..
I have "unicode" in my use flags but I had to recompile my ncurses to sove this bug.
Maybe ncurses is included in stage3. And this why I had to recompile..
Back to top
View user's profile Send private message
kimchi_sg
Advocate
Advocate


Joined: 26 Nov 2004
Posts: 2915
Location: Singapore

PostPosted: Mon Aug 22, 2005 6:32 pm    Post subject: Reply with quote

uprooter wrote:
Strange..
I have "unicode" in my use flags but I had to recompile my ncurses to sove this bug.
Maybe ncurses is included in stage3. And this why I had to recompile..

Yes, ncurses is bundled with a Stage 3. And that bundled copy is built without USE=unicode.

Hence if you need to turn on unicode support in your system, you'll need to run "emerge -uDvN system" after inserting USE=unicode in make.conf. Even if you're installing from Stage 3.
_________________
Murphy's Law of Gentoo installation: If a compile can fail, it will.

MacGillicuddy's Corollary: At the most inopportune time.

Please search and read the FAQs before posting.
Back to top
View user's profile Send private message
borfig
Apprentice
Apprentice


Joined: 27 Oct 2004
Posts: 162

PostPosted: Mon Aug 22, 2005 6:57 pm    Post subject: Reply with quote

any reasons why unicode isn't in stage(2|3)?????
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Mon Aug 22, 2005 8:55 pm    Post subject: Reply with quote

Moved from Installing Gentoo to Duplicate Threads in favour of ncurses glitch in dialog ebuild.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum