Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge -uD problems
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
sinisterdomestik
l33t
l33t


Joined: 28 Aug 2003
Posts: 683
Location: Texas

PostPosted: Mon Aug 22, 2005 10:38 pm    Post subject: emerge -uD problems Reply with quote

im trying to update world, and its showing me a bunch of kde blocks, such as these
Code:
root@localhost:~ emerge -uDp world

These are the packages that I would merge, in order:

Calculating world dependencies ...done!
[blocks B     ] =kde-base/khotkeys-3.4* (is blocking kde-base/kdebase-3.4.2-r1)
[blocks B     ] =kde-base/khelpcenter-3.4* (is blocking kde-base/kdebase-3.4.2-r1)
[blocks B     ] =kde-base/kdebase-data-3.4* (is blocking kde-base/kdebase-3.4.2-r1)
[blocks B     ] =kde-base/kcminit-3.4* (is blocking kde-base/kdebase-3.4.2-r1)
[blocks B     ] =kde-base/kdesu-3.4* (is blocking kde-base/kdebase-3.4.2-r1)
[blocks B     ] =kde-base/kdm-3.4* (is blocking kde-base/kdebase-3.4.2-r1)
[blocks B     ] =kde-base/kdebase-3.4* (is blocking kde-base/konqueror-3.4.2-r1)
[blocks B     ] =kde-base/kdebase-3.4* (is blocking kde-base/libkonq-3.4.2)
[blocks B     ] =kde-base/kdebase-3.4* (is blocking kde-base/kdesu-3.4.1)
[blocks B     ] =kde-base/kdebase-3.4* (is blocking kde-base/khotkeys-3.4.2)
[blocks B     ] =kde-base/kdebase-3.4* (is blocking kde-base/kcminit-3.4.1)
[blocks B     ] =kde-base/kdebase-3.4* (is blocking kde-base/khelpcenter-3.4.2)
[blocks B     ] =kde-base/kdebase-3.4* (is blocking kde-base/kcontrol-3.4.2)
[blocks B     ] =kde-base/kdebase-3.4* (is blocking kde-base/kdebase-data-3.4.2)
[blocks B     ] =kde-base/kdebase-3.4* (is blocking kde-base/kdialog-3.4.1)
[blocks B     ] =kde-base/kdebase-3.4* (is blocking kde-base/kdebase-kioslaves-3.4.2)
[blocks B     ] =kde-base/kdebase-3.4* (is blocking kde-base/kdm-3.4.2)
[ebuild     U ] sys-apps/file-4.15 [4.13]
[ebuild     U ] x11-libs/gtk+-2.6.10 [2.6.8]
[ebuild     U ] media-libs/xine-lib-1.1.0-r1 [1.1.0]
[ebuild     U ] sys-apps/baselayout-1.12.0_pre6 [1.12.0_pre5]
[ebuild     U ] dev-util/anjuta-1.2.4 [1.2.2-r1]
[ebuild  N    ] dev-java/cdegroot-db-0.08 
[ebuild  N    ] dev-java/commons-pool-1.2 
[ebuild  N    ] dev-java/commons-dbcp-1.2.1 
[ebuild  NS   ] dev-java/xerces-1.3.1-r1 
[ebuild  N F  ] dev-java/jta-1.0.1 
[ebuild  N    ] dev-java/jss-3.4 
[ebuild  N    ] dev-java/ldapsdk-4.1.7-r1 
[ebuild  N    ] dev-java/gnu-jaxp-1.3 
[ebuild  N    ] dev-java/adaptx-0.9.13_p20041105-r1 
[ebuild  N    ] dev-java/castor-0.9.5.3-r1 
[ebuild  NS   ] dev-java/xerces-2.3.0-r1 
[ebuild  N    ] dev-java/concurrent-util-1.3.4 
[ebuild  N    ] dev-java/jdbm-0.12 
[ebuild  N    ] dev-db/hsqldb-1.7.3.1-r1 
[ebuild  N F  ] dev-java/jms-1.1 
[ebuild  N    ] dev-java/exolabtools-1.0_p20050205 
[ebuild  N    ] dev-java/exolabcore-0.3.7_p20050205 
[ebuild  N    ] dev-java/openjms-0.7.6.1 
[ebuild  N    ] dev-java/openjms-bin-0.7.6 
[ebuild     U ] dev-java/log4j-1.2.11 [1.2.9]
[ebuild     U ] media-video/xine-ui-0.99.4-r2 [0.99.4-r1]
[ebuild     U ] www-client/opera-8.02 [8.00]
[ebuild  N    ] kde-base/kdebase-3.4.2-r1 
root@localhost:~

now i can unmerge all of them except the kdebase one, which i get this error when doing it
Code:
root@localhost:~ emerge -C kdebase

--- Couldn't find kdebase to unmerge.

>>> unmerge: No packages selected for removal.
can anyone help me figure this out so i can finish updating. thank you
_________________
Thou shalt NEVER speak of removing thine Linux
Back to top
View user's profile Send private message
UncleOwen
Veteran
Veteran


Joined: 27 Feb 2003
Posts: 1493
Location: Germany, Hamburg

PostPosted: Mon Aug 22, 2005 10:43 pm    Post subject: Reply with quote

add --tree to your emerge, to see what pulls kdebase in.
Back to top
View user's profile Send private message
sinisterdomestik
l33t
l33t


Joined: 28 Aug 2003
Posts: 683
Location: Texas

PostPosted: Mon Aug 22, 2005 10:46 pm    Post subject: Reply with quote

Code:
root@localhost:~ emerge -uDtp world

These are the packages that I would merge, in reverse order:

Calculating world dependencies ...done!
[blocks B     ] =kde-base/kdebase-3.4* (is blocking kde-base/kdm-3.4.2)
[blocks B     ] =kde-base/kdebase-3.4* (is blocking kde-base/kdebase-kioslaves-3.4.2)
[blocks B     ] =kde-base/kdebase-3.4* (is blocking kde-base/kdialog-3.4.1)
[blocks B     ] =kde-base/kdebase-3.4* (is blocking kde-base/kdebase-data-3.4.2)
[blocks B     ] =kde-base/kdebase-3.4* (is blocking kde-base/kcontrol-3.4.2)
[blocks B     ] =kde-base/kdebase-3.4* (is blocking kde-base/khelpcenter-3.4.2)
[blocks B     ] =kde-base/kdebase-3.4* (is blocking kde-base/kcminit-3.4.1)
[blocks B     ] =kde-base/kdebase-3.4* (is blocking kde-base/khotkeys-3.4.2)
[blocks B     ] =kde-base/kdebase-3.4* (is blocking kde-base/kdesu-3.4.1)
[blocks B     ] =kde-base/kdebase-3.4* (is blocking kde-base/libkonq-3.4.2)
[blocks B     ] =kde-base/kdebase-3.4* (is blocking kde-base/konqueror-3.4.2-r1)
[blocks B     ] =kde-base/kdm-3.4* (is blocking kde-base/kdebase-3.4.2-r1)
[blocks B     ] =kde-base/kdesu-3.4* (is blocking kde-base/kdebase-3.4.2-r1)
[blocks B     ] =kde-base/kcminit-3.4* (is blocking kde-base/kdebase-3.4.2-r1)
[blocks B     ] =kde-base/kdebase-data-3.4* (is blocking kde-base/kdebase-3.4.2-r1)
[blocks B     ] =kde-base/khelpcenter-3.4* (is blocking kde-base/kdebase-3.4.2-r1)
[blocks B     ] =kde-base/khotkeys-3.4* (is blocking kde-base/kdebase-3.4.2-r1)
[ebuild     U ] sys-fs/udev-068 [067]
[ebuild     U ] sys-boot/grub-0.97 [0.96-r3]
[nomerge      ] kde-base/kdm-3.4.2 
[nomerge      ] media-sound/amarok-1.3 
[ebuild  N    ]  kde-base/konqueror-3.4.2-r1 
[ebuild  N    ]   kde-base/kdebase-kioslaves-3.4.2 
[ebuild  N    ]    kde-base/kdialog-3.4.1 
[ebuild  N    ]   kde-base/kcontrol-3.4.2 
[nomerge      ]    kde-base/kdebase-data-3.4.2 
[nomerge      ]    kde-base/khelpcenter-3.4.2 
[nomerge      ]    kde-base/kcminit-3.4.1 
[nomerge      ]    kde-base/khotkeys-3.4.2 
[nomerge      ]    kde-base/kdesu-3.4.1 
[ebuild  N    ]   kde-base/libkonq-3.4.2 
[nomerge      ]  kde-base/kdemultimedia-3.4.2 
[ebuild  N    ]   kde-base/kdebase-3.4.2-r1 
[ebuild     U ] www-client/opera-8.02 [8.00]
[ebuild     U ] media-video/xine-ui-0.99.4-r2 [0.99.4-r1]
[nomerge      ] net-p2p/azureus-2.2.0.0-r1 
[nomerge      ]  dev-java/commons-cli-1.0-r4 
[nomerge      ]   dev-java/ant-1.6.5 
[nomerge      ]    dev-java/ant-tasks-1.6.5 
[nomerge      ]     dev-java/commons-logging-1.0.4-r1 
[ebuild     U ]      dev-java/log4j-1.2.11 [1.2.9]
[ebuild  N    ]       dev-java/openjms-bin-0.7.6 
[ebuild  N    ]       dev-java/openjms-0.7.6.1 
[ebuild  N    ]        dev-java/exolabcore-0.3.7_p20050205 
[ebuild  N    ]         dev-java/exolabtools-1.0_p20050205 
[ebuild  N F  ]        dev-java/jms-1.1 
[ebuild  N    ]        dev-db/hsqldb-1.7.3.1-r1 
[ebuild  N    ]        dev-java/jdbm-0.12 
[ebuild  N    ]        dev-java/concurrent-util-1.3.4 
[ebuild  NS   ]        dev-java/xerces-2.3.0-r1 
[ebuild  N    ]        dev-java/castor-0.9.5.3-r1 
[ebuild  N    ]         dev-java/adaptx-0.9.13_p20041105-r1 
[ebuild  N    ]          dev-java/gnu-jaxp-1.3 
[ebuild  N    ]         dev-java/ldapsdk-4.1.7-r1 
[ebuild  N    ]          dev-java/jss-3.4 
[ebuild  N F  ]         dev-java/jta-1.0.1 
[ebuild  NS   ]         dev-java/xerces-1.3.1-r1 
[ebuild  N    ]        dev-java/commons-dbcp-1.2.1 
[ebuild  N    ]        dev-java/commons-pool-1.2 
[ebuild  N    ]        dev-java/cdegroot-db-0.08 
[ebuild     U ] dev-util/anjuta-1.2.4 [1.2.2-r1]
[nomerge      ] net-wireless/ndiswrapper-1.2 
[nomerge      ]  net-wireless/wireless-tools-28_pre8-r1 
[ebuild     U ]   sys-apps/baselayout-1.12.0_pre6 [1.12.0_pre5]
[nomerge      ] media-gfx/pornview-0.2.0_pre1 
[ebuild     U ]  media-libs/xine-lib-1.1.0-r1 [1.1.0]
[nomerge      ] x11-misc/xscreensaver-4.22-r4 
[ebuild     U ]  x11-libs/gtk+-2.6.10 [2.6.8]
[nomerge      ] x11-terms/xterm-204 
[nomerge      ]  sys-apps/utempter-0.5.5.6 
[nomerge      ]   app-arch/rpm2targz-9.0-r3 
[ebuild     U ]    sys-apps/file-4.15 [4.13]
root@localhost:~

_________________
Thou shalt NEVER speak of removing thine Linux
Back to top
View user's profile Send private message
UncleOwen
Veteran
Veteran


Joined: 27 Feb 2003
Posts: 1493
Location: Germany, Hamburg

PostPosted: Mon Aug 22, 2005 10:57 pm    Post subject: Reply with quote

Try emerge --oneshot kde-base/kdemultimedia-arts kde-base/akode.
Back to top
View user's profile Send private message
sinisterdomestik
l33t
l33t


Joined: 28 Aug 2003
Posts: 683
Location: Texas

PostPosted: Mon Aug 22, 2005 11:19 pm    Post subject: Reply with quote

Code:
root@localhost:~ emerge --oneshot kde-base/kdemultimedia-arts kde-base/akode
Calculating dependencies ...done!

!!! Error: the =kde-base/kdemultimedia-3.4* package conflicts with another package.
!!!        both can't be installed on the same system together.
!!!        Please use 'emerge --pretend' to determine blockers.
should i unmerge all the packages i can and try again??

/EDIT

for what its worth, i have kde-base/kde* masked and the only kde app i want emerged is kdm, i dont know how that will work or affect the situation, but theres a tidbit
_________________
Thou shalt NEVER speak of removing thine Linux
Back to top
View user's profile Send private message
UncleOwen
Veteran
Veteran


Joined: 27 Feb 2003
Posts: 1493
Location: Germany, Hamburg

PostPosted: Tue Aug 23, 2005 12:05 am    Post subject: Reply with quote

Do you have kdemultimedia installed? If so, unmerge it.
Back to top
View user's profile Send private message
sinisterdomestik
l33t
l33t


Joined: 28 Aug 2003
Posts: 683
Location: Texas

PostPosted: Tue Aug 23, 2005 1:13 am    Post subject: Reply with quote

wow, that fixed it. if you wouldnt mind telling me HOW you figured that out. thank you
_________________
Thou shalt NEVER speak of removing thine Linux
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Mon Sep 05, 2005 8:44 am    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads in favour of Blockers in KDE 3.4.1
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum