Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Mounting read-only NFTS Partition
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Conway
n00b
n00b


Joined: 18 Aug 2005
Posts: 28

PostPosted: Sat Aug 27, 2005 4:32 am    Post subject: Mounting read-only NFTS Partition Reply with quote

I've read a few posts and noticed that everyone says not to mount an NTFS partition writable. Ok. I still need it read-only. Can someone show me their fstab file for this. Also, any USE variables that I need to 'use'? I'm pretty sure I didn't compile anything with the NTFS use flag. Do I need to do an

emerge --update --deep --newuse world

if I add this NTFS use flag?

Thank you!
Back to top
View user's profile Send private message
Dlareh
Advocate
Advocate


Joined: 06 Aug 2005
Posts: 2102

PostPosted: Sat Aug 27, 2005 4:39 am    Post subject: Reply with quote

do you have NTFS support in your kernel?

For readonly, just use the "ro" mount option in fstab
_________________
"Mr Thomas Edison has been up on the two previous nights discovering 'a bug' in his phonograph." --Pall Mall Gazette (1889)
Are we THERE yet?
Back to top
View user's profile Send private message
Conway
n00b
n00b


Joined: 18 Aug 2005
Posts: 28

PostPosted: Sat Aug 27, 2005 4:42 am    Post subject: Reply with quote

Not sure. How do I know that? How do I add it?
Back to top
View user's profile Send private message
Dlareh
Advocate
Advocate


Joined: 06 Aug 2005
Posts: 2102

PostPosted: Sat Aug 27, 2005 4:50 am    Post subject: Reply with quote

Conway wrote:
Not sure. How do I know that?

browse around `make menuconfig'
Quote:
How do I add it?

$EDITOR /etc/fstab
_________________
"Mr Thomas Edison has been up on the two previous nights discovering 'a bug' in his phonograph." --Pall Mall Gazette (1889)
Are we THERE yet?
Back to top
View user's profile Send private message
Conway
n00b
n00b


Joined: 18 Aug 2005
Posts: 28

PostPosted: Sat Aug 27, 2005 5:19 am    Post subject: Reply with quote

Compiled in kernel:

Code:
File systems  --->
   DOS/FAT/NT Filesystems  --->
      <*> MSDOS fs support
       <*> VFAT (Windows-95) fs support
        (437) Default codepage for FAT
         (iso8859-1) Default iocharset for FAT
          <*> NTFS file system support
            [*]   NTFS debugging support
           [*]   NTFS write support     


In FSTAB:

Code:
/dev/hda1               /mnt/windoze    ntfs            utf8,user,umask=0110    0 0


not working. Error on bootup.
Back to top
View user's profile Send private message
SinoTech
Advocate
Advocate


Joined: 20 Mar 2004
Posts: 2579
Location: Neunkirchen / Saarland / Germany

PostPosted: Sat Aug 27, 2005 11:55 am    Post subject: Reply with quote

Try to mount the partition from shell and post the errors.

Mfg

Sino
Back to top
View user's profile Send private message
Conway
n00b
n00b


Joined: 18 Aug 2005
Posts: 28

PostPosted: Sat Aug 27, 2005 1:39 pm    Post subject: Reply with quote

Here ya go[/code]

Code:
gentoo steve # mount /mnt/windoze
mount: wrong fs type, bad option, bad superblock on /dev/hda1,
       or too many mounted file systems


Again, here's my fstab:

Code:
/dev/hda1               /mnt/windoze    ntfs            utf8,user,umask=0110    0 0
Back to top
View user's profile Send private message
SinoTech
Advocate
Advocate


Joined: 20 Mar 2004
Posts: 2579
Location: Neunkirchen / Saarland / Germany

PostPosted: Sat Aug 27, 2005 1:57 pm    Post subject: Reply with quote

First you should make sure "hda1" is really your NTFS partition. If it is, try to remove the extra mount options. Try this instead (as root):
Code:

$ mount -t ntfs /dev/hda1 /mnt/windoze

If this works for you, there's something wrong in your additional mount options (utf8,user,umask=...)

Mfg

Sino

EDIT:
Think the problem is the "utf8" switch, since I got the same error message when using it.
Didn't know how to use the UTF stuff with linux. Perhaps it's enough to set "UTF8" in USE-Flags !? Never tried to use it.
Back to top
View user's profile Send private message
jmbsvicetto
Moderator
Moderator


Joined: 27 Apr 2005
Posts: 4734
Location: Angra do Heroísmo (PT)

PostPosted: Sat Aug 27, 2005 2:08 pm    Post subject: Reply with quote

Hi.

You should search the forums before posting! :wink:
Look at the following threads. They should give you some ideas.
https://forums.gentoo.org/viewtopic-t-29285-highlight-mount+ntfs.html
https://forums.gentoo.org/viewtopic-t-367925-highlight-ntfs.html
https://forums.gentoo.org/viewtopic-t-354232-highlight-ntfs.html
_________________
Jorge.

Your twisted, but hopefully friendly daemon.
AMD64 / x86 / Sparc Gentoo
Help answer || emwrap.sh
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Sat Aug 27, 2005 2:31 pm    Post subject: Reply with quote

Moved from Installing Gentoo to Duplicate Threads.
See here instead: https://forums.gentoo.org/viewtopic-t-29285.html
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum