Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Dependency problemen (met xsupplicant) [OPGELOST]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Dutch
View previous topic :: View next topic  
Author Message
Z_God
n00b
n00b


Joined: 14 Dec 2004
Posts: 15
Location: Netherlands

PostPosted: Sun Aug 28, 2005 6:07 pm    Post subject: Dependency problemen (met xsupplicant) [OPGELOST] Reply with quote

Om WIFI te kunnen gebruiken heb ik xsupplicant nodig. Deze had ik ge-emerged en geinstalleerd en hij werkte helemaal.
Op een gegeven moment heb ik echter Gentoo een paar keer geupdate (en een keer overbodige libs weg laten gooien) waarna xsupplicant opeens niet meer blijkt te werken. Hij klaagde eerst over libpcap, die heb ik nu met de hand ge-emerged, maar nu klaagt hij over libdnet.so.0. 'emgere libdnet' lijkt deze niet op te leveren.
Ik begrijp niet helemaal hoe het kan dat Gentoo dependencies uit het oog verliest, ik dacht dat emerge die wel bijhield.

Kan iemand zeggen wat het handigst is om dit probleem op te lossen?

Alvast bedankt,
Z


Last edited by Z_God on Mon Sep 05, 2005 1:42 pm; edited 1 time in total
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Sun Aug 28, 2005 6:20 pm    Post subject: Reply with quote

probeer revdep-rebuild eens.
Overbodige libs weggooien is vrij gevaarlijk. Soms blijken die dus toch niet overbodig te zijn. Altijd revdep-rebuild runnen als je zoiets doet dus.
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
wim-x
Tux's lil' helper
Tux's lil' helper


Joined: 26 Nov 2004
Posts: 109
Location: Netherlands

PostPosted: Thu Sep 01, 2005 6:35 pm    Post subject: Reply with quote

Het zou kunnen zijn dat je een nieuwere versie van libdnet.so.0 hebt en dat xsupplicant nog steeds naar de oude versie wil wijzen. Dit heb ik vaker meegemaakt met Gentoo. De oplossing was in alle gevallen vrij simpel: Zoeken naar de nieuwe versie en een symlink maken voor de door het programma gevraagde versie.

Ik gebruik zelf trouwens geen xsupplicant maar wpa_supplicant. Deze werkte een stuk eenvoudiger.
Back to top
View user's profile Send private message
VeXocide
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jul 2004
Posts: 131
Location: Netherlands, the

PostPosted: Mon Sep 05, 2005 1:35 pm    Post subject: Reply with quote

Kun je me eens vertellen welke versie xsupplicant je hebt gebruikt, en hoe je heb aan de praat hebt gekregen (config file) want hier op de TU/e heb ik 'm ook nodig maar 't lukt me niet, het is een combinatie van PEAP en mschap2 dat hier gebruikt wordt.
Back to top
View user's profile Send private message
Z_God
n00b
n00b


Joined: 14 Dec 2004
Posts: 15
Location: Netherlands

PostPosted: Mon Sep 05, 2005 1:42 pm    Post subject: Reply with quote

OK, het probleem is opgelost.
Na het installeren van die tools en het draaien van revdep-rebuild, zag ik dat ie gemasked was en dat het daardoor niet werkte. Na het unmasken heb ik de nieuwste versie geprobeerd, maar die kreeg ik niet aan de praat. Ik heb ook nog wpa_supplicant geprobeerd, maar die kreeg ik ook niet aan de praat.
Uiteindelijk heb ik 0.8b weer geïnstalleerd en die werkte zonder problemen met m'n oude config :)

>VeXocide
Geen idee of ik je kan helpen, maar dit is in ieder geval de config die ik gebruik:
http://haar.student.utwente.nl/~julius/wl-etc.tar.bz2
Ik gebruik dus xsupplicant 0.8b. De hardware die ik gebruik is overigens een Hermes II PCMCIA kaart. Hij werkt met de wlags driver van Agere in 2.4 kernels.
Back to top
View user's profile Send private message
VeXocide
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jul 2004
Posts: 131
Location: Netherlands, the

PostPosted: Tue Sep 06, 2005 7:19 pm    Post subject: Reply with quote

Z_God, bedankt. Ik gebruik op het moment xsupplicant 1.21 (nog niet in portage, wel op sourceforge, verder ga ik ook 0.8b terugzetten (de 1. versies compilede niet op m'n bak). En dan eens met die config prutsen. Ben benieuwd of ik iets werkende krijg, maar toch.

Vx
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Dutch All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum