Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
solved_not syncing vfs: unable to mount root fs
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
kasemodz
n00b
n00b


Joined: 12 Aug 2005
Posts: 59

PostPosted: Tue Aug 30, 2005 5:50 am    Post subject: solved_not syncing vfs: unable to mount root fs Reply with quote

not syncing vfs: unable to mount root fs on unknown-block(0,0)
rebooting in 180seconds

I just installed gentoo stage 3 on my ibook 500 mhz g3. I get stuck here with the top error. Here is my config file.
http://www.geocities.com/sharadshankar/config-2.6.12-gentoo-r6.txt

Here is my fstab file
http://www.geocities.com/sharadshankar/fstab.txt

Here is my yaboot.conf file
http://www.geocities.com/sharadshankar/yaboot.conf.txt

What should i do?


Last edited by kasemodz on Thu Sep 01, 2005 1:41 am; edited 1 time in total
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Tue Aug 30, 2005 1:19 pm    Post subject: Reply with quote

Most likely is that you either do not have ATA Disk support or that you're missing Apple partition support. Check your kernel configuration.

Good luck!
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
kasemodz
n00b
n00b


Joined: 12 Aug 2005
Posts: 59

PostPosted: Tue Aug 30, 2005 2:10 pm    Post subject: Reply with quote

i think forogt to enable this feaure on kernel. Should this fix the problem?
Code:
# CONFIG_BLK_DEV_IDEDISK is not set
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Tue Aug 30, 2005 2:43 pm    Post subject: Reply with quote

Yep. You're not going to get data read off of an IDE hard disk if you don't have IDE hard disk support built in. :)
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
kasemodz
n00b
n00b


Joined: 12 Aug 2005
Posts: 59

PostPosted: Tue Aug 30, 2005 4:02 pm    Post subject: Reply with quote

ok so i just do menuconfig and select then install it in chroot right? Nothing else? I dont have reinstall everything else after I recompile the kernel right?
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Tue Aug 30, 2005 4:06 pm    Post subject: Reply with quote

Don't forget to copy the kernel to /boot
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
kasemodz
n00b
n00b


Joined: 12 Aug 2005
Posts: 59

PostPosted: Tue Aug 30, 2005 9:57 pm    Post subject: Reply with quote

alright i tried enabling that and compiling the kernel copying it but still get the same error. Can someone please check my kernel config ide configuration. I think thats where I get the problem.
Back to top
View user's profile Send private message
btlee
Apprentice
Apprentice


Joined: 03 Sep 2004
Posts: 168
Location: San Francisco

PostPosted: Tue Aug 30, 2005 10:56 pm    Post subject: Reply with quote

set followings to y

CONFIG_BLK_DEV_IDEDISK
CONFIG_IDEDMA_PCI_AUTO
CONFIG_BLK_DEV_IDE_PMAC
CONFIG_BLK_DEV_IDEDMA_PMAC
CONFIG_BLK_DEV_IDE_PMAC_BLINK

set following to n

CONFIG_IDE_GENERIC

regards,
_________________
AMD64 3200+, 2G/160G+250G
DELL 700m, 1.8GHz, 2G/80G
iBook G3-500Mhz, 640M/100G
Back to top
View user's profile Send private message
kasemodz
n00b
n00b


Joined: 12 Aug 2005
Posts: 59

PostPosted: Wed Aug 31, 2005 3:57 pm    Post subject: Reply with quote

ok i got it working but now the keyboard doesnt work on bootup. There is one thing you have to enable but I don't remember for ibooks. Can you anyone tell me quick?
Back to top
View user's profile Send private message
btlee
Apprentice
Apprentice


Joined: 03 Sep 2004
Posts: 168
Location: San Francisco

PostPosted: Thu Sep 01, 2005 12:24 am    Post subject: Reply with quote

multiple questions in one thread.
above all, change the title of this thread into [solved]
and then post your other questions into another thread.
_________________
AMD64 3200+, 2G/160G+250G
DELL 700m, 1.8GHz, 2G/80G
iBook G3-500Mhz, 640M/100G
Back to top
View user's profile Send private message
kasemodz
n00b
n00b


Joined: 12 Aug 2005
Posts: 59

PostPosted: Thu Sep 01, 2005 1:40 am    Post subject: ok solved Reply with quote

thx
Back to top
View user's profile Send private message
soujirou
Apprentice
Apprentice


Joined: 22 Jun 2004
Posts: 205
Location: sweden

PostPosted: Fri Sep 02, 2005 7:14 pm    Post subject: hum! Reply with quote

hi, got the same problem but with kernel 2.6.12-gentoo-r9
my config file doesent look the same, i mean i dont have thoose
"CONFIG_BLK_DEV_IDEDISK
CONFIG_IDEDMA_PCI_AUTO
CONFIG_BLK_DEV_IDE_PMAC
CONFIG_BLK_DEV_IDEDMA_PMAC
CONFIG_BLK_DEV_IDE_PMAC_BLINK"

and where in kernel do i find the "Mac Partition types" ??

help =)
_________________
ibook 12" G3 800mhz 30gb 384ram
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum