Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Alsa kernel configuration won't work on a powerbook 15"
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
djst33l
n00b
n00b


Joined: 13 May 2005
Posts: 24
Location: Chicago

PostPosted: Tue Aug 30, 2005 8:54 pm    Post subject: Alsa kernel configuration won't work on a powerbook 15" Reply with quote

HELP ME! For the past month or so, on and off, I have been tweaking about with my kernel trying to get ALSA to work. I have a 15-inch powerbook 1GHz and have (at least I thought) followed all the instructions I could find anywhere. So now, at the pinnacle of my own desperation, I ask you, the gentoo linux community, humbly for help. Please? Someone?

Starting with a fresh copy of the gentoo sources 2.6.12-r9 I can't even get it to boot up at all. It doesn't get past the black-on-white screen immediately after yaboot.

Thanks in advance for any help I receive.

- m a x
Back to top
View user's profile Send private message
kiwi_uk
n00b
n00b


Joined: 28 Aug 2005
Posts: 59
Location: Leicester, UK

PostPosted: Tue Aug 30, 2005 9:10 pm    Post subject: Reply with quote

Regarding the blank screen, it sounds like you might have not selected a framebuffer driver that is needed. I suggest you go into Device Drivers -> Graphical bits (that's not the right name, but its like that) and have a good look.

Disabling frambuffer support altogether and just having a VGA console might be a good start if this is that case.

Jon

ps I don't use a Mac. Everything I say is BS.


Last edited by kiwi_uk on Wed Aug 31, 2005 7:37 am; edited 1 time in total
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7694
Location: Pelotas, BR

PostPosted: Tue Aug 30, 2005 9:50 pm    Post subject: Reply with quote

Moved from Multimedia.
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Wed Aug 31, 2005 12:47 am    Post subject: Reply with quote

The advice above regarding the FB is close, you'll need to *always* have the correct framebuffer device on PPC, otherwise it won't boot. You probably have a radeon so make sure that you have radeonfb compiled into the kernel. As for your ALSA issues, unless you can be more specific (What have you tried? What isn't working?) the best I can do is point you to the PPC FAQ.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum