Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Groff Blocking Manpage Installation
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Kenji Miyamoto
Veteran
Veteran


Joined: 28 May 2005
Posts: 1452
Location: Looking over your shoulder.

PostPosted: Sat Sep 03, 2005 9:24 pm    Post subject: Groff Blocking Manpage Installation Reply with quote

I'm at the "emerge -e system" step, and the merging of Groff is blocking the installation of the Japanese manpages, which I really could use. How do I fix this error?
Back to top
View user's profile Send private message
FreeFly42
l33t
l33t


Joined: 03 Nov 2003
Posts: 848
Location: Houston, TX

PostPosted: Sun Sep 04, 2005 1:39 am    Post subject: Reply with quote

/usr/portage/app-i18n/man-pages-ja/man-pages-ja-20050415.ebuild wrote:
DEPEND="!>=sys-apps/groff-1.19
=sys-apps/groff-1.18*
sys-apps/man"

It looks like groff-1.18.1-r4 is ok with man-pages-ja-20050415, so you should be able to do something like:
Code:
echo ">=sys-apps/groff-1.19.1-r2" >> /etc/portage/package.mask
emerge -uav groff  (this will revert you to 1.18)
emerge -uav man-pages-ja


man portage wrote:
package.mask
A list of DEPEND atoms to mask. Useful if specific ver-
sions of packages do not work well for you. For example,
you swear by the Nvidia drivers, but only versions ear-
lier than 1.0.4496. No problem!

Format:
- comments begin with #
- one DEPEND atom per line

Example:
# mask out versions 1.0.4496 of the nvidia
# drivers and later
>=media-video/nvidia-kernel-1.0.4496
>=media-video/nvidia-glx-1.0.4496

_________________
Kent

Planes are dangerous, get out of 'em quick
Back to top
View user's profile Send private message
Sefthuko
n00b
n00b


Joined: 11 Jun 2003
Posts: 64

PostPosted: Wed Sep 14, 2005 8:55 am    Post subject: Reply with quote

I had the same problem, and this did help. Thanks a lot!

This might be naive of me, but if the solution here is to block the latest groff package, why isn't it masked in the first place? Surely there are a lot of people that like to have japanese man pages out there.
Back to top
View user's profile Send private message
FreeFly42
l33t
l33t


Joined: 03 Nov 2003
Posts: 848
Location: Houston, TX

PostPosted: Wed Sep 14, 2005 4:06 pm    Post subject: Reply with quote

Just a guess (don't be offended) in the grand scheme of things the japanese users are probably not a large percentage of Gentoo users and the blocking mechanism works pretty well for alerting you to what you need to do to get around it.

But I'd suggest filing a report at bugs.gentoo.org.
_________________
Kent

Planes are dangerous, get out of 'em quick
Back to top
View user's profile Send private message
libero
Tux's lil' helper
Tux's lil' helper


Joined: 26 Mar 2004
Posts: 86
Location: Tokyo

PostPosted: Fri Nov 04, 2005 12:43 pm    Post subject: check LINGUAS Reply with quote

hi,

I have been planning my upgrade to 2005.1 profile
I also noticed this block in portage, and searched to find your post.

Then researched some more and have some new findings to add.

In /etc/make.conf there is another setting "LINGUAS" which is commented like this:
Quote:
# languages for kde-i18n

I'm not sure if those are my comments or they came some other way. I guess I added them when I added the LINGUAS config setting.

I tried
Code:
emerge -p -v --newuse -D system
with different values for the "LINGUAS" setting, and got different results. When LINGUAS included "en ja" together, I ran into the groff blocking issue. When I removed "ja" and had only "en" value, there was no groff blocking issue.

I'm kind of interested in kde-i18n so I suppose I will try to follow instructions and emerge the lower version of groff, so I get the man-pages-ja properly. I do fine with English though, so if I find more issues and blockages because of including "ja" in LINGUAS, I think I would rather just remove it.
Back to top
View user's profile Send private message
Horatio
Apprentice
Apprentice


Joined: 25 Feb 2004
Posts: 246
Location: Houston, TX

PostPosted: Mon Dec 05, 2005 10:28 am    Post subject: asian fonts man-pages acroread Reply with quote

I agree with libero. For english readers the LINGUAS variable in make.conf was the culprit. Before when LINGUAS contained different asian values I had problems emerging man-pages:
Code:

# emerge -pv man-pages

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild   R   ] sys-apps/man-pages-2.14  +nls 0 kB
[ebuild  N    ] app-i18n/man-pages-ja-20041115  0 kB

Total size of downloads: 0 kB
# USE="-nls" emerge -pv man-pages

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild   R   ] sys-apps/man-pages-2.14  -nls* 0 kB

Total size of downloads: 0 kB
#


Then I changed it to only contain only "en" and now man-pages looks as though it will emerge w/o problem:
Code:

# emerge -pv man-pages

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild   R   ] sys-apps/man-pages-2.14  +nls 0 kB

Total size of downloads: 0 kB
#


Setting the LINGUAS to "en" also allowed me to install the correct ENGLISH acroread.

Thank you much libero.
Back to top
View user's profile Send private message
pizzach
Apprentice
Apprentice


Joined: 28 Aug 2006
Posts: 195

PostPosted: Sun Sep 24, 2006 2:09 am    Post subject: Reply with quote

There has to be a better option than this.

1. I block the new version of groff because I don't care if I have the newest version. But my man pages are now totally unreadable. Got some moji bake going on. This is less useful than having english.

2. I try blocking the Japanese man pages....I just don't know how. I tried blocking with /etc/package.mask but emerge throws a hissy fit now when I try to update.

3. I tried switching my LINGUAS to only "ja", but I have the same problems. If I use "en" then firefox and openoffice are compiled with English only. I will settle for english man pages, but not English programs.


So.....have I not tried something? :cry:
Back to top
View user's profile Send private message
ihateusernames
n00b
n00b


Joined: 26 Sep 2006
Posts: 1

PostPosted: Tue Sep 26, 2006 2:47 am    Post subject: Reply with quote

I was having the same problem (I have a solution of sorts for people who don't particularly care about the man-pages-ja package at the bottom of the post), and it seems that matters are a lot worse than they were when this thread was started.

Masking ">=sys-apps/groff-1.19" doesn't help; in fact, should it not work without user intervention because of the "!>=sys-apps/groff-1.19" line in the ebuild?

Emerging groff first doesn't help; you just get a more interesting blocking message (which I'd quote if I felt like switching my groff version yet again just to get this information; adding "ja" to your LINGUAS variable in make.conf should be enough to reproduce it).

Nothing else in the merge seems to depend on >=sys-apps-groff=1.19, so why is portage insisting on it?

My "solution" is to add this line to /etc/portage/package.use:

Code:
sys-apps/man-pages   -linguas_ja


Amusingly, this still results in a downgrade to groff-1.18.1.1.

Also, a modified man-pages-ja ebuild with the "!>=sys-apps/groff-1.19" line in DEPEND works perfectly. I don't pretend to understand the precise workings of portage, but whoever maintains the package should; has this simply not been tested?
Back to top
View user's profile Send private message
pizzach
Apprentice
Apprentice


Joined: 28 Aug 2006
Posts: 195

PostPosted: Tue Sep 26, 2006 1:21 pm    Post subject: Reply with quote

ihateusernames wrote:
Also, a modified man-pages-ja ebuild with the "!>=sys-apps/groff-1.19" line in DEPEND works perfectly. I don't pretend to understand the precise workings of portage, but whoever maintains the package should; has this simply not been tested?



Agreed. I ended up realizing, I could get the same effect by turning off nls on the man-pages with less compiling. "sys-apps/man-pages -nls" I didn't have luck with "sys-apps/man-pages -linguas_ja" but I may have misspelled something or something.

I appreciate the help ihateusernames. It got my past my block. When I feel like trying to rebuild groff again, I amy try the above line. I was using ">=sys-apps/groff-1.19.1-r2" when all of the man text was funky characters.
Back to top
View user's profile Send private message
Un.tot
n00b
n00b


Joined: 16 Mar 2006
Posts: 55
Location: Hannover, Germany

PostPosted: Mon Nov 27, 2006 8:09 pm    Post subject: Reply with quote

For me the line in package.use works great. Thanks a lot ! :D
_________________
Currently running gentoo on
Toshiba Tecra R840-109 and one Desktop-PC
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum