Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
PHP5 wants to downgrade to 4.4.0 instead of update to 5.1.0
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Dizzutch
Guru
Guru


Joined: 09 Nov 2004
Posts: 463
Location: Worcester, MA

PostPosted: Mon Sep 05, 2005 2:24 pm    Post subject: PHP5 wants to downgrade to 4.4.0 instead of update to 5.1.0 Reply with quote

All,
I have php5 unmasked in /etc/portage/package.unmask with
Code:

>=dev-php/php-5.0.4
>=dev-php/mod_php-5.0.4
>=dev-php/PEAR-PEAR-1.3.5-r1

in /etc/make.conf i have
Code:

ACCEPT_KEYWORDS=~x86

everything was running fine until yesterday i did a sync && -auD world and I got this
Code:

[ebuild     UD] dev-php/php-4.4.0 [5.1.0_beta-r2]
[ebuild  NS   ] dev-php/mod_php-4.4.0-r1 

not sure what's going on, any ideas?
Thanks
-Dizz
Back to top
View user's profile Send private message
DaNIsH
Apprentice
Apprentice


Joined: 01 Jan 2003
Posts: 197
Location: Melbourne, Australia.

PostPosted: Mon Sep 05, 2005 2:31 pm    Post subject: Reply with quote

Also having this problem.. seems they've removed the ebuilds for later PHP versions?
Code:
danish@stan /usr/portage/dev-php/php $ ls -1 *.ebuild
php-4.3.11.ebuild
php-4.4.0.ebuild


Strange.

EDIT: I just synced 30 mins ago, maybe it was a bodgy mirror? Having some other strange problems.
Will resync soon and see how it goes.
_________________
Adopt an unanswered post today


Last edited by DaNIsH on Mon Sep 05, 2005 2:33 pm; edited 1 time in total
Back to top
View user's profile Send private message
Dizzutch
Guru
Guru


Joined: 09 Nov 2004
Posts: 463
Location: Worcester, MA

PostPosted: Mon Sep 05, 2005 2:33 pm    Post subject: Reply with quote

maybe if we wait it out it'll fix itself..:)
Back to top
View user's profile Send private message
llongi
Retired Dev
Retired Dev


Joined: 15 Apr 2004
Posts: 459
Location: Switzerland

PostPosted: Mon Sep 05, 2005 2:48 pm    Post subject: Reply with quote

The old PHP packages for php5 were indeed removed, the announcement was all over the place. ;) For more info, the following links:

GWN - Simultaneous PHP4/PHP5 support in Gentoo
Posting on gentoo-dev ML: Packages for mixed PHP4/PHP5 environment added to Portage
Planet Gentoo: PHP Overlay Packages Now In Portage
Gentoo Forums post: Packages for mixed PHP4/PHP5 environment added to Portage

Documentation from the Gentoo PHP Overlay project page:

Upgrade HOWTO: http://svn.gnqs.org/projects/gentoo-php-overlay/wiki/HowToUpgrade
FAQ: http://svn.gnqs.org/projects/gentoo-php-overlay/wiki/CommonQuestions
Retiring the old packages: http://svn.gnqs.org/projects/gentoo-php-overlay/wiki/RetiringTheOldPackages
_________________
Best regards, Luca.
Back to top
View user's profile Send private message
tomk
Bodhisattva
Bodhisattva


Joined: 23 Sep 2003
Posts: 7221
Location: Sat in front of my computer

PostPosted: Mon Sep 05, 2005 2:52 pm    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads, please follow up to this sticky topic.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum