Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
error during compiling Qt
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
nardew
Tux's lil' helper
Tux's lil' helper


Joined: 27 Aug 2005
Posts: 93

PostPosted: Wed Sep 07, 2005 6:23 pm    Post subject: error during compiling Qt Reply with quote

i want to compile Qt and then install KDE. but when i used emerge Qt with all the suitable flags, compilation after a while ends with message Segmentation fault. Can you tell why it is happening?

thnx
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Wed Sep 07, 2005 6:26 pm    Post subject: Reply with quote

Segfaults usually are caused by: incorrect/agressive cflags or damaged hardware.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
nardew
Tux's lil' helper
Tux's lil' helper


Joined: 27 Aug 2005
Posts: 93

PostPosted: Wed Sep 07, 2005 7:09 pm    Post subject: Reply with quote

thnx a lot :) i remove -pipe flag from cflags and it runs. :)
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Wed Sep 07, 2005 7:18 pm    Post subject: Reply with quote

Uhmm! Sorry to say, but I, really, dont think that your problem is in -pipe, this is from the gcc man page:

Code:

       -pipe
           Use pipes rather than temporary files for communication between the
           various stages of compilation.  This fails to work on some systems
           where the assembler is unable to read from a pipe; but the GNU
           assembler has no trouble.


Translated: -pipe makes the gcc compiler use pipes instead of passing the data from one process to another by writing on files. That speeds up the compilation procces, but has no other secondary effect other than that. It would be the first time that I have notice of -pipe causing any trouble.

If you changed no other flag, then Im inclined to think that your problem was (and probably still is) in your hardware (so, sometimes fails and sometimes does not, maybe depending on your cpu temperature or casual memory I/O errors). Of course, only the time can confirm that.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Wed Sep 07, 2005 7:26 pm    Post subject: Reply with quote

Moved from Installing Gentoo to Duplicate Threads.
See https://forums.gentoo.org/viewtopic-t-343118.html for example.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum