Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kde-base/kdemultimedia-3.4.2 failed to emerge
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
firex
Tux's lil' helper
Tux's lil' helper


Joined: 05 Jan 2004
Posts: 145
Location: Hamburg

PostPosted: Thu Sep 08, 2005 4:52 pm    Post subject: kde-base/kdemultimedia-3.4.2 failed to emerge Reply with quote

i did tried to emerge kde-base/kdemultimedia-3.4.2 and it's failed with following error message
Code:

make[3]: Entering directory `/var/tmp/portage/kdemultimedia-3.4.2/work/kdemultimedia-3.4.2/doc'
make[3]: Nothing to be done for `all-am'.
make[3]: Leaving directory `/var/tmp/portage/kdemultimedia-3.4.2/work/kdemultimedia-3.4.2/doc'
Making all in artsbuilder
make[3]: Entering directory `/var/tmp/portage/kdemultimedia-3.4.2/work/kdemultimedia-3.4.2/doc/artsbuilder'
/usr/kde/3.4/bin/meinproc --check --cache index.cache.bz2 ./index.docbook
XPath error : Undefined variable
$index.on.role != 0
               ^
compilation error: file /usr/kde/3.4/share/apps/ksgmltools2/docbook/xsl/html/autoidx.xsl line 106 element if
xsl:if : could not compile test expression '$index.on.role != 0'
XPath error : Undefined variable
$index.on.type != 0
               ^
compilation error: file /usr/kde/3.4/share/apps/ksgmltools2/docbook/xsl/html/autoidx.xsl line 112 element if
xsl:if : could not compile test expression '$index.on.type != 0'
XPath error : Undefined variable
compilation error: file /usr/kde/3.4/share/apps/ksgmltools2/docbook/xsl/html/autoidx.xsl line 132 element if
xsl:if : could not compile test expression '$others'
XPath error : Undefined variable
$alphabetical[count(.|key('letter',                                  translate(substring(normalize-space(concat(primary/@sortas, primary[not(@sortas)])), 1, 1),                                            'abcdefghijklmnopqrstuvwxyz','ABCDEFGHIJKLMNOPQRSTUVWXYZ'))[count(ancestor::node()|$scope) = count(ancestor::node())
                and ($role = @role or $type = @type or
                (string-length($role) = 0 and string-length($type) = 0))][1]) = 1]
             ^
compilation error: file /usr/kde/3.4/share/apps/ksgmltools2/docbook/xsl/html/autoidx.xsl line 155 element apply-templates
xsl:apply-templates : could not compile select expression '$alphabetical[count(.|key('letter',                                  translate(substring(normalize-space(concat(primary/@sortas, primary[not(@sortas)])), 1, 1),                                            'abcdefghijklmnopqrstuvwxyz','ABCDEFGHIJKLMNOPQRSTUVWXYZ'))[count(ancestor::node()|$scope) = count(ancestor::node())

and so on ........ many screens of errors. this is the first three error messages.

Code:

$ emerge --info
Portage 2.0.51.22-r2 (default-linux/x86/2005.0, gcc-3.4.4, glibc-2.3.5-r1, 2.6.11-gentoo-r6 i686)
=================================================================
System uname: 2.6.11-gentoo-r6 i686 Intel(R) Pentium(R) 4 CPU 2.40GHz
Gentoo Base System version 1.12.0_pre1
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
dev-lang/python:     2.3.5, 2.4.1-r1
sys-apps/sandbox:    1.2.1-r2
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.20
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium4 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=pentium4 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo"
LINGUAS="de en ru"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X acpi alsa apm arts avi berkdb bitmap-fonts crypt cups curl dba dvdread eds emboss encode esd f77 fam fbcon flac foomaticdb fortran gd gd-external gdbm gif gnome gpm gstreamer gtk gtk2 guile imagemagick imlib ipv6 java jpeg junit kde libg++ libwww mad mikmod mmx motif mp3 mpeg ncurses nls ogg oggvorbis opengl oss pam pdflib perl pic png ppds python qt quicktime readline samba sdl slang softmmu spell sse ssl svga tcltk tcpd tiff truetype truetype-fonts type1-fonts vorbis xine xml xml2 xmms xv xvid zlib linguas_de linguas_en linguas_ru userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, MAKEOPTS, PORTDIR_OVERLAY

can anybody help me?
thx
Back to top
View user's profile Send private message
deepwave
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jan 2004
Posts: 122
Location: ONS Insomniac

PostPosted: Fri Sep 09, 2005 1:16 am    Post subject: Reply with quote

Does USE="-doc" emerge kdemultimedia work?
_________________
Current open source project: justCheckers, a cross-platform checkers suite.
Back to top
View user's profile Send private message
firex
Tux's lil' helper
Tux's lil' helper


Joined: 05 Jan 2004
Posts: 145
Location: Hamburg

PostPosted: Fri Sep 09, 2005 9:21 am    Post subject: Reply with quote

no, it's didn't help :-(
and i didn't sure this flag used by kdemultimedia

Code:
emerge -pv kdemultimedia

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild     U ] kde-base/kdemultimedia-3.4.2 [3.4.1-r1] +alsa +arts -audiofile -debug +encode +flac +gstreamer* -jack -kdeenablefinal +mp3 -musicbrainz -speex -theora +vorbis +xine -xinerama 0 kB

Code:
equery uses kdemultimedia
[ Searching for packages matching kdemultimedia... ]
[ Colour Code : set unset ]
[ Legend        : Left column  (U) - USE flags from make.conf                     ]
[                  : Right column (I) - USE flags packages was installed with ]
[ Found these USE variables for kde-base/kdemultimedia-3.4.1-r1 ]
 U I
 + + alsa           : Adds support for media-libs/alsa-lib (Advanced Linux Sound Architecture)
 - - audiofile      : Adds support for libaudiofile where applicable
 + + encode         : Adds support for encoding of audio or video files
 - + flac           : Adds support for the flac audio codec
 + - gstreamer      : Adds support for media-libs/gstreamer (Streaming media)
 - - jack           : Adds support for the JACK Audio Connection Kit
 + + mp3            : Add support for reading mp3 files
 - - speex          : Adds support for the speex audio codec
 - - theora         : Adds support for the Theora Video Compression Codec
 + + vorbis         : Adds support for the OggVorbis audio codec
 - + xine           : Add support for the XINE movie libraries
 - - debug          : Tells configure and the makefiles to build for debugging. Effects vary across packages, but generally it will at least add -g to CFLAGS. Remember to set FEATURES=nostrip too
 + + arts           : Adds support for aRts: the KDE sound daemon
 - - xinerama       : Add support for the xinerama X11 extension, which allows you to stretch your display across multiple monitors
 - - kdeenablefinal : Makes kde ebuilds use the enable-final flag, yielding big compilation speedups at the cost of very heavy mem usage

here it is not exist, but it is information for kdemultimedia-3.4.1-r1
Back to top
View user's profile Send private message
vespaman
Guru
Guru


Joined: 28 Aug 2002
Posts: 309
Location: Stockholm, Sweden

PostPosted: Sun Sep 11, 2005 9:55 am    Post subject: Reply with quote

Any solution to this problem yet?

I have the exact behavior on a number of kde packages, klibido, kaffeine, and just now on kdebluetooth. :cry:

Code:
Making all in kdebluetooth
make[3]: Entering directory `/var/tmp/portage/kdebluetooth-1.0_beta1/work/kdebluetooth-1.0_beta1/doc/kdebluetooth'
/usr/kde/3.4/bin/meinproc --check --cache index.cache.bz2 ./index.docbook
XPath error : Undefined variable
$index.on.role != 0
               ^


.. and then hundreds of rows of similar problems ..

What could this possibly be? I have emerged the latest libgpg-error (1.1) with no change.

- Micael
Back to top
View user's profile Send private message
roland_ke
n00b
n00b


Joined: 28 Sep 2003
Posts: 21
Location: Vienna / Austria

PostPosted: Sun Sep 11, 2005 11:54 am    Post subject: Reply with quote

vespaman wrote:
Any solution to this problem yet?

I have the exact behavior on a number of kde packages, klibido, kaffeine, and just now on kdebluetooth. :cry:

Code:
Making all in kdebluetooth
make[3]: Entering directory `/var/tmp/portage/kdebluetooth-1.0_beta1/work/kdebluetooth-1.0_beta1/doc/kdebluetooth'
/usr/kde/3.4/bin/meinproc --check --cache index.cache.bz2 ./index.docbook
XPath error : Undefined variable
$index.on.role != 0
               ^


.. and then hundreds of rows of similar problems ..

What could this possibly be? I have emerged the latest libgpg-error (1.1) with no change.

- Micael

i got the same problem with amarok (1.3.1), and as it was an XPath error i looked at the version-history of libxml2, an i saw libxml2 (2.6.21) was just updated a few days before.
so i masked libxml2(2.6.21) and switched back to libxml2(2.6.20-r2) and then amarok compiled...

try that, it should help!

greetings from Vienna/Austria,
roland
_________________
don't blame me, it's a hardware problem!
Back to top
View user's profile Send private message
vespaman
Guru
Guru


Joined: 28 Aug 2002
Posts: 309
Location: Stockholm, Sweden

PostPosted: Sun Sep 11, 2005 11:59 am    Post subject: Reply with quote

Thanks!

.. in the meantime, I found a solution, which also seam to work (I am currently compiling 4 out of 5 successfully) by; updating libxslt!

:D Micael
Back to top
View user's profile Send private message
firex
Tux's lil' helper
Tux's lil' helper


Joined: 05 Jan 2004
Posts: 145
Location: Hamburg

PostPosted: Mon Sep 12, 2005 2:08 pm    Post subject: Reply with quote

thanks!

it helps! i did updated libxslt and now i can compile.
Back to top
View user's profile Send private message
mwiertz
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jul 2003
Posts: 88
Location: Selfkant, Germany

PostPosted: Sun Sep 25, 2005 9:05 am    Post subject: Reply with quote

Hi,

same problem here with kregexpeditor-3.4.1-r1 and klibido-0.2.4.1... and unfortunately my libxslt is up to date (1.1.14-r2)
Back to top
View user's profile Send private message
mwiertz
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jul 2003
Posts: 88
Location: Selfkant, Germany

PostPosted: Sun Sep 25, 2005 10:19 am    Post subject: Reply with quote

After re-emerging libxslt I was able to emerge kregexpeditor and klibido without problems again... just to let you know!
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4920
Location: Gothenburg, Sweden

PostPosted: Sun Dec 25, 2005 8:02 pm    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads in favour of [Solved] "XPath error : Undefined variable" ;kaffeine etc.
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum