Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
sound problem!! [solved]
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
soujirou
Apprentice
Apprentice


Joined: 22 Jun 2004
Posts: 205
Location: sweden

PostPosted: Tue Sep 13, 2005 6:23 am    Post subject: Reply with quote

where do i find PNP in kernel ?


got this settings in kernel:

Device Drivers
- sound
<*> Sound Card Support
< > PowerMac DMA support
Advanced Linux Sound Architecture
<M> Advanced Linux Sound Architecture
<M> Sequencer support
<M> Sequencer dummy client
<M> OSS Mixer API
<M> OSS PCM API
[ * ] OSS sequencer API
.....
.....
ALSA PowerMac Devices
<M > Powermac (AWACS, DACA...)
USB Devices
<M> USB Audio/MIDI driver
_________________
ibook 12" G3 800mhz 30gb 384ram
Back to top
View user's profile Send private message
smerf
l33t
l33t


Joined: 06 Nov 2004
Posts: 778
Location: Polska

PostPosted: Tue Sep 13, 2005 6:53 am    Post subject: Reply with quote

Device Drivers ---> Plug and Play support ---> HERE
_________________
Microsoft is not the answer, Microsoft is the question, the answer is no.
Back to top
View user's profile Send private message
soujirou
Apprentice
Apprentice


Joined: 22 Jun 2004
Posts: 205
Location: sweden

PostPosted: Tue Sep 13, 2005 3:14 pm    Post subject: Reply with quote

thnx for helping smerf =)

i try to enter it but i cant get into plugandplaysuport, it just getting me in to main menu all the time.

=(
_________________
ibook 12" G3 800mhz 30gb 384ram
Back to top
View user's profile Send private message
soujirou
Apprentice
Apprentice


Joined: 22 Jun 2004
Posts: 205
Location: sweden

PostPosted: Tue Sep 13, 2005 8:26 pm    Post subject: Reply with quote

added ISA support in kernel then i could add PNP.

now i have installed alsa-driver

./alsasound stop
* Storing ALSA Mixer Levels ...
/usr/sbin/alsactl: save_state:1163: No soundcards found... [ !! ] <-----
* Unloading ALSA ... [ ok ]
* Unloading ALSA modules ... [ ok ]
>_<;
_________________
ibook 12" G3 800mhz 30gb 384ram
Back to top
View user's profile Send private message
smerf
l33t
l33t


Joined: 06 Nov 2004
Posts: 778
Location: Polska

PostPosted: Tue Sep 13, 2005 9:07 pm    Post subject: Reply with quote

ok, one thing: is your sound system working now (with alsa in modules instead of being compiled into the kernel)? working = could you produce sound (despite of inability to change volume etc.)?
_________________
Microsoft is not the answer, Microsoft is the question, the answer is no.
Back to top
View user's profile Send private message
soujirou
Apprentice
Apprentice


Joined: 22 Jun 2004
Posts: 205
Location: sweden

PostPosted: Tue Sep 13, 2005 9:18 pm    Post subject: Reply with quote

nopps no sound =(
_________________
ibook 12" G3 800mhz 30gb 384ram
Back to top
View user's profile Send private message
smerf
l33t
l33t


Joined: 06 Nov 2004
Posts: 778
Location: Polska

PostPosted: Tue Sep 13, 2005 9:25 pm    Post subject: Reply with quote

with hardcompiled drivers there was sound but without ability to use mixer, right? are you sure you're using drivers apropiate to your hardware? (check what have you been using before) try to hardcompile whole alsa stuff (including mixer) - just change <m> to <y>
_________________
Microsoft is not the answer, Microsoft is the question, the answer is no.
Back to top
View user's profile Send private message
soujirou
Apprentice
Apprentice


Joined: 22 Jun 2004
Posts: 205
Location: sweden

PostPosted: Wed Sep 14, 2005 7:50 am    Post subject: Reply with quote

when i do "alsaconfig" it finds:

powermac powermac
legacy Probe legacy

i select powermac

Configuring snd-powermac
Do you want to modify /etc/modules.d/alsa ?
yes / no, = yes

OK, sound driver configured
now i'l run alsasound init script blaa blaa.

then "modules update"
Now ALSA is ready to use.
For adjustment of volumes, use your favorite mixer.

Have a lot of fun!


mpg123 lambrett.mp3
High Performance MPEG 1.0/2.0/2.5 Audio Player for Layer 1, 2 and 3.
Version 0.59s-r9 (2000/Oct/27). Written and copyrights by Michael Hipp.
Uses code from various people. See 'README' for more!
THIS SOFTWARE COMES WITH ABSOLUTELY NO WARRANTY! USE AT YOUR OWN RISK!
Can't open /dev/dsp!

lsmod
Module Size Used by
snd_pcm_oss 61248 0
snd_mixer_oss 19936 1 snd_pcm_oss
snd_seq_dummy 3012 0
snd_seq_oss 40148 0
snd_seq_midi_event 6656 1 snd_seq_oss
snd_seq 60152 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device 8652 3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_powermac 61804 1
snd_pcm 90916 2 snd_pcm_oss,snd_powermac
snd_timer 24036 2 snd_seq,snd_pcm
snd 52980 9 snd_pcm_oss,snd_mixer_oss,snd_seq_dummy,snd_seq_oss,snd_seq,snd_seq_device,snd_powermac,snd_pcm,snd_timer
snd_page_alloc 8388 1 snd_pcm


USE="fbsetbg aterm softmmu sdl mplayer samba xmms ssh qt dvd cdr apache apache2"
ALSA_CARDS="powermac"

alsamixer

alsamixer: function snd_ctl_open failed for default: No such device


./alsasound stop
* Storing ALSA Mixer Levels ...
/usr/sbin/alsactl: save_state:1163: No soundcards found... [ !! ] <-----
* Unloading ALSA ... [ ok ]
* Unloading ALSA modules ... [ !! ]


bah, yes it worked before with dmasound_pmac, but it was pretty weird in xmms, the mixer didnt work either. just sound at the same vol. pretty low

lspci
0000:00:0b.0 Host bridge: Apple Computer Inc. UniNorth/Pangea AGP
0000:00:10.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500]
0001:10:0b.0 Host bridge: Apple Computer Inc. UniNorth/Pangea PCI
0001:10:17.0 Class ff00: Apple Computer Inc. KeyLargo/Pangea Mac I/O
0001:10:18.0 USB Controller: Apple Computer Inc. KeyLargo/Pangea USB
0001:10:19.0 USB Controller: Apple Computer Inc. KeyLargo/Pangea USB
0002:20:0b.0 Host bridge: Apple Computer Inc. UniNorth/Pangea Internal PCI
0002:20:0e.0 Class ffff: Apple Computer Inc. UniNorth/Pangea FireWire (rev ff)
0002:20:0f.0 Ethernet controller: Apple Computer Inc. UniNorth/Pangea GMAC (Sun GEM)
_________________
ibook 12" G3 800mhz 30gb 384ram
Back to top
View user's profile Send private message
soujirou
Apprentice
Apprentice


Joined: 22 Jun 2004
Posts: 205
Location: sweden

PostPosted: Thu Sep 15, 2005 9:14 pm    Post subject: Reply with quote

added the I2C KeyWest drive in kernel, now dmasound_pmac works =)

no strange vol changing anymoore =)
_________________
ibook 12" G3 800mhz 30gb 384ram
Back to top
View user's profile Send private message
smerf
l33t
l33t


Joined: 06 Nov 2004
Posts: 778
Location: Polska

PostPosted: Thu Sep 15, 2005 10:38 pm    Post subject: Reply with quote

obvious, isn't it? ;)
_________________
Microsoft is not the answer, Microsoft is the question, the answer is no.
Back to top
View user's profile Send private message
soujirou
Apprentice
Apprentice


Joined: 22 Jun 2004
Posts: 205
Location: sweden

PostPosted: Fri Sep 16, 2005 6:35 am    Post subject: Reply with quote

haaaaa yes =)

thnx again
_________________
ibook 12" G3 800mhz 30gb 384ram
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum