Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved]"undefined symbol: _SDA_BASE_" - gentoo dying again?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
Cenrim
Tux's lil' helper
Tux's lil' helper


Joined: 04 Dec 2004
Posts: 142
Location: Germany

PostPosted: Tue Sep 13, 2005 11:32 am    Post subject: [solved]"undefined symbol: _SDA_BASE_" - gentoo dy Reply with quote

Hoi guys!

last night the output of etc-update was interrupted by a line like
Code:
less: symbol lookup error: less: unsefined symbol: _SDA_BASE_


I know this s**t, the last time I had to rebuild the whole system.
now anything with less would look like
Code:

# less /foo/bar
less: symbol lookup error: less: undefined symbol: _SDA_BASE_
#



I googled for this _SDA_BASE_ and found out it's ppc-specific (something with memory allocation) and definitivly to high for me to understand ^^""
first I thought was a broken library, something with stdout, but ones the broken one is loaded every prog using it would die with this symbol lookup error.
2nd thought was a kernel problem, but I'm using this kernel for over a month now and the machine was running for at least 8 hours...
(the first time my ibook was 'running' for over a week, suspend2ram is godmode for a game called uptime :twisted: )
the strangest thing is, it's spreading slowly, last time with several reboots between
it starts with less, soon it will be ssh, then something I need for X, some other small things and finaly login
pretty cool when you see things like
Code:
hostname login: root
login: symbol lookup error: login: undefined symbol: _SDA_BASE_

hostname login: foo
login: symbol lookup error: login: undefined symbol: _SDA_BASE_

hostname login:

on your screen..

after I found an old patch for the binutils related to _SDA_base_ I hadthe idea to downgrade the binutils, maybe they are the evildoers.. now, after a few secs the screen went black a the harddisk made this beautiful "argh, voltage down! i die!" noise...
then the silence of an complete powerdown I learned to love from some ppbuttonsd-versions.. *sigh*

so, I got no fscking clue whats wrong, anybody an idea?

PS: I'm pretty stuck in OS X, cause I cannot be sure that I even login when I reboot gentoo...


Last edited by Cenrim on Thu Sep 15, 2005 10:07 am; edited 1 time in total
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Tue Sep 13, 2005 1:11 pm    Post subject: Reply with quote

Well, as far as I know, that symbol has to do with the linking process. What are you using for CFLAGS, LDFLAGS, glibc version? Are you running ~ppc or ppc? Can you check your filesystem for errors with a livecd?

I've never heard of this problem before, but we'll see if we can help you out. :(
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
Cenrim
Tux's lil' helper
Tux's lil' helper


Joined: 04 Dec 2004
Posts: 142
Location: Germany

PostPosted: Tue Sep 13, 2005 3:16 pm    Post subject: Reply with quote

my emerge info:
Code:

Gentoo Base System version 1.12.0_pre8
Portage 2.0.52-r1 (default-linux/ppc/2004.3, gcc-3.4.4, glibc-2.3.5-r0, 2.6.12-gentoo-r9-1st ppc)
=================================================================
System uname: 2.6.12-gentoo-r9-1st ppc 7447A, altivec supported
dev-lang/python:     2.3.5, 2.4.1-r1
sys-apps/sandbox:    1.2.13
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6
sys-devel/binutils:  2.16.90.0.3
sys-devel/libtool:   1.5.20
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="ppc ~ppc"
AUTOCLEAN="yes"
CBUILD="powerpc-unknown-linux-gnu"
CFLAGS="-O2 -mcpu=G4 -maltivec -mabi=altivec -pipe -fno-strict-aliasing"
CHOST="powerpc-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/texmf/web2c /etc/env.d"
CXXFLAGS="-O2 -mcpu=G4 -maltivec -mabi=altivec -pipe -fno-strict-aliasing"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks sandbox sfperms strict userpriv usersandbox"
GENTOO_MIRRORS="ftp://pandemonium.tiscali.de/pub/gentoo/ http://pandemonium.tiscali.de/pub/gentoo/ http://gentoo.eliteminds.com"
LANG="de_DE.UTF-8"
LC_ALL="de_DE.UTF-8"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="ppc X alsa altivec bash-completion berkdb bitmap-fonts cdr crypt curl directfb dvd emboss esd fam fbcon flac font-server fortran gdbm gif gpm gtk gtk2 imagemagick imlib ipv6 java jpeg libwww mad mikmod mmap motif mp3 mpeg ncurses nls nocd nptl nptlonly ogg oggvorbis pam pdflib perl plotutils png python readline sdk sdl slang ssl tcpd tetex tiff truetype truetype-fonts type1-fonts unicode vorbis xml2 xv zlib userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LDFLAGS, LINGUAS       


my FSs seem to be OK:
Code:

/dev/hda
        #                    type name                  length   base      ( size )  system
/dev/hda1     Apple_partition_map Apple                     63 @ 1         ( 31.5k)  Partition map
/dev/hda2         Apple_Bootstrap bootstrap               1600 @ 64        (800.0k)  NewWorld bootblock
/dev/hda3         Apple_UNIX_SVR2 gentoo-root         20971520 @ 1664      ( 10.0G)  Linux native
/dev/hda4               Apple_HFS OS_X                31457280 @ 20973184  ( 15.0G)  HFS
/dev/hda5         Apple_UNIX_SVR2 gentoo-home         10485760 @ 52430464  (  5.0G)  Linux native
/dev/hda6               Apple_HFS data                54294016 @ 62916224  ( 25.9G)  HFS

Block size=512, Number of Blocks=117210240
DeviceType=0x0, DeviceId=0x0

/dev/hda3: clean, 364940/1310720 files, 1698961/2621440 blocks
/dev/hda5: clean, 7090/655360 files, 431050/1310720 blocks   


PS: sorry I forgot to post this stuff too ^^""
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Tue Sep 13, 2005 4:30 pm    Post subject: Reply with quote

By check your FS, I meant with fsck. That version of binutils hasn't been tested at all, it's not even marked ~ppc yet! I'd suggest that it may be causing your trouble. If you're going to use versions that aren't even marked ~ppc yet, I'd expect that you'll end up with a broken mess eventually. :)

Good luck!
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
Cenrim
Tux's lil' helper
Tux's lil' helper


Joined: 04 Dec 2004
Posts: 142
Location: Germany

PostPosted: Tue Sep 13, 2005 5:11 pm    Post subject: Reply with quote

wtf...?

Code:

 ls -al /usr/local/portage/sys-devel/                       
insgesamt 12
drwxr-xr-x  3 root    root    4096 13. Jun 22:29 .
drwxr-xr-x  8 root    root    4096 15. Jun 11:06 ..
drwxr-xr-x  3 portage portage 4096 13. Sep 18:54 binutils


why the f**k should the user portage make such a dir??
the only one using this user is portage itself...
I haven't touched /usr/local/portage in days...the last time I can remember was when I used it to fetch the xen stuff for my x86 (@home with no net-access until tomorrow), but why should I unmask this binutils package for ppc???
garrggh... I better stop thinking about this, my head would hurt in no time and paramoia is prolly no fun at all... :evil:

just to repair this s**t will be fun enough... :roll:

PS: btw: thats ">>"ed output of mac-fdisk -l and 2 fsck.ext3 -n :wink:
Back to top
View user's profile Send private message
Cenrim
Tux's lil' helper
Tux's lil' helper


Joined: 04 Dec 2004
Posts: 142
Location: Germany

PostPosted: Thu Sep 15, 2005 10:12 am    Post subject: Reply with quote

I was lucky, this time I tired to emerge binutils-2.16.1 my iBook didn't die ^^
everythings fine again,
thx JoseJX!

maybe I just was to f***ing tired to really know what I'm doing, when I unmasked and emerged 2.16.1.90.0.3 :oops:
insomnia is the path to the strangest parts of my mind :roll:
Back to top
View user's profile Send private message
Headrush
Watchman
Watchman


Joined: 06 Nov 2003
Posts: 5597
Location: Bizarro World

PostPosted: Wed Sep 21, 2005 4:24 pm    Post subject: Reply with quote

Cenrim wrote:
wtf...?
why the f**k should the user portage make such a dir??
the only one using this user is portage itself...
I haven't touched /usr/local/portage in days...the last time I can remember was when I used it to fetch the xen stuff for my x86

This sure looks like a PEBCAC problem. :wink:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum