Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
new libungif/giflib hell [SOLVED, ditch windowmaker]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
dakster
Apprentice
Apprentice


Joined: 26 Jul 2004
Posts: 178
Location: New England

PostPosted: Tue Sep 13, 2005 5:48 pm    Post subject: new libungif/giflib hell [SOLVED, ditch windowmaker] Reply with quote

Ok, I do believe I've gone through all the forums, and still it's not working for me. I've uninstalled libungif, revdep-rebuilt successfully, added gif to my USE, and recompiled imlib and imlib2, and still yet again successfully revdep-rebuilt. Still, when I'm trying to run emerge -ep world, I get:

[blocks B ] media-libs/giflib (is blocking media-libs/libungif-4.1.3)


I thought that the revdep-rebuild would take care of anything that still wants to use libungif? I dont' have anything weird in my package.* files that would affect this, I hardly use that at all. All other forums posts I've read had this issue fixed by the un installation of libungif and a revdep-rebuild. What might I be missing here? Thanks in advance for any help!


btw, more info:

I'm on amd64, moving to 2005.0 at the moment


shadowcat(root)> equery l giflib
[ Searching for package 'giflib' in all categories among: ]
* installed packages
[I--] [ ] media-libs/giflib-4.1.3 (0)



shadowcat(root)> equery l libungif
[ Searching for package 'libungif' in all categories among: ]
* installed packages
shadowcat(root)>



Thanks!


Last edited by dakster on Sun Sep 18, 2005 6:49 pm; edited 3 times in total
Back to top
View user's profile Send private message
dakster
Apprentice
Apprentice


Joined: 26 Jul 2004
Posts: 178
Location: New England

PostPosted: Tue Sep 13, 2005 6:09 pm    Post subject: update Reply with quote

After further digging, it appears that at least windowmaker still wants to use libungif. I don't know why, I recompiled this earlier during a revdep-rebuild successfully without the libungif, I'm going to look for ways to knock some sense into the windowmaker ebuild (which is -0.80.2-r4 btw, I've never found .90 to be stable with all apps in amd64). If anyone has further tips for me on what's wrong with windowmaker, and why it's still looking for libungif, I'm all ears :)
Back to top
View user's profile Send private message
dakster
Apprentice
Apprentice


Joined: 26 Jul 2004
Posts: 178
Location: New England

PostPosted: Thu Sep 15, 2005 12:44 pm    Post subject: Reply with quote

Well, after 5 years of using windowmaker, this was my solution:

emerge enlightenment
emerge -C windowmaker
edit .xinitrc


Sad to see windowmaker go for me, but it's been beyond time to move on. I was hoping to wait unti e17 went stable, but I'll use e16 till then. Looks good so far. Not as fast as windowmaker, but looks like it has some more bells and whistles.
Back to top
View user's profile Send private message
dakster
Apprentice
Apprentice


Joined: 26 Jul 2004
Posts: 178
Location: New England

PostPosted: Sun Sep 18, 2005 5:19 pm    Post subject: Reply with quote

Well, now on my home computer, I'm having an even worst time getting past the giflib/libungif issue. I'm uninstalled windowmaker, installed enlightenment, and still I get:

[blocks B ] media-libs/giflib (is blocking media-libs/libungif-4.1.3)


On my emerge -e world. libungif isn't installed, I've revdep-rebuild'd successfully, and when I check what depends on libungif (equery d libungif) NOTHING depends on it. WTF????? HELP!!!! lol
Back to top
View user's profile Send private message
Zarhan
l33t
l33t


Joined: 27 Feb 2004
Posts: 960

PostPosted: Sun Sep 18, 2005 5:46 pm    Post subject: Reply with quote

Stupid question, but is there any chance that the libungif has somehow ended up in your world file? Check /var/lib/portage world...

Also, try emerge --tree option.
Back to top
View user's profile Send private message
dakster
Apprentice
Apprentice


Joined: 26 Jul 2004
Posts: 178
Location: New England

PostPosted: Sun Sep 18, 2005 6:49 pm    Post subject: Reply with quote

Doh! Ok, I don't know why equery didn't pick it up, but although I had uninstalled windowmaker, windowmaker-themes still depends on libungif for some strange reason. Thanks for the tree tip, never used that before. Looks to be quite handy :)
Back to top
View user's profile Send private message
Gentree
Watchman
Watchman


Joined: 01 Jul 2003
Posts: 5350
Location: France, Old Europe

PostPosted: Mon Sep 19, 2005 2:57 pm    Post subject: Reply with quote

Thanks for posting, I was having the same issue without window-makeer et al.

seems an overlay wine-cvs was calling for libungif which produced the same blockage!

Like you I decided I didnot need that package so it cleared but its only a workaround.

Looks like there is a bug that needs clearing in the gif/ungif department.

:roll:
_________________
Linux, because I'd rather own a free OS than steal one that's not worth paying for.
Gentoo because I'm a masochist
AthlonXP-M on A7N8X. Portage ~x86
Back to top
View user's profile Send private message
dakster
Apprentice
Apprentice


Joined: 26 Jul 2004
Posts: 178
Location: New England

PostPosted: Mon Sep 19, 2005 3:02 pm    Post subject: Reply with quote

Yeah, I'd file one but I'm totally confused on my first bug report (talk about nOOb!) that I'm continually updating. I don't understand this problem at all, so I'll leave any bug reporting to someone who has a clue what's going on :)
I do miss windowmaker though. Should equery d have listed the windowmaker-themes package? I assumed it would have listed all packages that are depending on teh libungif, but I don't use equery much, so I'm not sure. Ah, just checked the man page, and it's listed as an unimplemented option. Doh! Live and learn...
Back to top
View user's profile Send private message
Gentree
Watchman
Watchman


Joined: 01 Jul 2003
Posts: 5350
Location: France, Old Europe

PostPosted: Mon Sep 19, 2005 3:32 pm    Post subject: Reply with quote

https://bugs.gentoo.org/show_bug.cgi?id=85720

this bug is already known. It says that windowmaker should be ok once you have removed libungif which in now included in giflib.

Quote:
x11-wm/windowmaker-0.91.0-r4 is fixed -- *** it will need to be rebuilt if libungif is removed
*** however.


If you still have a problem getting back you fave WM add to the bugreport.

In principal it should be OK.

:D

building 0.92.0-r1 ; no sign of gif/ungif probs
_________________
Linux, because I'd rather own a free OS than steal one that's not worth paying for.
Gentoo because I'm a masochist
AthlonXP-M on A7N8X. Portage ~x86
Back to top
View user's profile Send private message
dakster
Apprentice
Apprentice


Joined: 26 Jul 2004
Posts: 178
Location: New England

PostPosted: Mon Sep 19, 2005 3:47 pm    Post subject: Reply with quote

Ah yes, I use the last version of windowmaker, I never found the .90 version to be stable on amd64. I only use it on ppc :(
I've been meaning to make the enlightenment move for sometime, this is good for me :)
Back to top
View user's profile Send private message
dee2
n00b
n00b


Joined: 08 Jan 2005
Posts: 71

PostPosted: Sun Sep 25, 2005 4:01 am    Post subject: Reply with quote

I've had this hell for a long time also, tracked it down to gmencoder with the --tree option.
Glad to get rid of it!
Back to top
View user's profile Send private message
tomk
Bodhisattva
Bodhisattva


Joined: 23 Sep 2003
Posts: 7221
Location: Sat in front of my computer

PostPosted: Sun Oct 09, 2005 9:48 pm    Post subject: Reply with quote

Moved to Duplicate Threads, follow ups to this topic.
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum