Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
python-fchksum-1.7.1 failed
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
jmarcus
Apprentice
Apprentice


Joined: 12 Jun 2004
Posts: 197

PostPosted: Tue Sep 20, 2005 11:12 am    Post subject: python-fchksum-1.7.1 failed Reply with quote

I'm doing a stage 1 and python-fchksum is failing.

Code:
 
23:22:16 (148.39 KB/s) - `/usr/portage/distfiles/python-fchksum-1.7.1.tar.gz' saved [26,724/26,724]
 
>>> md5 files   ;-) python-fchksum-1.7.1.ebuild
>>> md5 files   ;-) python-fchksum-1.6.1-r1.ebuild
>>> md5 files   ;-) files/digest-python-fchksum-1.7.1
>>> md5 files   ;-) files/digest-python-fchksum-1.6.1-r1
>>> md5 src_uri ;-) python-fchksum-1.7.1.tar.gz
>>> Unpacking source...
>>> Unpacking python-fchksum-1.7.1.tar.gz to /var/tmp/portage/python-fchksum-1.7.1/work
>>> Source unpacked.
['setup.py', 'build']
running build
running build_ext
building 'fchksum' extension
creating build
creating build/temp.linux-i686-2.3
i386-pc-linux-gnu-gcc -pthread -fno-strict-aliasing -DNDEBUG -O2 -mcpu=i686 -fomit-frame-pointer -fPIC -I/usr/include/python2.3 -c md5.c -o build/temp.linux-i686-2.3/md5.o
unable to execute i386-pc-linux-gnu-gcc: No such file or directory
error: command 'i386-pc-linux-gnu-gcc' failed with exit status 1
 
!!! ERROR: dev-python/python-fchksum-1.7.1 failed.
!!! Function src_compile, Line 20, Exitcode 1
!!! (no error message)
!!! If you need support, post the topmost build error, NOT this status message.
 
livecd / #


Here is my make.conf
Code:
# These settings were set by the catalyst build script that automatically built this stage
# Please consult /etc/make.conf.example for a more detailed example
CFLAGS="-O2 -mcpu=i686 -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j2"
USE="gtk gnome mysql python apache2 mysql vhosts innodb -apache -D PHP4 -D SSL -D PERL"


Does this have anything to do with my CFLAGS OR CHOST?

thanks,
James
Back to top
View user's profile Send private message
suma
n00b
n00b


Joined: 15 Sep 2005
Posts: 23
Location: canberra, australia

PostPosted: Tue Sep 20, 2005 11:18 am    Post subject: Reply with quote

hey... i was getting this same error. it can be easily fixed, but you may experience other errors after this.

check out:
https://forums.gentoo.org/viewtopic-t-382482.html

cheers,
suma
Back to top
View user's profile Send private message
kimchi_sg
Advocate
Advocate


Joined: 26 Nov 2004
Posts: 2915
Location: Singapore

PostPosted: Tue Sep 20, 2005 11:38 am    Post subject: Reply with quote

Duplicate of https://forums.gentoo.org/viewtopic-t-348363.html
_________________
Murphy's Law of Gentoo installation: If a compile can fail, it will.

MacGillicuddy's Corollary: At the most inopportune time.

Please search and read the FAQs before posting.
Back to top
View user's profile Send private message
Naib
Watchman
Watchman


Joined: 21 May 2004
Posts: 5673
Location: Removed by Neddy

PostPosted: Tue Sep 20, 2005 12:07 pm    Post subject: Reply with quote

The propper solution can be found in this bug
https://bugs.gentoo.org/show_bug.cgi?id=88777

namely reply 14
_________________
The best argument against democracy is a five-minute conversation with the average voter
Great Britain is a republic, with a hereditary president, while the United States is a monarchy with an elective king
Back to top
View user's profile Send private message
suma
n00b
n00b


Joined: 15 Sep 2005
Posts: 23
Location: canberra, australia

PostPosted: Tue Sep 20, 2005 12:37 pm    Post subject: Reply with quote

i think the further problems i'm experiencing may be caused by not resolving this correctly.

a few searches leads to http://gentooexperimental.org/~chriswhite/read.php?id=39, which in turn leads to the link referenced by Naib. only problem, is i cant seem to open that link. i can ping bugs.gentoo.org, but either it's not serving http correctly, or there is some problem with my machine.

Quote:
The propper solution can be found in this bug
https://bugs.gentoo.org/show_bug.cgi?id=88777


is anyone else able to get to that page?
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Tue Sep 20, 2005 4:55 pm    Post subject: Reply with quote

Hmm... the link to the bug works perfectly here... Maybe your DNS is having an off-day? Look for threads in Networking & Security and maybe start a new one if you can't get it working.

Moved from Installing Gentoo to Duplicate Threads in favour of [Solved] Emerge Fails on python-fchksum.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum