Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Mac OS X software on linux PPC?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
dracula1985
Apprentice
Apprentice


Joined: 13 May 2005
Posts: 299
Location: Vicenza (Italy)

PostPosted: Wed Sep 21, 2005 12:25 pm    Post subject: Mac OS X software on linux PPC? Reply with quote

Is there a way to make working Mac OS X software under Linux PPC?
I known that a lot of linux software works under Mac OS X...

I was looking for skype on my linux ppc, but the linux version don't work...
_________________
Marco

"Man is least himself when he talks in his own person. Give him a mask, and he will tell you the truth." --Oscar Wilde.
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Wed Sep 21, 2005 1:25 pm    Post subject: Reply with quote

Three words: Mac On Linux (mol for short). It lets you run a copy of OSX as a process on Linux. For more info, check out: http://maconlinux.org or to install it on Gentoo, emerge mol. Note that if you want to run Tiger, you'll need the ~ppc version instead.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
dracula1985
Apprentice
Apprentice


Joined: 13 May 2005
Posts: 299
Location: Vicenza (Italy)

PostPosted: Wed Sep 21, 2005 7:31 pm    Post subject: Reply with quote

JoseJX wrote:
Three words: Mac On Linux (mol for short). It lets you run a copy of OSX as a process on Linux. For more info, check out: http://maconlinux.org or to install it on Gentoo, emerge mol. Note that if you want to run Tiger, you'll need the ~ppc version instead.


I merged mol, but I can't find molvconfig...
I edited /etc/mol/molrc.video and /etc/mol/molrc.osx manually but I can't find where I mistake...
This is the output of startmol -X
Code:
powerbook ~ # startmol -X
Mac-on-Linux 0.9.71-pre1 [Sep 21 2005 20:14]
Copyright (C) 1997-2004 Samuel Rydh
Starting MOL session 1
Running in PowerPC 7400 mode, 96 MB RAM
Timebase: 18.43 MHz, Bus: 73.72 MHz, Clock: 765 MHz
Using USB mouse on /dev/input/mice
OHCI USB controller registered
Could not open '/var/lib/mol/x11.kbd'
Video driver(s): [xvideo]

     640* 480, depth 8,32   { 0.0 } Hz
     800* 600, depth 8,32   { 0.0 } Hz
    1024* 768, depth 8,32   { 0.0 } Hz
    1152* 864, depth 8,32   { 0.0 } Hz
    1280*1024, depth 8,32   { 0.0 } Hz
    1600*1200, depth 8,32   { 0.0 } Hz

DHCP nameserver exported: 151.99.125.1
Ethernet Interface 'tun-<tun1>' @ 00:00:0D:EA:DB:EE

    ip/mask: 192.168.41.2/255.255.255.0  gw: 192.168.41.1
    broadcast: 192.168.41.255  nameserver: 192.168.41.1

ALSA sound driver (device 'default')

----> /dev/hda2 might be a boot-strap partition.
    Unembedded HFS+ /dev/hda5                       <rw>  128 MB
----> /dev/hda2 might be a boot-strap partition.
------> The volume '/dev/hda5' is locked
No volumes found in '/dev/hda'
No volumes found in '/dev/hdb'
No volumes found in '/dev/sda'
No volumes found in '/dev/sdb'

SCSI devices:

    <No SCSI Devices>

>> ==================================================
>> MacOS X Boot Loader 0.9.70 [96MB memory map patch]
>> SyncRead: error
>> SyncRead: error
>> --> Boot loader failure: No bootable disk found

cleaning up...
Terminating threads...
DONE


In the best case this end with a window with the mol logo that I can't close, in the other case it ends without graphical output...
_________________
Marco

"Man is least himself when he talks in his own person. Give him a mask, and he will tell you the truth." --Oscar Wilde.
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Thu Sep 22, 2005 1:56 am    Post subject: Reply with quote

Like it says when you emerge MOL, for console support (and molvconfig) you need to have the fbcon USE flag enabled.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
dracula1985
Apprentice
Apprentice


Joined: 13 May 2005
Posts: 299
Location: Vicenza (Italy)

PostPosted: Thu Sep 22, 2005 8:16 pm    Post subject: Reply with quote

JoseJX wrote:
Like it says when you emerge MOL, for console support (and molvconfig) you need to have the fbcon USE flag enabled.


Ok, I added fbcon, sheep and pci to my USE flags to make mol working (I do that following the errors of mol).

But the problem is that now it don't start!

First time i make startmol after making molvconf it freezed my pc and now kdm don't start...
I tryed to emerge kdm hoping it was a broken file, but nothing changed...

I empty /tmp, /var/tmp and /var/run hoping to resolve the problem, but nothing changed...
_________________
Marco

"Man is least himself when he talks in his own person. Give him a mask, and he will tell you the truth." --Oscar Wilde.
Back to top
View user's profile Send private message
pieman
n00b
n00b


Joined: 22 Sep 2005
Posts: 41
Location: San Dimas - Calif.

PostPosted: Fri Sep 23, 2005 5:35 pm    Post subject: Reply with quote

Does Mac on Linux work with 10.4 X86 tiger?
_________________
Viva la penguin
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Fri Sep 23, 2005 9:42 pm    Post subject: Reply with quote

No it doesn't work with x86. It currently contains lots of PPC assembly.

dracula1985: You're going to have to be more specific with error messages. MOL by itself would not have screwed up KDM. What is the error you're getting when trying to start KDM?
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
dracula1985
Apprentice
Apprentice


Joined: 13 May 2005
Posts: 299
Location: Vicenza (Italy)

PostPosted: Sat Sep 24, 2005 2:30 pm    Post subject: Reply with quote

JoseJX wrote:
No it doesn't work with x86. It currently contains lots of PPC assembly.

dracula1985: You're going to have to be more specific with error messages. MOL by itself would not have screwed up KDM. What is the error you're getting when trying to start KDM?


KDM don't start because when MOL freezed my powerbook the hardware clock has been set to 0...
I set the clock to the current time and kdm returned to work fine.
_________________
Marco

"Man is least himself when he talks in his own person. Give him a mask, and he will tell you the truth." --Oscar Wilde.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum