Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Hang on boot, Possibly Grub problem?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
icerogue
n00b
n00b


Joined: 14 Dec 2004
Posts: 6

PostPosted: Tue Dec 14, 2004 10:57 pm    Post subject: Hang on boot, Possibly Grub problem? Reply with quote

The issue i am having is that my computer hangs when i try to boot into Gentoo. This is the last line output;
Code:
vesafb: scrolling: redraw

There is no error mesage at all. I am doing my first install and I am following the manual as close as i can.
Here is my hardware list,
    2 40 gig Hardrives
    DVDrom
    CDRW
    AMD Athlon Xp 2200+
    Soyo k7vme Mainboard - I am using onboard video, sound, and network right now

My grub.conf looks like this (as close as I can remember)
Code:
default 0
timeout 30
splashimage=(hd0,0)/grub/splash.xpm.gz

title=Gentoo Linux 2.6.9-gentoo-r9
root (hd0,0)
kernel /kernel-2.6.9-gentoo-r9 root=/dev/hda3

I know that with the live cd, to get it to boot, i need to use
Code:
gentoo -noapic


As you can see i am using the gentoo-dev-source, and it is the 2004.3 release. I have gone through several times mounting and chrooting to try and fix it (origianally i was running lilo), and i even switched from genkernel to making my own.
Any tips or advice that could help me figure this one out would be greatly appreciated.
_________________
Ice Rogue

"Code Warrior - Man Your Battle Stations"
Back to top
View user's profile Send private message
icerogue
n00b
n00b


Joined: 14 Dec 2004
Posts: 6

PostPosted: Tue Dec 14, 2004 11:05 pm    Post subject: Forgot to mention Reply with quote

I forgot to mention what my partitions are (since it might mater)
hda1 ext2 /boot 60M
hda3 reiserfs /
hdb2 reiserfs /home
hda2 & hdb1 are both 512M swap
_________________
Ice Rogue

"Code Warrior - Man Your Battle Stations"
Back to top
View user's profile Send private message
cokey
Advocate
Advocate


Joined: 23 Apr 2004
Posts: 3343

PostPosted: Thu Dec 16, 2004 2:12 am    Post subject: Reply with quote

do you get to the grub screen? If so go through the options and try turning off framebuffer etc
_________________
"Sex: breakfast of champions" - James Hunt
Back to top
View user's profile Send private message
rezza
Guru
Guru


Joined: 09 Apr 2003
Posts: 434
Location: Edinburgh, UK

PostPosted: Thu Dec 16, 2004 3:21 am    Post subject: Reply with quote

It may be that your framebuffer device isn't working properly, and the booting continues just fine, but you can't see anything happening on your screen. Try waiting a suitable amount of time then logging in blind, and starting up X. Or playing a music file. If something like that works, you know that you've booted up OK, and that there's just an error with your framebuffer.
_________________
screenshots
blog
Back to top
View user's profile Send private message
Dr Gonzo
Apprentice
Apprentice


Joined: 31 Jan 2004
Posts: 276
Location: Austin, TX

PostPosted: Thu Dec 16, 2004 4:34 am    Post subject: Reply with quote

cokehabit wrote:
do you get to the grub screen? If so go through the options and try turning off framebuffer etc
Come on, cokie, how about some real advice?
_________________
"Families is where our nation finds hope, where wings take dream."

George W. Bush
Back to top
View user's profile Send private message
porodzila
Guru
Guru


Joined: 22 May 2004
Posts: 307
Location: Terrapin Station

PostPosted: Thu Dec 16, 2004 7:13 am    Post subject: Reply with quote

try adding "vga=780" ( or whatever mode) to
" kernel /kernel-2.6.9-gentoo-r9 root=/dev/hda3 "

if that doesnt help a quick fix is to not have a pretty framebuffer console
_________________
ubi primum potero, me hinc subduco.
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Sun Sep 25, 2005 10:09 am    Post subject: Reply with quote

Moved from Installing Gentoo to Duplicate Threads in favour of Kernel doesn't boot, stops with "vesafb: scrolling: redraw".
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum