Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Portage database problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Ranma2264
n00b
n00b


Joined: 06 Mar 2004
Posts: 6

PostPosted: Tue Sep 27, 2005 8:12 am    Post subject: Portage database problem Reply with quote

Hello to all...
I have a really huge problem and I hope somebody out there can help...

When I search to an specific package emerge tells me that the package is not installed, but on the contrary I do have that package installed. I tried with a lot of packages I know that I have installed but emerge still says that is not... I already checked all the number versions just in case, I can't find any solution to this problem...
Is there a way to rebuild my database of all my installed packages?

THANKS IN ADVANCE...

RANMA
Back to top
View user's profile Send private message
kimchi_sg
Advocate
Advocate


Joined: 26 Nov 2004
Posts: 2915
Location: Singapore

PostPosted: Tue Sep 27, 2005 1:15 pm    Post subject: Reply with quote

these are silly questions, but just to make sure... :wink:

  1. Did you install anything manually, without using emerge?
  2. Do you have anything in /var/db/pkg directory? If you have a installed system there will be subdirectories of installed application information inside.

_________________
Murphy's Law of Gentoo installation: If a compile can fail, it will.

MacGillicuddy's Corollary: At the most inopportune time.

Please search and read the FAQs before posting.
Back to top
View user's profile Send private message
alu
n00b
n00b


Joined: 19 Apr 2004
Posts: 74
Location: Sweden

PostPosted: Wed Mar 15, 2006 4:21 pm    Post subject: Re: Portage database problem Reply with quote

I too would want to know this..
Back to top
View user's profile Send private message
Genone
Retired Dev
Retired Dev


Joined: 14 Mar 2003
Posts: 9236
Location: beyond the rim

PostPosted: Wed Mar 15, 2006 4:41 pm    Post subject: Reply with quote

For any package (lets call it "cat/foo" here) you think you have installed please do the following:
Code:
emerge -p cat/foo
emerge -s cat/foo
ls -ld /var/b/pkg/cat/foo*

All of these should give you the same information (either all agree the package is installed or they all agree it's not).
Back to top
View user's profile Send private message
alu
n00b
n00b


Joined: 19 Apr 2004
Posts: 74
Location: Sweden

PostPosted: Fri Mar 17, 2006 1:56 am    Post subject: Reply with quote

I'm sorry, I wasen't beeing informativ enough.
I'm missing the /var/db/pkg catalog, but my world file is intact.
Don't blame me, I'm using a Kororaa LiveCD. And don't blame Kororaa! :lol:

I have fixed the problem by running the regenpkgdb script and emerge --regen world.
Thanks !
Back to top
View user's profile Send private message
tomk
Bodhisattva
Bodhisattva


Joined: 23 Sep 2003
Posts: 7221
Location: Sat in front of my computer

PostPosted: Fri Mar 17, 2006 8:35 am    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads, please see this topic.
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum