Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem with Eclipse compiling
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
cagnaluia
l33t
l33t


Joined: 01 Sep 2004
Posts: 998
Location: Treviso

PostPosted: Fri Sep 30, 2005 12:45 pm    Post subject: Problem with Eclipse compiling Reply with quote

Hola,

excuseme for my poor english.

I have a problem with eclicpse-sdk compiling in my powerbook.

when i try to emerge it, appear this java compile error (i think...):

Code:

....
    [javac] Compiling 48 source files to /var/tmp/portage/junit-3.8.1-r1/work/ju
nit3.8.1
    [javac] This version of java does not support the classic compiler; upgradin
g to modern
    [javac] error: IO exception sun.io.MalformedInputException
    [javac] 1 error

BUILD FAILED
/var/tmp/portage/junit-3.8.1-r1/work/junit3.8.1/build.xml:28: Compile failed; se
e the compiler error output for details.

Total time: 7 seconds

!!! ERROR: dev-java/junit-3.8.1-r1 failed.
!!! Function src_compile, Line 33, Exitcode 1
!!! failed to build
!!! If you need support, post the topmost build error, NOT this status message.




maybe i must upgrade ibm-jdk--bin to 1.5.... but it isn't support by ppc....
Back to top
View user's profile Send private message
eldzis
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jan 2005
Posts: 138
Location: Latvia, Valmiera

PostPosted: Fri Sep 30, 2005 12:50 pm    Post subject: Reply with quote

try diferent jdk
and don`t forget to update your system
_________________
Proud #368799 Linux User
Gentoo - true Linux distribution
Back to top
View user's profile Send private message
cagnaluia
l33t
l33t


Joined: 01 Sep 2004
Posts: 998
Location: Treviso

PostPosted: Fri Sep 30, 2005 12:52 pm    Post subject: Reply with quote

eldzis wrote:
try diferent jdk
and don`t forget to update your system


only ibm-jdk i know working for ppc.... any else?
Back to top
View user's profile Send private message
zeekec
n00b
n00b


Joined: 24 Feb 2004
Posts: 56
Location: Athens, GA, USA

PostPosted: Fri Sep 30, 2005 1:49 pm    Post subject: Re: Problem with Eclipse compiling Reply with quote

cagnaluia wrote:
Code:
BUILD FAILED
/var/tmp/portage/junit-3.8.1-r1/work/junit3.8.1/build.xml:28: Compile failed; se
e the compiler error output for details.


Perhapse removing "junit" from your use flags will let you install eclipse? Eclipse doesn't seem to depend directly on junit, so Eclipse should work fine.

Erik

P.S. I realize that this isn't an optimal solution, but it may let you get started using Eclipse.
_________________
Against stupidity the very gods
Themselves contend in vain.
-Johann Christoph Friedrich von Schiller (1801)
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Fri Sep 30, 2005 2:21 pm    Post subject: Reply with quote

Those IOException errors are due to poor UTF8 support. See this bug:
https://bugs.gentoo.org/show_bug.cgi?id=93649
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
cagnaluia
l33t
l33t


Joined: 01 Sep 2004
Posts: 998
Location: Treviso

PostPosted: Fri Sep 30, 2005 3:22 pm    Post subject: Re: Problem with Eclipse compiling Reply with quote

zeekec wrote:
cagnaluia wrote:
Code:
BUILD FAILED
/var/tmp/portage/junit-3.8.1-r1/work/junit3.8.1/build.xml:28: Compile failed; se
e the compiler error output for details.


Perhapse removing "junit" from your use flags will let you install eclipse? Eclipse doesn't seem to depend directly on junit, so Eclipse should work fine.

Erik

P.S. I realize that this isn't an optimal solution, but it may let you get started using Eclipse.


ofcurse... i used -junit in USE
Back to top
View user's profile Send private message
cagnaluia
l33t
l33t


Joined: 01 Sep 2004
Posts: 998
Location: Treviso

PostPosted: Fri Sep 30, 2005 3:23 pm    Post subject: Reply with quote

JoseJX wrote:
Those IOException errors are due to poor UTF8 support. See this bug:
https://bugs.gentoo.org/show_bug.cgi?id=93649



i'm going to see... :oops:
Back to top
View user's profile Send private message
xyz
n00b
n00b


Joined: 29 Oct 2003
Posts: 67

PostPosted: Sat Oct 01, 2005 7:02 am    Post subject: Reply with quote

I had that problem before on my gentoo ppc64 with IBM Java 1.4.2, but no problem for the latest version.
Try to use [code]
export LANG=en_US
./build -os linux -ws gtk -arch ppc
[/code]
Back to top
View user's profile Send private message
cagnaluia
l33t
l33t


Joined: 01 Sep 2004
Posts: 998
Location: Treviso

PostPosted: Sat Oct 01, 2005 7:32 am    Post subject: Reply with quote

xyz wrote:
I had that problem before on my gentoo ppc64 with IBM Java 1.4.2, but no problem for the latest version.
Try to use
Code:

export LANG=en_US
./build -os linux -ws gtk -arch ppc


:oops: xcuseme.. i don't understand... where i use this script?
Back to top
View user's profile Send private message
xyz
n00b
n00b


Joined: 29 Oct 2003
Posts: 67

PostPosted: Sun Oct 02, 2005 12:47 pm    Post subject: Reply with quote

[quote="cagnaluia"][quote="xyz"]I had that problem before on my gentoo ppc64 with IBM Java 1.4.2, but no problem for the latest version.
Try to use [code]
export LANG=en_US
./build -os linux -ws gtk -arch ppc
[/code][/quote]

:oops: xcuseme.. i don't understand... where i use this script?[/quote]

Just in a terminal window, Terminal in Gnome, for example. Firstly set your LANG variable to en_US(is your LANG en_US.UFT-8?), then execute build script with arguments like above under the eclipse root directory where you uncompressed its source code.
Back to top
View user's profile Send private message
cagnaluia
l33t
l33t


Joined: 01 Sep 2004
Posts: 998
Location: Treviso

PostPosted: Fri Oct 07, 2005 6:34 am    Post subject: Reply with quote

xyz wrote:
cagnaluia wrote:
xyz wrote:
I had that problem before on my gentoo ppc64 with IBM Java 1.4.2, but no problem for the latest version.
Try to use
Code:

export LANG=en_US
./build -os linux -ws gtk -arch ppc


:oops: xcuseme.. i don't understand... where i use this script?


Just in a terminal window, Terminal in Gnome, for example. Firstly set your LANG variable to en_US(is your LANG en_US.UFT-8?), then execute build script with arguments like above under the eclipse root directory where you uncompressed its source code.



again...sorry..

but.. where i find it?

do i must download java jdk sources? and... from where?
Back to top
View user's profile Send private message
Massimo B.
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1563
Location: Germany

PostPosted: Fri Oct 07, 2005 8:11 am    Post subject: Reply with quote

It tried the ~ppc eclipse 3.1 and get a similar error. The old eclipse compiled fine.
Code:
BUILD SUCCESSFUL
Total time: 7 minutes 11 seconds
 * Compiling Eclipse -- see /var/tmp/portage/eclipse-sdk-3.1-r1/work/eclipse-sdk-3.1/compilelog.txt for details
Die JVM-Option ist ungültig: -XX:CompileThreshold=1500
Java Virtual Machine konnte nicht erstellt werden.
[...]
!!! ERROR: dev-util/eclipse-sdk-3.1-r1 failed.
!!! Function src_compile, Line 119, Exitcode 1
!!! Failed to compile Eclipse
!!! If you need support, post the topmost build error, NOT this status message.

_________________
ppc:PowerBook5,8 15"(1440)-G4/1.67,2G|amd64:HP EliteBook 8560w,i7-2620M,16G|Acer Z5610 (Core2QuadQ8200),8G|amd64-prefix:OpenSuse|HP EliteDesk 800G1 i7-4790|HP Compaq Pro 6300 i7-3770
Lila-Theme
Back to top
View user's profile Send private message
cagnaluia
l33t
l33t


Joined: 01 Sep 2004
Posts: 998
Location: Treviso

PostPosted: Fri Oct 07, 2005 8:26 am    Post subject: Reply with quote

..... i have the same error in the new & old version of eclipse...

maybe eclipse compiling right.... but some dependecies don't work... sing :oops:
Back to top
View user's profile Send private message
xyz
n00b
n00b


Joined: 29 Oct 2003
Posts: 67

PostPosted: Fri Oct 07, 2005 1:04 pm    Post subject: Reply with quote

[quote="cagnaluia"][quote="xyz"][quote="cagnaluia"][quote="xyz"]I had that problem before on my gentoo ppc64 with IBM Java 1.4.2, but no problem for the latest version.
Try to use [code]
export LANG=en_US
./build -os linux -ws gtk -arch ppc
[/code][/quote]

:oops: xcuseme.. i don't understand... where i use this script?[/quote]

Just in a terminal window, Terminal in Gnome, for example. Firstly set your LANG variable to en_US(is your LANG en_US.UFT-8?), then execute build script with arguments like above under the eclipse root directory where you uncompressed its source code.[/quote]


again...sorry..

but.. where i find it?

do i must download java jdk sources? and... from where?[/quote]

Then try to use in a window:
export LANG=en_US
emerge eclipse
Back to top
View user's profile Send private message
VanDan
Guru
Guru


Joined: 30 Sep 2002
Posts: 586
Location: Australia

PostPosted: Fri Oct 14, 2005 4:27 am    Post subject: Reply with quote

I'm getting exactly the same problem:

Code:
BUILD SUCCESSFUL
Total time: 57 seconds
 * Bootstrapping ecj
     [echo] TARGET: compiler2
     [echo] compilerArg -encoding ISO-8859-1
     [echo] build compiler org.eclipse.jdt.core.JDTCompilerAdapter
     [echo] UPDATE ecj.jar

BUILD SUCCESSFUL
Total time: 48 seconds
 * Compiling Eclipse -- see /var/tmp/portage/eclipse-sdk-3.1-r1/work/eclipse-sdk-3.1/compilelog.txt for details
The JVM option is invalid: -XX:CompileThreshold=1500
Could not create the Java virtual machine.

Usage: java [-options] class [args...]
           (to execute a class)
   or  java [-jar] [-options] jarfile [args...]
           (to execute a jar file)

where options include:
    -cp -classpath <directories and zip/jar files separated by :>
              set search path for application classes and resources
    -D<name>=<value>
              set a system property
    -verbose[:class|gc|jni]
              enable verbose output
    -version  print product version
    -showversion  print product version and continue
    -? -help  print this help message
    -X        print help on non-standard options
    -assert   print help on assert options


!!! ERROR: dev-util/eclipse-sdk-3.1-r1 failed.
!!! Function src_compile, Line 119, Exitcode 1
!!! Failed to compile Eclipse
!!! If you need support, post the topmost build error, NOT this status message.

skitz eclipse-sdk #


The strange this is that I've had this version of eclipse emerged before. I unfortunately decided to uninstall it, delete everything, and start again ( EPIC plugin was pissing me off ). But now the above happens.

I've also tried:

Code:
export LANG=en_US
emerge eclipse-sdk


The problem remains ...
Back to top
View user's profile Send private message
Massimo B.
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1563
Location: Germany

PostPosted: Fri Oct 14, 2005 8:05 am    Post subject: Reply with quote

I think everyone has this problem. But you say it worked before? I still have eclipse 3.0 and can't do the update to 3.1 like you.
But maybe with the next ibm-jdk 5...
_________________
ppc:PowerBook5,8 15"(1440)-G4/1.67,2G|amd64:HP EliteBook 8560w,i7-2620M,16G|Acer Z5610 (Core2QuadQ8200),8G|amd64-prefix:OpenSuse|HP EliteDesk 800G1 i7-4790|HP Compaq Pro 6300 i7-3770
Lila-Theme
Back to top
View user's profile Send private message
VanDan
Guru
Guru


Joined: 30 Sep 2002
Posts: 586
Location: Australia

PostPosted: Fri Oct 14, 2005 10:51 am    Post subject: Reply with quote

Yeah. I installed it just recently, oblivious to the fact that it's not supposed to work:

Code:
1123483648: Started emerge on: Aug 08, 2005 16:47:28
1123483648:  *** emerge  eclipse-sdk
1123483648:  >>> emerge (1 of 1) dev-util/eclipse-sdk-3.1-r1 to /
1123483648:  === (1 of 1) Cleaning (dev-util/eclipse-sdk-3.1-r1::/usr/portage/dev-util/eclipse-sdk/eclipse-sdk-3.1-r1.ebuild)
1123483650:  === (1 of 1) Compiling/Merging (dev-util/eclipse-sdk-3.1-r1::/usr/portage/dev-util/eclipse-sdk/eclipse-sdk-3.1-r1.ebuild)
1123486083:  === (1 of 1) Updating world file (dev-util/eclipse-sdk-3.1-r1)
1123486083:  === (1 of 1) Post-Build Cleaning (dev-util/eclipse-sdk-3.1-r1::/usr/portage/dev-util/eclipse-sdk/eclipse-sdk-3.1-r1.ebuild)
1123486147:  >>> AUTOCLEAN: dev-util/eclipse-sdk
1123486147:  --- AUTOCLEAN: Nothing unmerged.
1123486147:  ::: completed emerge (1 of 1) dev-util/eclipse-sdk-3.1-r1 to /
1123486147:  *** Finished. Cleaning up...
1123486151:  *** exiting successfully.
1123486160:  *** terminating.


I then frigged around with EPIC for a while, screwed things up, unmerged everything, deleted the eclipse folder, re-emerged it, re-installed EPIC, and found that I still couldn't get it working properly.

A couple of weeks later, I created an ebuild for eclipse-3.1.1, unmerged 3.1, deleted my eclipse folder, and tried to emerge 3.1.1. It didn't work. I submitted a version-bump-request bug and then gave up for a while.

Then I decided I'd just use the syntax highlighting part of eclipse / EPIC, and went to emerge 3.1 again, and found that it suddenly didn't want to emerge. Damn!
Back to top
View user's profile Send private message
SmasSive
n00b
n00b


Joined: 22 May 2003
Posts: 21

PostPosted: Sat Oct 15, 2005 3:54 pm    Post subject: Reply with quote

Here with the same problem.

Anybody knows how to solve the problem? Dev team are working on a new ebuild that fixes it?

Thanks! ;)
Back to top
View user's profile Send private message
VanDan
Guru
Guru


Joined: 30 Sep 2002
Posts: 586
Location: Australia

PostPosted: Mon Oct 17, 2005 7:56 am    Post subject: Reply with quote

As far as I know - no, there is no-one working on it.

I don't think it's a problem with the ebuild. I think it's a problem somewhere else. The ebuild didn't change between the time when I could successfully install eclipse, and now. So it must be something else that I've upgraded on my system that is causing this bug. It's not the JRE either - I certainly didn't upgrade that - it's such a PITA to find and download. But I don't know what the problem is. It's possible that the new Java 5 thing will fix things, but I wouldn't hold my breath. Maybe something in the compiler toolchain?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum