Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Alternativ Benutzung von Genkernel [gelöst]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Demmaro
n00b
n00b


Joined: 26 Jan 2012
Posts: 65

PostPosted: Sat Feb 18, 2012 5:03 pm    Post subject: Alternativ Benutzung von Genkernel [gelöst] Reply with quote

Hallo hab mich für die alternativ Benutzung von Genkernel (automatisch konfigurieren) entschieden

bei ausführen des Befehls

Code:
# emerge genkernel


kommt volgende meldung

Code:
Failed to emerge app-arch/cpio-2.11, log file

>>> '/var/tmp/portage/app-arch/cpio-2.11/temp/build.log'


mit welchen schritten kann ich die Datei dort hin bekommen ? weiß gerade nicht mehr weiter


Last edited by Demmaro on Mon Feb 20, 2012 5:00 pm; edited 1 time in total
Back to top
View user's profile Send private message
kriz
Apprentice
Apprentice


Joined: 22 Jan 2003
Posts: 231

PostPosted: Sat Feb 18, 2012 5:21 pm    Post subject: Reply with quote

In dem Log kannst du nachsehen was beim übersetzen nicht funktioniert hat bzw hast du eine detaillierte Auflistung des Fehlers.
Öffnen kannst du das Log mit jedem Texteditor.
cc
Back to top
View user's profile Send private message
Demmaro
n00b
n00b


Joined: 26 Jan 2012
Posts: 65

PostPosted: Sun Feb 19, 2012 9:44 am    Post subject: Reply with quote

hab mal raus geschrieben was ich als Meldung bekomme

cat build.log

Code:
 * Features: sandbox
>>> Unpacking source
>>> Unpacking cpio-2.11.tar.bz2 to /var/tmp/portage/app-arch/cpio-2.11/work
>>> Source unpacked in /var/tmp/portage/app-arch/cpio-2.11/work
>>> Preparing source in /var/tmp/portage/app-arch/cpio-2.11/work/cpio-2.11 ...
 * Applying cpio-2.11-stat.patch ...                     [ok]
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/app-arch/cpio-2.11/work/cpio-2.11 ...
 * econf: updating cpio-2.11/build-aux/config.guess with /usr/share/gnuconfig/config.guess
 * econf: updating cpio-2.11/build-aux/config.sub with /usr/share/gnuconfig/config.sub
./configure --prefix/usr --build=x86_64-pc-linux-gnu --host=x86_64-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info
  --datadir=/usr/share --syconfdir=/etc --localstatedir=/var/lib --libdir=/usrlib64 --enable-nls --bindir=/bin --with-rmt=/usr/sbin/rmt
checking for a BSD-compatible install... /usr/bin/install -c
checking wether build enviromment is sane ... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking wether make sets $(MAKE)... yes
checking how to create a ustar tar archive... gnutar
checking for x86_64-pc-linux-gnu-dcc... x86_64-pc-linux-gnu-gcc
checking for c compiler default output file name...
configure: error: in'/var/tmp/portage/app-arch/cpio-2.11/work/cpio-2.11':
configure: error: ccompiler cannot create executables
see 'config.log' for more details.

!!! Please attach the following file when seeking support
!!! /var/tmp/portage/app-arch/cpio-2.11/work/cpio-2.11/config.log
 *ERROR: app-erch/cpio-2.11 failed (configure phase)
   econf failed

 * Call stack:
         ebuild.sh, line    85: Called src_configure
        enviroment, line      2061: Called econf '--enable-nls' '--bindir=/bin' '--with-rmt=/usr/sbin/rmt'
 *  phase-helpers.sh, line       467: Called die
 * The specific snippet of code:
         die "econf failed"

 * If you need support, post the output of 'emerge --info =app-arch/cpio-2.11'
 * the complete build log and the output of 'emerge -pqv =app-arch/cpio-2.11'.
 * The complete build log is located at '/var/tmp/portage/app-arch/cpio-2.11/temp/build.log'.
 * The ebuild environment file is located at ' /var/tmp/portage/app-rch/cpio-2.11/temp/environment'.
 * S: '/var/tmp/portage/app-arch/cpio-2.11/work/cpio-2.11'


vielleicht kann jemand damit was anfangen
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Sun Feb 19, 2012 9:57 am    Post subject: Reply with quote

Code:
configure: error: ccompiler cannot create executables

What does gcc-config say?
Also, the exact name of your processor and emerge --info would help.
Back to top
View user's profile Send private message
Max Steel
Advocate
Advocate


Joined: 12 Feb 2007
Posts: 2050
Location: My own world! I and Gentoo!

PostPosted: Sun Feb 19, 2012 10:05 am    Post subject: Reply with quote

Hast du irgendeinen Tippfehler in den CFLAGS, CXXFLAGS oder in den LDFLAGS?
_________________
mfg
Steel
___________________
Sorry for my bad English.

Heim-PC: Intel i7-5820K, 32GB RAM, GTX 1080
Laptop: Intel Core i5-4300U, 16GB RAM, Intel Graphic
Arbeit-PC: Intel i5-3470S, 16GB RAM, Intel Graphic
Back to top
View user's profile Send private message
Demmaro
n00b
n00b


Joined: 26 Jan 2012
Posts: 65

PostPosted: Sun Feb 19, 2012 10:20 am    Post subject: Reply with quote

beim eingeben von

Code:
gcc-config

steht volgendes

Code:
For example:               i686-pc-linux-gnu-3.2.1


Ich habe ein Intel Core i3 Prozessor.


CFLAGS, CXXFLAGS

hab ich volgendes eingetipt



Code:
CFLAGS="-mararch=corei3 -02 -pipe"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j2"
LINGUAS="de"
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Sun Feb 19, 2012 10:24 am    Post subject: Reply with quote

In CFLAGS="-mararch=corei3 -02 -pipe" ist ein Tipfehler:
Zudem würde ich march auf native setzen:

CFLAGS="-march=native -02 -pipe"
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
Demmaro
n00b
n00b


Joined: 26 Jan 2012
Posts: 65

PostPosted: Sun Feb 19, 2012 10:27 am    Post subject: Reply with quote

habe gerade die make.conf Datei nochmal angeschaut die ist komplett leer muss ich die irgendwas machen ich hab die installation am nächsten tag weiter gemacht hab volgendes durchgeführt bevor ich mit der installation fortgefahren habe


Code:
mount /dev/MEINROOT /mnt/gentoo
mount -o bind /dev /mnt/gentoo/dev
mount -o bind /proc /mnt/gentoo/proc


Code:
chroot /mnt/gentoo /bin/bash
mount /dev/meineBOOTPART /boot
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Sun Feb 19, 2012 10:28 am    Post subject: Reply with quote

Erm....
http://en.gentoo-wiki.com/wiki/Safe_Cflags
1) Es heißt "-march" und nicht "-mararch"
2) corei3 gibbet nicht!
3) welchen core i3? Sandybridge? Nen älteren? Deshalb EXAKTER Prozessor Name (Core i3 2125 o.Ä.)
Back to top
View user's profile Send private message
Demmaro
n00b
n00b


Joined: 26 Jan 2012
Posts: 65

PostPosted: Sun Feb 19, 2012 10:38 am    Post subject: Reply with quote

model name der cpu

Code:
Intel core i3 cpu M350 @ 2,27Ghz
prozessor 3
model 37
cpu family 6
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Sun Feb 19, 2012 11:43 am    Post subject: Reply with quote

Google -> CFLAGS for intel core i3 M350 -> https://forums.gentoo.org/viewtopic-t-882609-start-0.html
Aber (wie oben erwähnt) ist wohl -march=native die beste Option (falls du nicht vorhast DISTCC o.Ä. zu verwenden).
Back to top
View user's profile Send private message
Demmaro
n00b
n00b


Joined: 26 Jan 2012
Posts: 65

PostPosted: Mon Feb 20, 2012 5:03 pm    Post subject: Reply with quote

Hab es auf
Code:

CFLAGS="-march=native -02 -pipe"


gesetzt und ging vielen dank
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum