Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
/etc/runlevels/boot odd symlinks
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
shenion
n00b
n00b


Joined: 01 Oct 2005
Posts: 4

PostPosted: Sat Oct 01, 2005 1:52 am    Post subject: /etc/runlevels/boot odd symlinks Reply with quote

I was looking around the runlevels and noticed the following in /etc/runlevels/boot

lrwxrwxrwx 1 root root 36 Sep 28 20:42 bootmisc -> /tmp/stage1root//etc/init.d/bootmisc
lrwxrwxrwx 1 root root 35 Sep 28 20:42 checkfs -> /tmp/stage1root//etc/init.d/checkfs
lrwxrwxrwx 1 root root 37 Sep 28 20:42 checkroot -> /tmp/stage1root//etc/init.d/checkroot
lrwxrwxrwx 1 root root 33 Sep 28 20:42 clock -> /tmp/stage1root//etc/init.d/clock
(and so on all links are to /tmp/stage1root....)

This system has beed running for a few days with no problems. It looks like it will not boot properly as there is no /tmp/stage1root directory.

I have created a /tmp/stage1root link to / and it seems happy. I can manually fix the links.

I just wonder what would change these links to be invalid? It looks like it had set up a temp area do do some update and never restored the links.
Back to top
View user's profile Send private message
chunderbunny
Veteran
Veteran


Joined: 31 May 2004
Posts: 1281
Location: 51°24'27" N, 0°57'15" W

PostPosted: Sat Oct 01, 2005 9:41 pm    Post subject: Reply with quote

I have those links on my system and nothing in /tmp. My system boots just fine, I don't think they should be necessary.
Back to top
View user's profile Send private message
thepi
Guru
Guru


Joined: 06 Jan 2004
Posts: 352
Location: Tokyo, Japan

PostPosted: Sun Dec 04, 2005 4:31 pm    Post subject: Reply with quote

It's a known bug in baselayout, it's fixed in the new 2005.1-r1. A solution has been discussed here. Just follow the instructions in that post for every runlevel that has those faulty symlinks. Should work fine.

Regards,
pi~
_________________
Violence is the last resort of the incompetent --Isaac Asimov
Gentoo on Acer TM800 | Help! | Vote! | Get FF!
Back to top
View user's profile Send private message
Earthwings
Bodhisattva
Bodhisattva


Joined: 14 Apr 2003
Posts: 7753
Location: Karlsruhe, Germany

PostPosted: Sun Dec 04, 2005 4:36 pm    Post subject: Reply with quote

thepi wrote:
It's a known bug in baselayout, it's fixed in the new 2005.1-r1. A solution has been discussed here. Just follow the instructions in that post for every runlevel that has those faulty symlinks. Should work fine.

Moved to dups, thanks for the link.
_________________
KDE
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum