Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
12" Powerbook - Xorg - failed to load module "fbdev"[Solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
juno44
n00b
n00b


Joined: 08 Apr 2004
Posts: 36

PostPosted: Mon Oct 03, 2005 6:12 pm    Post subject: 12" Powerbook - Xorg - failed to load module "fbde Reply with quote

Trying to get Xorg running on my 12" Powerbook and when I run Xorg -configure I get the following error:

(EE) Failed to load module "fbdev" (once-only module. 0)

When I run startx I get the following:

XIO fatal error 104 (connection reset by peer) on X server ":0.0@

I have done a stage three install and used genkernal to compile the kernel.

I am assuming that there is a module called fbdev that should have been loaded?

Any ideas?
_________________
'where there's open source there's a way'


Last edited by juno44 on Tue Oct 04, 2005 7:24 pm; edited 1 time in total
Back to top
View user's profile Send private message
e-ipi
Apprentice
Apprentice


Joined: 23 Aug 2005
Posts: 192

PostPosted: Tue Oct 04, 2005 4:42 am    Post subject: Reply with quote

I don't think that's a kernel module, but an xorg module. In any case, the module that ought to be loading is "nv". The graphical setup utility didn't work for me. I think xorgconfig is more reliable anyway. Try that. It's a little more work, but it usually does the job.

If you have one of the current powerbook 12", you could use my xorg.conf, which I posted in some other thread. Perhaps a search will retrieve it.
Back to top
View user's profile Send private message
AaronPPC
Guru
Guru


Joined: 29 May 2005
Posts: 522
Location: Tucson, AZ

PostPosted: Tue Oct 04, 2005 5:00 am    Post subject: Reply with quote

Actually, there is a PPC-specific utility called xorgautoconfig.
_________________
--Aaron
Back to top
View user's profile Send private message
juno44
n00b
n00b


Joined: 08 Apr 2004
Posts: 36

PostPosted: Tue Oct 04, 2005 7:23 pm    Post subject: Reply with quote

e-ipi - Many, Many thanks - I copied you xorg.config and it worked first time.

For those that follow:

The config file can be found here:

https://forums.gentoo.org/viewtopic-t-378072.html

I have a 12" powerbook (A1010), 1Ghz/256/40gig/SD

Let the nightmare continue...
_________________
'where there's open source there's a way'
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum