Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
x11-base/xorg-x11 blocking itself?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Ribs
Tux's lil' helper
Tux's lil' helper


Joined: 16 Nov 2002
Posts: 133
Location: UK

PostPosted: Sun Oct 16, 2005 2:04 pm    Post subject: x11-base/xorg-x11 blocking itself? Reply with quote

Hi,

I've been forced to use the unstable versions of xorg-x11 due to the newish hardware I'm using not having drivers in stable (a SP13000 motherboard, if that matters).

Basically, I've been using xorg-x11-6.8.99.14 with only minor issues. So I decided to upgrade to .15-r4, to see if that would fix everything.

Sadly, .15-r4 doesn't even start on my hardware. So, I try to downgrade to .14 again.

Thankfully, I did quickpkg on my .14 install before doing anything. So, just a simple unmerge of .15 and install of .14, right? Not quite. I did the unmerge of .15, but .14 now won't install, claiming that x11-base/xorg-x11 blocks itelf(?)
Code:
mythtv x11-base # emerge -K -p =x11-base/xorg-x11-6.8.99.14

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[blocks B     ] x11-base/xorg-x11 (is blocking x11-base/xorg-x11-6.8.99.14)
[binary  N    ] x11-base/xorg-x11-6.8.99.14

mythtv x11-base # emerge unmerge xorg-x11

--- Couldn't find xorg-x11 to unmerge.

>>> unmerge: No packages selected for removal.


Oh dear. This could be due to the .14 ebuild not existing anymore. But how can a package block itself? And does the archived version of .14 not contain any information for portage?

So, I could try to get .15 working (not very likley). Or try to force portage to install .14

I want to get .14 back. What is the best way forward?

Regards,
Ribs.
Back to top
View user's profile Send private message
DDV01
n00b
n00b


Joined: 08 Jul 2003
Posts: 70
Location: The Netherlands

PostPosted: Tue Oct 18, 2005 8:11 am    Post subject: Reply with quote

I think the problem is that you want to install a binary package (-K), and that the currently installed version isn't. Try removing it first (emerge -C xorg-x11) then install the binary one.
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Mon Dec 05, 2005 8:06 pm    Post subject: Reply with quote

Moved from Desktop Environments to Duplicate Threads.
See here
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum