Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
liboil compile error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
VanDan
Guru
Guru


Joined: 30 Sep 2002
Posts: 586
Location: Australia

PostPosted: Tue Oct 25, 2005 11:33 am    Post subject: liboil compile error Reply with quote

I'm upgrading to Gnome-2.12. liboil bails out with:

Code:
if /bin/sh ../../libtool --tag=CC --mode=compile powerpc-unknown-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I../..    -Wall -Wa,-mregnames -Wa,-maltivec -D_BSD_SOURCE -D_GNU_SOURCE -I../.. -O2 -maltivec -mabi=altivec -fasm-blocks -O2 -mtune=7450 -mcpu=7450 -maltivec -mabi=altivec -pipe -MT libpowerpc_la-recon8x8_altivec.lo -MD -MP -MF ".deps/libpowerpc_la-recon8x8_altivec.Tpo" -c -o libpowerpc_la-recon8x8_altivec.lo `test -f 'recon8x8_altivec.c' || echo './'`recon8x8_altivec.c; \
then mv -f ".deps/libpowerpc_la-recon8x8_altivec.Tpo" ".deps/libpowerpc_la-recon8x8_altivec.Plo"; else rm -f ".deps/libpowerpc_la-recon8x8_altivec.Tpo"; exit 1; fi
 powerpc-unknown-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I../.. -Wall -Wa,-mregnames -Wa,-maltivec -D_BSD_SOURCE -D_GNU_SOURCE -I../.. -O2 -maltivec -mabi=altivec -fasm-blocks -O2 -mtune=7450 -mcpu=7450 -maltivec -mabi=altivec -pipe -MT libpowerpc_la-recon8x8_altivec.lo -MD -MP -MF .deps/libpowerpc_la-recon8x8_altivec.Tpo -c recon8x8_altivec.c  -fPIC -DPIC -o .libs/libpowerpc_la-recon8x8_altivec.o
recon8x8_altivec.c: In function `recon8x8_intra_altivec':
recon8x8_altivec.c:49: error: parse error before '{' token
recon8x8_altivec.c: In function `recon8x8_inter_altivec':
recon8x8_altivec.c:182: error: parse error before '{' token
recon8x8_altivec.c: In function `recon8x8_inter2_altivec':
recon8x8_altivec.c:400: error: parse error before '{' token
make[3]: *** [libpowerpc_la-recon8x8_altivec.lo] Error 1
make[3]: Leaving directory `/var/tmp/portage/liboil-0.3.3/work/liboil-0.3.3/liboil/powerpc'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/liboil-0.3.3/work/liboil-0.3.3/liboil'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/liboil-0.3.3/work/liboil-0.3.3'
make: *** [all] Error 2

!!! ERROR: dev-libs/liboil-0.3.3 failed.
!!! Function src_compile, Line 21, Exitcode 2
!!! emake failed
!!! If you need support, post the topmost build error, NOT this status message.


I've tried with:

Code:
USE="-altivec" emerge liboil


and get the same problem.
Back to top
View user's profile Send private message
dashnu
l33t
l33t


Joined: 21 Jul 2004
Posts: 703
Location: Casco Maine

PostPosted: Tue Oct 25, 2005 12:48 pm    Post subject: Reply with quote

https://bugs.gentoo.org/show_bug.cgi?id=109270

also If you emerge gst-plugins-ffmpeg let me know if that works.

thanks
_________________
write quit bang
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum