Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Web Server How-To (Apache2 + mod_php + mysql)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
Decode
n00b
n00b


Joined: 26 Apr 2003
Posts: 12

PostPosted: Wed Jun 18, 2003 11:52 am    Post subject: Decode = not awake / not enough coffee Reply with quote

I just found it...

I guess I should try LOOKING a little.

Thanks nepenthe.

Decode
_________________
/--------------------------------------------------\
x ∈ U ∆ V ↔ ( x ∈ U ∪ V ∧ x ¬∈ U ∩ V )
\--------------------------------------------------/
Back to top
View user's profile Send private message
nepenthe
Guru
Guru


Joined: 14 Jul 2002
Posts: 317
Location: Sanford, ME

PostPosted: Wed Jun 18, 2003 9:33 pm    Post subject: Reply with quote

Its all good...I've made 5 billion stupid mistakes... Just glad I could help.
Back to top
View user's profile Send private message
BlackDuck
n00b
n00b


Joined: 28 Jun 2003
Posts: 67
Location: Canberra.au

PostPosted: Mon Jun 30, 2003 3:30 pm    Post subject: Reply with quote

khel,

Thanks for this How-to. I have been following instructions and started "emerge mysql". Part 1 of 9 has completed successfully but Part 2 of 9 has failed. Part 2 is trying to emerge dev-perl/Net-Daemon-0.37 but can't locate File/Spec.pm in @INC at /usr/lib/perl5/5.8.0/ExtUtils/Liblist.pm line 6.
Compilation aborted at /usr/lib/perl5/5.8.0/ExtUtils/Liblist.pm line 6.

Any thoughts or suggestions what I should do next?

Thanx. :?
_________________

Join the unanswered post initiative
Dell GX1 PIII 500 512MB Onboard ATI Rage Pro 3D | HP P1120 21" 1600x1200@85Hz
2 HP Vectra VE PIII 500 512MB Onboard Matrox G200
Back to top
View user's profile Send private message
nepenthe
Guru
Guru


Joined: 14 Jul 2002
Posts: 317
Location: Sanford, ME

PostPosted: Fri Jul 04, 2003 3:22 pm    Post subject: Reply with quote

just a thought but try re-emerging perl
hope it helps =]
Back to top
View user's profile Send private message
vulcan_
n00b
n00b


Joined: 06 May 2003
Posts: 61
Location: Gent, Belgium

PostPosted: Sat Jul 05, 2003 10:19 pm    Post subject: some important corrections Reply with quote

i found this post a good help .. even tho it is Apache 1.37 that I am installing at the moment.

A few things can be done a little more easily:

the LoadModule lines can take advantage of the fact that that installation that emerge does puts links into /etc/apache that point to /usr/lib/apache etc. Thus
Code:

LoadModule php4_module     extramodules/libphp4.so
LoadModule ssl_module        extramodules/libssl.so
LoadModule gzip_module      extramodules/mod_gzip.so

works and is slightly more robust than the absolute paths proposed.

the comments in the apache.conf file warn that you must update the AddModule section that follows the LoadModule items .. and the docs back this up. So I added
Code:

AddModule mod_php4.c
AddModule mod_ssl.c
AddModule mod_gzip.c

but this does not work as Apache cannot find the needed .c files that give the intended module identifiers (as mentioned in the apache docs). So either find the .c files and update these lines or forget it and comment them out.

MTA proposed to put this line into apache.conf
Code:
Include conf/modules.d/41_mod_ssl.default-vhost.conf

but that should be
Code:
Include conf/ssl/ssl.default-vhost.conf

now. I guess the installation has changed since MTA posted.

that is all that I found as of time of writing
_________________
vulcan was a Roman myth - god of smiths
Back to top
View user's profile Send private message
ak
n00b
n00b


Joined: 04 Apr 2003
Posts: 15

PostPosted: Thu Jul 10, 2003 10:10 pm    Post subject: Reply with quote

Great HOW-TO! Thanks a lot!

May I suggest adding the following at the end of apache2.conf file:

Code:

AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps


This way php scripts will be executed properly :)

Best Regards,

ak
Back to top
View user's profile Send private message
ak
n00b
n00b


Joined: 04 Apr 2003
Posts: 15

PostPosted: Fri Jul 11, 2003 8:46 am    Post subject: Reply with quote

Also, the following line is not needed (php 4.3.2 + apache 2.0.47)
Code:

LoadModule php4_module /usr/lib/apache2-extramodules/libphp4.so


Otherwise, it complains at boot that PHP is already loaded (just a warning msg)


Best Regards,

ak
Back to top
View user's profile Send private message
WarMachine
Apprentice
Apprentice


Joined: 15 Jul 2002
Posts: 181

PostPosted: Sat Jul 12, 2003 11:41 pm    Post subject: Reply with quote

ak wrote:
Great HOW-TO! Thanks a lot!

May I suggest adding the following at the end of apache2.conf file:

Code:

AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps


This way php scripts will be executed properly :)

Best Regards,

ak


Just out of curiosity, without this, how are they executed improperly? The only php thing on my site is phpBB and I haven't experienced any problem without those lines.
Back to top
View user's profile Send private message
aridhol
Guru
Guru


Joined: 20 Jan 2003
Posts: 509
Location: Stockholm, Sweden

PostPosted: Mon Jul 14, 2003 4:28 am    Post subject: Reply with quote

Maybe this should be moved to Documentation Tips and Tricks?
_________________
72 of Pitcairn Islands 49 inhabitants use Seti@Home
"If you buy a DVD you have a copy. If you want a backup copy you buy another one."
"Anyone who is capable of getting themselves made President should on no account be allowed to do the job."
Back to top
View user's profile Send private message
Decode
n00b
n00b


Joined: 26 Apr 2003
Posts: 12

PostPosted: Thu Jul 17, 2003 6:13 pm    Post subject: Setting up Email sending for PHP Reply with quote

Hello;

I've been reading some threads on installing mail system for allowing PHP Mail() to work.

This thread recommends setting up qmail for it's quick/easy config.
https://forums.gentoo.org/viewtopic.php?t=25077&highlight=php+email

And a thread on QMail configuration:
https://forums.gentoo.org/viewtopic.php?t=3622&highlight=setup+qmail

I know there's alternatives (Sendmail, etc) but I'm going to try sendmail for this simple demo-server. If this was production, I might try something beefier.

Decode

Note: Let me expound on what I was doing and a frustration I overcame.
The server I am setting up is a simple local webserver so I can run some PHP aps like Achievo and Mantis. The server shouldn't need a full blown mail server installed, all I wanted was to have this box forward all locally generated emails (PHP::mail()) to our normal M$FT Exchange server for handling. Anyway, finding out how to do this was a painful hour and a half Google extravaganza.

Turns out, you can:
Code:
echo ":mymailserver.mydomain.com" >> /var/qmail/control/smtproutes

This will work unless you're dmz, like mine, won't be able to resolve "mymailserver.mydomain.com" Instead, try
Code:
echo ":0.0.0.0" >> /var/qmail/control/smtproutes

where 0.0.0.0 is the ip address of your mailserver.

Refer to ( http://archives.mandrakelinux.com/firewall/2002-08/msg00022.php ) for the details.

I hope this benefits someone. Heh, I'm sure it will benefit me in 3 months when I'm setting up another linux server 'cause my boss realizes that free is alot less than an average $7500/cpu.

Rock
_________________
/--------------------------------------------------\
x ∈ U ∆ V ↔ ( x ∈ U ∪ V ∧ x ¬∈ U ∩ V )
\--------------------------------------------------/
Back to top
View user's profile Send private message
timfreeman
Tux's lil' helper
Tux's lil' helper


Joined: 19 May 2003
Posts: 142
Location: Chicago

PostPosted: Fri Jul 18, 2003 10:10 pm    Post subject: Reply with quote

There is some slightly different advice here, too:

https://forums.gentoo.org/viewtopic.php?t=68136&highlight=mysql

(both this thread and the link have helped, thanks!)
Back to top
View user's profile Send private message
jgrimm73
n00b
n00b


Joined: 24 Mar 2003
Posts: 9
Location: Atlanta, GA

PostPosted: Tue Jul 29, 2003 3:10 pm    Post subject: Re: Apach2 and php4 - libpq.so.2: cannot open shared obje Reply with quote

chatgris wrote:
mxc wrote:
Hi All,

I have emerged apache2 and php4. I have checked the steps as outlined by khel in the first post and all seems ok.

I have my php .so file in /etc/apache2/extramodules.

When I run apache2 start I get the following error

Syntax error on line 57 of /etc/apache2/conf/apache2.conf:
Cannot load /etc/apache2/extramodules/libphp4.so into server: libpq.so.2: cannot open shared object file: No such file or dir

How do I fix this? I know it may be simple to some of you but I am struggling a bit. I need to get to know php/apache/postgres to get a piece of software I want to evaluate, i.e tutos, working.

Thanks
Mark


Edit ****** Ok I have found a libpq.so.3 on my system. How do I edit php4 to use this instead of the .2 version?


libpq.so.2 is postgres interface..

Either you need to install postgres, or compile php with -postgresql

hope that helps.


Thank you for the post, I had been running postgres and phppgadmin previously on this machine and like you said php was still trying to load support for it. I unmerged php and mod_php and remerged with this command:

USE="-X -java -qt -postgres mysql apache2 perl" emerge unmerge php mod_php && emerge -u php mod_php

Everything is working just fine now.

Also I've had instances where when emerging the USE variables in make.conf were ignored. This was mentioned in an earlier post. I've had better luck doing export on the arch= or use= or including them in the command line.

J
_________________
"In an ever evolving quantam universe those that stand still are actually moving backwards"
~Robert Anton Wilson~
Back to top
View user's profile Send private message
chrisis
Tux's lil' helper
Tux's lil' helper


Joined: 22 May 2003
Posts: 112
Location: Auckland

PostPosted: Mon Sep 15, 2003 2:26 am    Post subject: Re: Web Server How-To Reply with quote

Buzzz wrote:
khel wrote:

I'm not new to linux but really new to Gentoo :-) anyway, for example what steps should be taken after finishing with Installation guide?

1. emerge xinetd (any use variables??)
2. rc-update add xinetd



I don't use xinetd, I think it is only confusing. All access control can be done in apache itself or with your firewall. I just like the stand-alone way of doing things.


xinetd is useful not only for access control but for saving resources. xinetd can start and stop services as and when they are needed so that the maximum amount of memory/cpu is available to the system. In other words, if no-one is making http requests to your server this minute, why have httpd eating up memory/cpu? If an http request is received, xinetd starts up httpd, which services the request; after a given period of time, if there are no further http requests, xinetd stops httpd, freeing those resources up again.

This is particularly useful when you have a machine doing lots of jobs with less-than-desirable resources (like my Celery 300 with 128mb RAM ;-))

The only disadvantage is a momentary knock in performance while xinetd starts httpd for the first time (remember, it leaves httpd running as long as there are further requests... only when the requests stop coming does it shut down httpd again...). So for a computer that is ONLY going to be a webserver, you may want to leave out xinetd and start httpd directly.

khel wrote:

I'm not new to linux but really new to Gentoo :-) anyway, for example what steps should be taken after finishing with Installation guide?

1. emerge xinetd (any use variables??)
2. rc-update add xinetd



If you do decide to use xinetd to start/stop services, each service will have to have a config file in /etc/xinetd.d/ Some services are configured to use xinetd, so they will create their own config file in /etc/xinetd.d. For eg, swat creates a file called /etc/xinetd.d/swat and all you have to do to make swat actually USE xinetd, edit the file and change

Code:
         disable         = yes


to:
Code:
          disable        = no


If you'd like to see code for /etc/xinetd.d/httpd, let me know, I'll post it once I get home (my home server which servers http requests infrequently uses xinetd to listen for http request).

To summarize: xinetd, IMHO, doesn't add confusion -- it adds a level of configurability. For a server that is sharing web serving with other tasks, it is ideal to use, and not difficult at all to setup. You just need to spend some time designing your system, and if xinetd fits in with that design, go ahead and emerge it!

:-)
_________________
But the situation seemed to call for witty repartee. "Huh?" I said.
Back to top
View user's profile Send private message
Passe-Poil
Tux's lil' helper
Tux's lil' helper


Joined: 18 Feb 2004
Posts: 139
Location: Québec, QC, Canada

PostPosted: Fri Feb 20, 2004 8:03 pm    Post subject: xinetd HOWTO ??? Reply with quote

I would like to see your /etc/xinetd.d/httpd !!
does httpd start on-demand or is the xinetd service configured so it only passes the requests to the server (internal thingy I think ??)

A xinetd HOWTO would be SOOOO appreciated !!!
_________________
Violence is the last refuge of the incompetent.
Back to top
View user's profile Send private message
St_Andrew
n00b
n00b


Joined: 07 Feb 2004
Posts: 37

PostPosted: Wed Mar 17, 2004 11:59 pm    Post subject: Reply with quote

gah, i have no "APACHE2_OPTS="-D SSL -D PHP4"" in my apache2.conf file, what's wrong with me?! tried to add it by myself, but i get an error when tring to start apache then...

Code:
 * Apache2 has detected a syntax error in your configuration files:
Syntax error on line 17 of /etc/apache2/conf/apache2.conf:
Invalid command 'APACHE2_OPTS="-D', perhaps mis-spelled or defined by a module not included in the server configuration


can't get it to work, need to have it until tomorrow though :(

thanks in advance... :)
Back to top
View user's profile Send private message
timfreeman
Tux's lil' helper
Tux's lil' helper


Joined: 19 May 2003
Posts: 142
Location: Chicago

PostPosted: Thu Mar 18, 2004 1:55 am    Post subject: Reply with quote

is it in /etc/conf.d/apache2 ? or /etc/apache2/conf/apache2.conf ? it should be in the first one, does that work?
_________________
|||
Back to top
View user's profile Send private message
St_Andrew
n00b
n00b


Joined: 07 Feb 2004
Posts: 37

PostPosted: Thu Mar 18, 2004 6:45 am    Post subject: Reply with quote

timfreeman wrote:
is it in /etc/conf.d/apache2 ? or /etc/apache2/conf/apache2.conf ? it should be in the first one, does that work?


lol thanks... that did the thing, it was in /etc/conf.d/apache2 =)

thanks!
Back to top
View user's profile Send private message
poonix
n00b
n00b


Joined: 23 Aug 2004
Posts: 5

PostPosted: Sat Sep 04, 2004 8:17 am    Post subject: piggy backing on this topic Reply with quote

I am trying to get php working. I've followed all these steps, and the error message I get when I restart apache2 is

* Apache2 has detected a syntax error in your configuration files:
Syntax error on line 24 of /etc/apache2/conf/apache2.conf: Cannot load /usr/lib/apache-extramodules/libphp4.so into server: /usr/lib/apache-extramodules/libphp4.so: undefined symbol: ap_block_alarms

Anyone know how I can fix this?

teh poo
_________________
http://www.poonix.net
Back to top
View user's profile Send private message
tightcode
Tux's lil' helper
Tux's lil' helper


Joined: 23 Mar 2004
Posts: 110

PostPosted: Sun Sep 05, 2004 10:00 pm    Post subject: Maybe not much help, but... Reply with quote

Hello Poonix,

This may not come as much help, but your path doesn't look like the standard path I have in my gentoo installation. For me the path to libphp4.so is:
/usr/lib/apache2/extramodules/libphp4.so

I do not know if you changed your folder structure and thus intentionally have libphp4.so in a non default folder, resulting in that not being related, or if you have a typo in your config.

In any case I did a google search for "libphp4.so: undefined symbol: ap_block_alarms" (removing the non standard path to increase results) and it found quite a few things (some dating back to 2002?) I didn't take the time to really read through them but the link to the results is here:
http://www.google.com/search?q=libphp4.so%3A+undefined+symbol%3A+ap_block_alarms&btnG=Search&hl=en&lr=&ie=ISO-8859-1

I only offer this because I know if you were searching for your whole error message (including non default paths) it was probably not returning many results.

I hope this helps if not post back and I will keep an eye on this to see if I can be of more help.

TightCode
Back to top
View user's profile Send private message
_mikec_
Guru
Guru


Joined: 22 May 2004
Posts: 386

PostPosted: Tue Feb 08, 2005 10:57 pm    Post subject: Reply with quote

a more simple way is this yet very OUTDATED, taken from the GentooX for xbox website:
http://gentoox.shallax.com/modules.php?name=Sections&op=viewarticle&artid=10


Quote:
This tutorial guides you in setting up your apache server:

emerge sync
emerge apache mod_php php
nano -w /etc/conf.d/apache2
Find the APACHE2_OPTS line and make sure it reads:
APACHE_OPTS="-D SSL -D PHP4"
rc-update add apache2 default
nano -w /etc/apache2/conf/apache2.conf
Change "#ServerName localhost" to "ServerName whatever".
Obviously change "whatever" to what you want. Also note that the "#" has been removed from the beginning.
mkdir -p /var/log/apache2; mkdir -p /usr/lib/apache2/logs
/etc/init.d/apache2 start

There, all done. Now you have an Apache webserver with php support that autoloads and has been started. To push you in the right direction… All files should have .html extensions and “index.html” is the default index file (i.e. autoloaded when you visit the website). All files go in /var/www/localhost/htdocs/ (there will already be some files in there, just delete them all – “rm –rf /var/www/localhost/htdocs/*” then put your own in there!).


read before using this guide because i think the installation directory /var/www/localhost is different.
_________________
(8 Mars 2005 - 07:52:46)
(18 September 2017 - 11:25:35)


Last edited by _mikec_ on Sun Feb 13, 2005 1:32 am; edited 1 time in total
Back to top
View user's profile Send private message
Rush[ZA]
n00b
n00b


Joined: 01 Dec 2004
Posts: 56
Location: Johannesburg

PostPosted: Sat Feb 12, 2005 10:42 pm    Post subject: Reply with quote

I followed this guide to the T and get errors

is it outdated?

from here



Quote:
hen restart apache

/etc/init.d/apache2 -k restart


I get these errors

What should I change?


Code:
* Usage: apache2 { start|stop|restart|reload }
 *        apache2 without arguments for full help
server distfiles # /etc/init.d/apache2 start
 * You don't appear to have the mysql database installed yet.
 * Please run /usr/bin/mysql_install_db to have this done...
 * Apache2 has detected a syntax error in your configuration files:
Syntax error on line 57 of /etc/apache2/conf/apache2.conf:
Cannot load /usr/lib/apache2-extramodules/libphp4.so into server: /usr/lib/apache2-extramodules/libphp4.so: cannot open shared object file: No such file or directory
server distfiles # /usr/bin/mysql_install_db
Preparing db table
Preparing host table
Preparing user table
Preparing func table
Preparing tables_priv table
Preparing columns_priv table
Installing all prepared tables

To start mysqld at boot time you have to copy support-files/mysql.server
to the right place for your system

PLEASE REMEMBER TO SET A PASSWORD FOR THE MySQL root USER !
To do so, issue the following commands to start the server
and change the applicable passwords:
  /etc/init.d/mysql start
  /usr/bin/mysqladmin -u root -h server password 'new-password'
  /usr/bin/mysqladmin -u root password 'new-password'
Depending on your configuration, a -p option may be needed
in the last command. See the manual for more details.

You can start the MySQL daemon with:
cd /usr ; /usr/bin/mysqld_safe &

You can test the MySQL daemon with the benchmarks in the 'sql-bench' directory:
cd sql-bench ; perl run-all-tests

Please report any problems with the /usr/bin/mysqlbug script!

The latest information about MySQL is available on the web at
http://www.mysql.com
Support MySQL by buying support/licenses at https://order.mysql.com



then I try and set the passwd and this is what I get

Code:
server distfiles #  /usr/bin/mysqladmin -u root -h server password *********
/usr/bin/mysqladmin: connect to server at 'server' failed
error: 'Host 'server.bursting' is not allowed to connect to this MySQL server'
server distfiles #

_________________
<------- This ad space for rent ------>
Back to top
View user's profile Send private message
j-m
Retired Dev
Retired Dev


Joined: 31 Oct 2004
Posts: 975

PostPosted: Sat Feb 12, 2005 11:28 pm    Post subject: Reply with quote

Rush[ZA] wrote:
I followed this guide to the T and get errors

is it outdated?

from here


Yes, this guide is very outdated...

Code:

APACHE_OPTS="-D SSL -D PHP4"


is basically all you need from the Apache side.

As for the MySQL problem, you are either trying to connect to MySQL from another computer, which is not allowed in default configuration, or you should omit the -h server part completely if you are connecting from localhost.

Don´t run mysql_install_db, run the command as advised after emerging MySQL. Then run mysql_secure_installation and this will set sane permissions, delete guest user, etc.
Back to top
View user's profile Send private message
Rad
Guru
Guru


Joined: 11 Feb 2004
Posts: 387
Location: Berne, Switzerland

PostPosted: Sat Feb 12, 2005 11:39 pm    Post subject: Reply with quote

Yes, the guide's quite outdated... you dont get php4 anymore when using ACCEPT_KEYWORDS="~x86", hence "-D PHP4" wont work, I guess that's what caused the first error with php4. EDIT: Sorry, I made a mistake. I think "-D PHP4" should work (at least here it loads php5 anyways), but it has not got the same config - it lacks some entries which are labelled bugfix.

Also, setting said ACCEPT_KEYWORDS is considered bad practice now. If you really want the apache from gentoo unstable (I don't know if you even do), you should set that up in /etc/portage/package.keywords (example: add a line saying "net-www/apache ~x86").
Else you'll get your whole system migrated to gentoo unstable when you next do emerge -u world, which probably is not what you want...


I think best would be to remove the ACCEPT_KEYWORDS - Statement from your make.conf if you don't want to run Gentoo unstable and then refer to this HOWTO to perform all appropriate changes:
http://gentoo-wiki.com/HOWTO_Apache2_with_PHP_MySQL
Back to top
View user's profile Send private message
orvtech
Tux's lil' helper
Tux's lil' helper


Joined: 28 Aug 2004
Posts: 115
Location: US. Florida

PostPosted: Sat Feb 26, 2005 11:00 pm    Post subject: Re: Web Server How-To (Apache2 + mod_php + mysql) Reply with quote

khel wrote:
I couldn't find any step-by-step instructions on setting up a webserver, so, after lurking on this forum for a while, I decided to share my experience on the subject. Anyway, to make the long story short, that's what I did to make Apache2/mod_php/mysql combo work to suite my needs :-)

edit /etc/make.conf and add
ACCEPT_KEYWORDS="~x86"
USE="-X -gtk -gnome -alsa -qt -qtmt -pdflib mysql apache2 pam ssl"


and don't forget to run env-update after changing the make.conf :-)

emerge mysql
rc-update add mysqld default
emerge netpbm
(image manipulation package required by Gallery)


emerge apache
rc-update add apache2 default


then
emerge mod_php
emerge clean


edit /etc/conf.d/apache2 and add this line
APACHE_OPTS="-D SSL -D PHP4"

edit /etc/apache2/conf/apache2.conf and add this line
LoadModule php4_module /usr/lib/apache2-extramodules/libphp4.so

then restart apache

/etc/init.d/apache2 -k restart

p.s. If you change "DocumentRoot" in apache2.conf, you'll need to change it in commonapahche2.conf as well.
Look for

###This should be changed to whatever you set Document root to.
###
<Directory /home/httpd/htdocs>

And in /etc/apache2/conf/modules.d/41_mod_ssl.default-vhost.conf for SSL to work

So far it works just fine for me, but time will show how stable and bug free it is :-)

If you have any comment/suggestions - feel free to post :-)
I hope this will be useful at leas to somebody.


Ohhh thanks a lot dude for this tutorial i have been looking for this for about 2 weeks now, i even desided to run fedora as a web server ( I Know .. Im so so so Sorry, i will make it up today with this guide). i will post here my experince.

Thanks again
_________________
http://orvtech.com
http://www.linuxevolution.org
Back to top
View user's profile Send private message
zephid
n00b
n00b


Joined: 07 Sep 2003
Posts: 39
Location: Denmark

PostPosted: Fri Mar 11, 2005 8:44 am    Post subject: Re: Web Server How-To (Apache2 + mod_php + mysql) Reply with quote

khel wrote:

edit /etc/make.conf and add
ACCEPT_KEYWORDS="~x86"
USE="-X -gtk -gnome -alsa -qt -qtmt -pdflib mysql apache2 pam ssl"


and don't forget to run env-update after changing the make.conf :-)

To start with, i'll say your guide looks rather good, but one thing I find very interresting is your ACCEPT_KEYWORDS="~x86" in make.conf? Are you out off your mind? :) A global ACCEPT_KEYWORDS could destroy your gentoo installation, so here is what I would have done instead.

Example, we want PHP5 instead of PHP4, this is what we will do:
Code:
echo "dev-php/php ~x86" >> /etc/portage/packages.keywords
echo "dev-php/mod_php ~x86" >> /etc/portage/packages.keywords

That way it's only php and mod_php there will be installed with the ~x86 args. :)
Hope you got the point :)


Last edited by zephid on Mon Apr 04, 2005 9:26 am; edited 2 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3  Next
Page 2 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum