Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] portage wil kde downgraden
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Dutch
View previous topic :: View next topic  
Author Message
meeuwer
n00b
n00b


Joined: 04 May 2005
Posts: 6

PostPosted: Wed Nov 09, 2005 2:42 pm    Post subject: [solved] portage wil kde downgraden Reply with quote

Sinds enige tijd (ik dacht eerst dat het een foutje in portage was dat zichzelf wel zou oplossen) krijg ik als output van emerge -upv world
dat ik kdelibs 3.4.1 (en alle bijhorende dependencies) moet installeren ipv kde3.4.3 dat nu zonder problemen draait. 8O

[ebuild UD] kde-base/kdelibs-3.4.1-r1 [3.4.3] +alsa -arts +cups -debug -doc -jpeg2k -kdeenablefinal -kerberos -openexr -spell +ssl +tiff -xinerama -zeroconf 0 kB
[ebuild NS ] sys-kernel/gentoo-sources-2.6.13-r5 -build -doc +symlink (-ultra1) 207 kB
[...]

Ik heb al verschillende keren een emerge sync gedaan en ondertussen ook alle packages geupdate die geen problemen maken van kde.
In package.mask heb ik enkel de nieuwste k3b en cdrdao gemasked staan omdat na upgrade ik geen enkel cdtje of dvdtje kan branden.
Als ik k3b & cdrdao unemerge en opnieuw emerge -upv world probeer krijg ik het zelfde resultaat als hierboven. :cry:

Heeft er iemand een idee wat er fout gaat? (ik draai x86_64 fyi)


Last edited by meeuwer on Wed Nov 09, 2005 5:07 pm; edited 2 times in total
Back to top
View user's profile Send private message
BlackEdder
Advocate
Advocate


Joined: 26 Apr 2004
Posts: 2588
Location: Dutch enclave in Egham, UK

PostPosted: Wed Nov 09, 2005 2:54 pm    Post subject: Reply with quote

Probeer is een emerge -uvtp world om te zien welk programma kdelibs-3.4.1 wil installeren
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Wed Nov 09, 2005 3:00 pm    Post subject: Reply with quote

echo "=kde-base/kdelibs-3.4.3 ~amd64" >> /etc/portage/package.keywords
En hetzelfde voor alle dependencies.
Of je moet je KEYWORDS in /etc/make.conf op ~amd64 willen zetten.

Ik weet niet precies wat je gedaan hebt, maar op een of andere manier heb je een ~amd64 versie van kde geinstalleerd terwijl je KEYWORDS geen ~amd64 bevat en je package.keywords die kde packages ook niet bevat.
ACCEPT_KEYWORDS="~amd64" emerge kde <- zoiets zou je gedaan kunnen hebben, en dan weet je nu waarom dat een slecht idee is :wink:
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
meeuwer
n00b
n00b


Joined: 04 May 2005
Posts: 6

PostPosted: Wed Nov 09, 2005 5:05 pm    Post subject: Reply with quote

nixnut wrote:
/etc/portage/package.keywords
Ik weet niet precies wat je gedaan hebt, maar op een of andere manier heb je een ~amd64 versie van kde geinstalleerd terwijl je KEYWORDS geen ~amd64 bevat en je package.keywords die kde packages ook niet bevat.

Nou, je slaat de nagel op de kop. :lol:
Ik was een tijd geleden wat aan het rondneuzen in de wiki, en daar stond een scriptje om de 'overtollige' entries in je /etc/portage/package.* er uit te halen. Blijkbaar vond die kde niet nodig of ben ik weer wat te ijverig geweest :oops: .

Ik heb inderdaad geen ~amd64 in mn profiel, omdat ik liever zelf beslis wat ik unstable draai en wat niet..
Ik ga wel even weer op zoek naar dat commandootje dat ineens alle nodige kde-progsels in je package.keywords stopte
(dat is het minder leuke aspect aan split-ebuilds). :P

thanks
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Dutch All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum