Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge --newuse world -Dpv frustration
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3231
Location: Gainesville, Florida

PostPosted: Thu Nov 10, 2005 11:13 pm    Post subject: emerge --newuse world -Dpv frustration Reply with quote

I just removed all gnome packages I could find, in order to make my system pure kde, and clean out stuff I never use. The objective is to rid the sytem of all the myriad of gnome libs, etc., so I also unmerged anything i thought was dependent on gnome related packages. Also added -gnome to my use flags. I've read all the related docs, and forum posts, but still don't quite understand why I still get the following-

emerge --newuse still wants to reinstall lots of unwanted (by me) gnome packages I removed. I'd surely appreciate some expert pointers on what I need to do. Or am I going to be stuck with a certain number of unwanted gnome stuff no matter what, because other packages seem to require the gnome libs/packages? I'd be able to live with xfce4, in addition to my kde system, but this is pretty irritating.

mymachine wrc # emerge --newuse world -Dpv
>>> --newuse implies --update... adding --update to options.

These are the packages that I would merge, in order:

Calculating world dependencies ...done!
[ebuild N ] gnome-extra/libgsf-1.13.2 -bzip2 -debug -doc -gnome -static 0 kB
[ebuild U ] media-gfx/sane-backends-1.0.16-r4 [1.0.16-r2] -gphoto2 +ipv6 +usb -v4l 0 kB
[ebuild N ] gnome-base/gnome-libs-1.4.2 -doc +kde +nls 0 kB
[ebuild R ] dev-perl/gtk-perl-0.7009-r2 -applet -gnome* -gnome-print -gtkhtml +opengl 0 kB
[ebuild NS ] gnome-base/orbit-2.12.4 -debug -doc +ssl -static 0 kB
[ebuild N ] gnome-base/gconf-2.12.0 -debug -doc -static 0 kB
[ebuild U ] dev-lisp/cmucl-19b [19a-r1] -doc -lesstif -nosource 0 kB
[ebuild U ] media-video/transcode-0.6.14-r3 [0.6.14-r1] +3dnow +X -a52 (-altivec) -dv -dvdread +encode -fame +gtk -imagemagick* +jpeg -lzo -mjpeg +mmx +mpeg -network +ogg -pvm +quicktime +sdl -sse -sse2 -theora +truetype -v4l +vorbis +xml2 -xvid 0 kB
[ebuild R ] media-libs/xine-lib-1.1.0-r6 +X -a52 -aac +aalib +alsa (-altivec) +arts -cle266 -directfb -dts -dvd -dxr3 +esd -fbcon -ffmpeg +flac -gnome* -i8x0 -imagemagick* +ipv6 -libcaca +mad -mng +nls -nvidia +opengl +oss -samba +sdl +speex -theora -v4l -vcd -vidix +vorbis -win32codecs -xinerama +xv -xvmc 0 kB
[ebuild R ] media-sound/rosegarden-4.1.0-r1 +arts* -debug +jack -kdeenablefinal -xinerama 0 kB
[ebuild R ] media-libs/raptor-1.4.7 +curl -gnome* +ssl +xml2 0 kB
[ebuild N ] gnome-base/libglade-2.5.1 -debug -doc 0 kB
[ebuild N ] gnome-base/libbonobo-2.10.1 -debug -doc -static 0 kB
[ebuild N ] gnome-base/gnome-mime-data-2.4.2 -debug 0 kB
[ebuild N ] gnome-base/gnome-vfs-2.12.1.1 -debug -doc -gnutls -hal -howl +ipv6 -samba +ssl 0 kB
[ebuild N ] gnome-base/libgnome-2.12.0.1 -debug -doc +esd -static 0 kB
[ebuild N ] gnome-base/libbonoboui-2.10.1-r1 +X -debug -doc -static 0 kB
[ebuild N ] gnome-base/gnome-keyring-0.4.5 -debug 0 kB
[ebuild N ] gnome-base/libgnomeui-2.12.0 -debug -doc +jpeg -static 0 kB
[ebuild N ] gnome-extra/evolution-data-server-1.4.1 -debug -doc +ipv6 -kerberos -krb4 -ldap -mozilla -nntp +ssl -static 0 kB
[ebuild N ] x11-themes/gnome-icon-theme-2.12.1 -debug 0 kB
[ebuild N ] x11-themes/gnome-themes-2.12.1 -accessibility -debug 0 kB
[ebuild R ] app-cdr/cdrdao-1.2.0-r1 -debug +encode -gnome* -pccts 0 kB
[ebuild N ] x11-wm/fluxbox-0.9.14-r1 -gnome +imlib +kde +nls +truetype -xinerama 0 kB

Total size of downloads: 0 kB
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r2, gcc-9.1.0 kernel-5.0.14-gentoo USE=experimental
Back to top
View user's profile Send private message
dgaffuri
Advocate
Advocate


Joined: 05 Jun 2005
Posts: 2078
Location: Italy

PostPosted: Thu Nov 10, 2005 11:19 pm    Post subject: Reply with quote

Add -gtk -gtk2 to USE variable in /etc/make.conf. The -t flag with emerge -pv may help you finding why unwanted packages are required.
_________________
Adopt an unanswered post
If you feel that your problem has been solved please edit the top post and add [solved] to the subject
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3231
Location: Gainesville, Florida

PostPosted: Fri Nov 11, 2005 12:08 am    Post subject: Reply with quote

Thanks dgaffuri,

That clued me in- I think I can go from here and figure it out- just started an emerge --update --deep --newuse world.

I guess I should remove this thread, as I subsequently have found a bunch of other posts on the subject., but I'll wait a day and see if I mess up first..

Hmmm..... Or can the original poster remove the thread after someone answers?
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r2, gcc-9.1.0 kernel-5.0.14-gentoo USE=experimental
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Fri Nov 11, 2005 12:20 am    Post subject: Reply with quote

Use emerge -puDvNt to see a full list with all the related deps in a tree like hierarchy. That can give you an idea of the package that need some gnome libs. Generally, I would not encourage you to use -gtk -gtk2 unless you fully understand the implications. See that gtk and gtk2 are not necesarily gnome apps. Assuming that you know what you are doing, another thing to note is that usually, gtk and gtk2 has nothing to do with all these apps. Some programs might offer an alternative interface using gtk or gtk2 and usually they dont need gnome libraries at all (no, gtk is not a gnome library, but the Gimp ToolKit) and now that I named it, remember that you will need gtk to run the gimp.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Wed Jan 04, 2006 5:22 pm    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads in favour of GF8: Why is <y> getting pulled in when I emerge <x>?
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum