Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Quik at the Boot Line
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
samus8zero2x
n00b
n00b


Joined: 08 Jul 2005
Posts: 30
Location: OKC, OK

PostPosted: Fri Nov 11, 2005 3:08 pm    Post subject: Quik at the Boot Line Reply with quote

Hello,

I've just finished several days of set up to get Gentoo working on an OldWorld G3. The step before I replaced the Debian install files was going to be to attempt to boot the new kernel from quik (mainly to see if it would actually recognize the file to boot it), and if it saw it, I was going to replace all of the Debian system files with the Gentoo system files.

Anyway, I reconfigured quik.conf to add a second boot section for the new kernel (which was located at /gentoo/boot). I also kept the original section for my Debian kernel (located at /boot). I wrote the later version of quik which I emerged from Gentoo to the drive (as opposed to the one that came with the Debian install which doesn't support larger kernels), but now quik won't boot either kernel!

Does any one know how to use the quik boot command line to directly boot to a kernel image? All of my attempts have failed. It says to use the format [Device:][partition]/[path], but it seems to not identify any of the devices I try to give it (such as hda, hda0, ata/ata-disk@0, etc.). My only other alternative is to try to find the Debian boot disk and monkey around with quik.conf until it works.

And on the side...can you specify a folder as the root partition in quik...like root=/dev/hda4/gentoo instead of /dev/hda4 (which is the root for the Debian install)?

Thanks.
_________________
~DMP
Back to top
View user's profile Send private message
samus8zero2x
n00b
n00b


Joined: 08 Jul 2005
Posts: 30
Location: OKC, OK

PostPosted: Fri Nov 11, 2005 9:31 pm    Post subject: Reply with quote

I solved my own problem. About a year ago, when I set up my G3, I had to use ide0/disk@0 as the boot device in OpenFirmware. I needed to use that instead of ata0/ata-disk@0, which is what almost all of the quik how-to's show. So, a standard boot line would look something like:

boot> ide0/disk@0:4/boot/vmlinux

Maybe this will help others out there.

As for the second question, Quik does not appear to really care about the "root=" parameter. The fstab (as far as I could tell) would not load /dev/hda4/gentoo as a root partition and required /dev/hda4 instead, resulting in a kernel panic rather than a quik error. Even if you set root=/dev/hda4/gentoo, quik still looks in /dev/hda4 as the root when loading kernel images.

Kudos to quik 2.1.6...it works TONS better than quik 2.0. I will migrate the box to Gentoo, then it is on to patching the kernel for openMosix!

I will be making my own HOW-TO on how to get OldWorld Beige G3s up and running with Gentoo as soon as I have the bumps smoothed out.

Thanks.
_________________
~DMP
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum