Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
many automake versions installed
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
krigav
Tux's lil' helper
Tux's lil' helper


Joined: 10 Nov 2005
Posts: 121

PostPosted: Fri Nov 11, 2005 6:26 pm    Post subject: many automake versions installed Reply with quote

I've installed gentoo from stage 3 using the Jackass package. After a complete upgrade of the system using emwrap I've 6 (!) versions of automake installed on my system. There is automake in the versions 1.7.9-r1, 1.8.5-r3, 1.9.6-r1, 1.5, 1.4_p6 and 1.6.3.

Who can I remove the unneeded versions without demaging the system? Should I remove any version of automake at all?

my emerge info:

Gentoo Base System version 1.6.13
Portage 2.0.51.22-r3 (default-linux/x86/2005.1, gcc-3.4.4, glibc-2.3.5-r3, 2.6.13.4
i686)
=================================================================
System uname: 2.6.13.4 i686 Pentium III (Coppermine)
dev-lang/python: 2.3.5, 2.4.2
sys-apps/sandbox: 1.2.12
sys-devel/autoconf: 2.13, 2.59-r6
sys-devel/automake: 1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils: 2.15.92.0.2-r10
sys-devel/libtool: 1.5.20
virtual/os-headers: 2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium3 -pipe -O2 -momit-leaf-frame-pointer -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config
/usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=pentium3 -pipe -O2 -momit-leaf-frame-pointer -fomit-frame-pointer
-fvisibility-inlines-hidden"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks nodoc noinfo sandbox sfperms strict"
GENTOO_MIRRORS="http://mirror.switch.ch/mirror/gentoo/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="x86 X alsa apm arts avi berkdb bitmap-fonts bmp bzip2 cdr crypt encode expat
gdbm gif gtk gtk2 imlib ipv6 jpeg kde libg++ libwww mad motif mp3 mpeg ncurses nptl
ogg oggvorbis opengl pam pdflib perl png python qt quicktime readline sdl ssl tcpd
truetype truetype-fonts type1-fonts udev vorbis xml2 xv zlib userland_GNU
kernel_linux elibc_glibc"
Unset: ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS

Thank you.
Back to top
View user's profile Send private message
Dizzutch
Guru
Guru


Joined: 09 Nov 2004
Posts: 463
Location: Worcester, MA

PostPosted: Fri Nov 11, 2005 6:30 pm    Post subject: Reply with quote

you can try
Code:

emerge -P automake

that should do the trick
Back to top
View user's profile Send private message
El_Presidente_Pufferfish
Veteran
Veteran


Joined: 11 Jul 2002
Posts: 1179
Location: Seattle

PostPosted: Fri Nov 11, 2005 6:31 pm    Post subject: Reply with quote

I'm pretty sure it's completely normal to have multiple versions of automake installed.
Back to top
View user's profile Send private message
Halcy0n
Developer
Developer


Joined: 17 Sep 2003
Posts: 1682
Location: Freehold, NJ

PostPosted: Fri Nov 11, 2005 6:32 pm    Post subject: Reply with quote

Its normal to have them all. Some things depend on having an older version of automake.
_________________
Mark Loeser
http://www.halcy0n.com
Back to top
View user's profile Send private message
krigav
Tux's lil' helper
Tux's lil' helper


Joined: 10 Nov 2005
Posts: 121

PostPosted: Fri Nov 11, 2005 6:42 pm    Post subject: Reply with quote

So it's recommended to keep all the versions on the system despite the redundancy? Is it to high-risk to purge all of the old versions, and to keep just the newest one (1.8.5-r)?

Can I expect a lot of problems if I remove them, and can I reinstall the old versions without much problems if some build errors, because of missing old versions of automake, arise?
Back to top
View user's profile Send private message
Dizzutch
Guru
Guru


Joined: 09 Nov 2004
Posts: 463
Location: Worcester, MA

PostPosted: Fri Nov 11, 2005 6:46 pm    Post subject: Reply with quote

you can purge, but if you run into an ebuild which requires a different version, it will install it, or error out saying automake1.4 can't be found, so you just have to install it manually.
Back to top
View user's profile Send private message
Earthwings
Bodhisattva
Bodhisattva


Joined: 14 Apr 2003
Posts: 7753
Location: Karlsruhe, Germany

PostPosted: Fri Nov 11, 2005 6:51 pm    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads in favour of post 2017323
_________________
KDE
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum