Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
JUMPDRIVE USB will not mount/automount (Gnome 2.12) Solved
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
heavyt
Guru
Guru


Joined: 03 Mar 2003
Posts: 498
Location: Matrix (Washington,DC)

PostPosted: Sat Nov 12, 2005 3:54 am    Post subject: JUMPDRIVE USB will not mount/automount (Gnome 2.12) Solved Reply with quote

I can't get a JumpDrive Sport usb drive to mount or automount on my TiBook. I have Gnome 2.12 setup with hal, dbus, pmount, and gamin to take care of automounting. When my jumpdrive is plugin Nautilus displays an icon for it (not on the desktop but in the window) but I get the following errors when I try to mount;

Code:

Unable to mount the selected volume. The volume is probably in a format that cannot be mounted.
mount: wrong fs type, bad option, bad superblock on /dev/sda1,
       missing codepage or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so


Code:

# dmesg
usb 1-1: new full speed USB device using ohci_hcd and address 2
scsi0 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 2
usb-storage: waiting for device to settle before scanning
  Vendor: LEXAR     Model: JUMPDRIVE SPORT   Rev: 1000
  Type:   Direct-Access                      ANSI SCSI revision: 00
SCSI device sda: 1010784 512-byte hdwr sectors (518 MB)
sda: Write Protect is off
sda: Mode Sense: 43 00 00 00
sda: assuming drive cache: write through
SCSI device sda: 1010784 512-byte hdwr sectors (518 MB)
sda: Write Protect is off
sda: Mode Sense: 43 00 00 00
sda: assuming drive cache: write through
 sda: sda1
Attached scsi removable disk sda at scsi0, channel 0, id 0, lun 0
Attached scsi generic sg0 at scsi0, channel 0, id 0, lun 0,  type 0
usb-storage: device scan complete
Unable to load NLS charset iso8859-1
FAT: IO charset iso8859-1 not found


Code:

# fdisk -l

Disk /dev/hda: 40.0 GB, 40007761920 bytes
255 heads, 63 sectors/track, 4864 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Disk /dev/hda doesn't contain a valid partition table

Disk /dev/sda: 517 MB, 517521408 bytes
128 heads, 32 sectors/track, 246 cylinders
Units = cylinders of 4096 * 512 = 2097152 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1         247      505375+   4  FAT16 <32M
Partition 1 has different physical/logical endings:
     phys=(249, 127, 32) logical=(246, 98, 31)

I can mount this jumpdrive on suse, ubuntu, etc so I know this drive works fine also my usb printer has no problem. :cry:


Last edited by heavyt on Tue Nov 22, 2005 3:56 am; edited 1 time in total
Back to top
View user's profile Send private message
gentoo_dude
l33t
l33t


Joined: 08 May 2004
Posts: 645
Location: Washington, DC

PostPosted: Sat Nov 12, 2005 4:14 am    Post subject: Reply with quote

Does your kernel have this built in?
Quote:
Unable to load NLS charset iso8859-1
FAT: IO charset iso8859-1 not found

Also VFAT and MS-DOS FAT support built in?
Back to top
View user's profile Send private message
heavyt
Guru
Guru


Joined: 03 Mar 2003
Posts: 498
Location: Matrix (Washington,DC)

PostPosted: Sat Nov 12, 2005 2:29 pm    Post subject: Reply with quote

gentoo_dude wrote:
Does your kernel have this built in?
Quote:
Unable to load NLS charset iso8859-1
FAT: IO charset iso8859-1 not found

Also VFAT and MS-DOS FAT support built in?


Yes, here are the setting
Code:

#
# DOS/FAT/NT Filesystems
#
CONFIG_FAT_FS=y
CONFIG_MSDOS_FS=y
CONFIG_VFAT_FS=y
CONFIG_FAT_DEFAULT_CODEPAGE=437
CONFIG_FAT_DEFAULT_IOCHARSET="iso8859-1"
CONFIG_NTFS_FS=y
# CONFIG_NTFS_DEBUG is not set
CONFIG_NTFS_RW=y

This has got the best of me. :cry:
Back to top
View user's profile Send private message
oliver
Apprentice
Apprentice


Joined: 25 Jun 2003
Posts: 170

PostPosted: Sat Nov 19, 2005 11:15 pm    Post subject: Reply with quote

heavyt wrote:

#
# DOS/FAT/NT Filesystems
#
CONFIG_FAT_FS=y
CONFIG_MSDOS_FS=y
CONFIG_VFAT_FS=y
CONFIG_FAT_DEFAULT_CODEPAGE=437
CONFIG_FAT_DEFAULT_IOCHARSET="iso8859-1"
CONFIG_NTFS_FS=y
# CONFIG_NTFS_DEBUG is not set
CONFIG_NTFS_RW=y
[/code]
This has got the best of me. :cry:



Make sure it's also set in NLS (in file-systems --> native language support)

Code:
#
# Native Language Support
#
CONFIG_NLS=y
CONFIG_NLS_DEFAULT="iso8859-1"
CONFIG_NLS_ISO8859_1=y
Back to top
View user's profile Send private message
heavyt
Guru
Guru


Joined: 03 Mar 2003
Posts: 498
Location: Matrix (Washington,DC)

PostPosted: Sun Nov 20, 2005 4:40 am    Post subject: Reply with quote

Yes it's also set in NLS
Code:

#
# Native Language Support
#
CONFIG_NLS=y
CONFIG_NLS_DEFAULT="iso8859-1"
CONFIG_NLS_CODEPAGE_437=y
CONFIG_NLS_ASCII=y
CONFIG_NLS_ISO8859_1=y
Back to top
View user's profile Send private message
heavyt
Guru
Guru


Joined: 03 Mar 2003
Posts: 498
Location: Matrix (Washington,DC)

PostPosted: Tue Nov 22, 2005 3:55 am    Post subject: Reply with quote

After emerge update of gnome-vfs to 2.12.1.1-r1, gnome-python to 2.12.0, and remerge hal-0.5.4 my JumpDrive automounts. :D I can not tell you why those steps work, they may not be the reason it automounts but I don't give a damn, as long as it will mount am happy! Thanks for your suggestions!
Back to top
View user's profile Send private message
nejiron
Tux's lil' helper
Tux's lil' helper


Joined: 27 Apr 2004
Posts: 95
Location: U.S.A.

PostPosted: Fri Jun 02, 2006 4:57 pm    Post subject: Reply with quote

add

iocharset=utf8

to the mount command

either

/dev/sda1 /mnt/storage -type vfat -o iocharset=utf8

or just add it to your /etc/fstab file at the same place noatime and what not go
_________________
I am a traveler of both time and space
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum