Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Updated Portage, Can't Emerge Anything
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Maheriano
l33t
l33t


Joined: 18 Jun 2005
Posts: 623
Location: Calgary, Alberta

PostPosted: Sun Nov 13, 2005 7:58 pm    Post subject: Updated Portage, Can't Emerge Anything Reply with quote

Code:
tux ~ # emerge azureus
Calculating dependencies ...done!
>>> emerge (1 of 1) net-p2p/azureus-2.3.0.4 to /
>>> md5 files   ;-) azureus-2.3.0.4.ebuild
>>> md5 files   ;-) azureus-2.2.0.0-r1.ebuild
>>> md5 files   ;-) files/digest-azureus-2.2.0.0-r1
>>> md5 files   ;-) files/UpdaterPatcher.java
>>> md5 files   ;-) files/azureus-gentoo.sh
>>> md5 files   ;-) files/digest-azureus-2.3.0.4
>>> md5 files   ;-) files/azureus.desktop
>>> md5 files   ;-) files/build.xml
>>> md5 files   ;-) files/azureus-gentoo-2.3.0.4.sh
>>> md5 files   ;-) files/SWTThread.java
>>> md5 files   ;-) files/azureus.png
>>> md5 src_uri ;-) Azureus_2.3.0.4_source.zip
>>> md5 src_uri ;-) seda-20040224.zip
>>> Unpacking source...
>>> Unpacking Azureus_2.3.0.4_source.zip to /var/tmp/portage/azureus-2.3.0.4/work/azureus
>>> Unpacking seda-20040224.zip to /var/tmp/portage/azureus-2.3.0.4/work/azureus
>>> Source unpacked.
Traceback (most recent call last):
  File "/usr/bin/java-config", line 14, in ?
    from java_config import jc_options
ImportError: No module named java_config
Traceback (most recent call last):
  File "/usr/bin/java-config", line 14, in ?
    from java_config import jc_options
ImportError: No module named java_config
Traceback (most recent call last):
  File "/usr/bin/java-config", line 14, in ?
    from java_config import jc_options
ImportError: No module named java_config
Error: JAVA_HOME is not defined correctly.
  We cannot execute

!!! ERROR: net-p2p/azureus-2.3.0.4 failed.
!!! Function src_compile, Line 61, Exitcode 1
!!! ant build failed
!!! If you need support, post the topmost build error, NOT this status message.


Code:
tux ~ # emerge kmplayer

........t-align -Wconversion -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -DNDEBUG -DNO_DEBUG -O2 -O2 -march=pentium3 -pipe -Wformat-security -Wmissing-format-attribute -fno-exceptions -fno-check-new -fno-common -fno-exceptions -fno-check-new -fno-common    -o kxvplayer -L/usr/kde/3.4/lib -L/usr/qt/3/lib -L/usr/lib    -R /usr/lib -R /usr/kde/3.4/lib -R /usr/qt/3/lib -R /usr/lib xvplayer.o libkmplayerbackend.la -lDCOP -lXv
libtool: link: cannot find the library `/usr/lib/gcc-lib/i386-pc-linux-gnu/3.3.5-20050130/libstdc++.la'
make[2]: *** [kxvplayer] Error 1
make[2]: *** Waiting for unfinished jobs....
libtool: link: cannot find the library `/usr/lib/gcc-lib/i386-pc-linux-gnu/3.3.5-20050130/libstdc++.la'
make[2]: *** [kxineplayer] Error 1
make[2]: Leaving directory `/var/tmp/portage/kmplayer-0.9.0c/work/kmplayer-0.9.0c/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/kmplayer-0.9.0c/work/kmplayer-0.9.0c'
make: *** [all] Error 2

!!! ERROR: media-video/kmplayer-0.9.0c failed.
!!! Function kde_src_compile, Line 168, Exitcode 2
!!! died running emake, kde_src_compile:make
!!! If you need support, post the topmost build error, NOT this status message.


I just changed a whole load of stuff. I emerge portage to update it, emerge --sync, changed my USE flags in make.conf, changed mplayer.conf, and added a line for mplayer into /etc/portage/package.use. Which of these could be to blame? I finally got mplayer working and now everything else is busted!
_________________
Current project - carputer running.........Gentoo?
Back to top
View user's profile Send private message
cokey
Advocate
Advocate


Joined: 23 Apr 2004
Posts: 3343

PostPosted: Sun Nov 13, 2005 8:25 pm    Post subject: Reply with quote

see this: https://forums.gentoo.org/viewtopic-t-318790.html
_________________
"Sex: breakfast of champions" - James Hunt
Back to top
View user's profile Send private message
cokey
Advocate
Advocate


Joined: 23 Apr 2004
Posts: 3343

PostPosted: Sun Nov 13, 2005 8:26 pm    Post subject: Reply with quote

run this:
Code:
fix_libtool_files.sh

_________________
"Sex: breakfast of champions" - James Hunt
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Sun Nov 13, 2005 8:27 pm    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads.
See link above
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum