Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Ctrl-Alt-+ not working in xorg-x11-7.0.0_rc1
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
ZZamboni
Tux's lil' helper
Tux's lil' helper


Joined: 16 Jan 2004
Posts: 96
Location: Zurich, Switzerland

PostPosted: Wed Nov 09, 2005 3:09 pm    Post subject: Ctrl-Alt-+ not working in xorg-x11-7.0.0_rc1 Reply with quote

Hi,

I upgraded to xorg-x11-7.0.0_rc1, which went quite smoothly. I am using the radeon driver with MergedFB, and my xorg.conf file worked unmodified with the new version, except for having to change the ModulePath from /usr/X11R6/lib/modules/ to /usr/lib/xorg/modules/.

Only now, I cannot switch between the different MetaModes I have defined. The MetaModes themselves are recognized properly, from Xorg.0.log:

Code:
(II) RADEON(0): Generating MergedFB mode list
(II) RADEON(0): Merged "1600x1200" (1600x1200) and "1600x1200" (1600x1200) to 3200x1200
(II) RADEON(0): Merged "1600x1200" (1600x1200) and "1600x1200" (1600x1200) to 1600x1200 (Clone)
(II) RADEON(0): Merged "1024x768" (1024x768) and "1024x768" (1024x768) to 1024x768 (Clone)


But Ctrl-Alt-+ doesn't do anything. I can find no relevant error messages or logs. You can see my xorg.conf at http://www.zzamboni.org/diego/files/xorg.conf

Thanks for any ideas,
--ZZamboni
Back to top
View user's profile Send private message
chunderbunny
Veteran
Veteran


Joined: 31 May 2004
Posts: 1281
Location: 51°24'27" N, 0°57'15" W

PostPosted: Wed Nov 09, 2005 9:52 pm    Post subject: Reply with quote

I get the same behaviour with my xorg-7.0.0-RC1 and the Nvidia binary driver. Perhaps there is some app which controls the mode changing which as been split out of the build?
Back to top
View user's profile Send private message
ZZamboni
Tux's lil' helper
Tux's lil' helper


Joined: 16 Jan 2004
Posts: 96
Location: Zurich, Switzerland

PostPosted: Thu Nov 10, 2005 12:08 pm    Post subject: Reply with quote

That's what I thought as well, but I can't find any package that looks like the thing I'm missing...
Back to top
View user's profile Send private message
ZZamboni
Tux's lil' helper
Tux's lil' helper


Joined: 16 Jan 2004
Posts: 96
Location: Zurich, Switzerland

PostPosted: Mon Nov 14, 2005 12:44 pm    Post subject: Reply with quote

*bump*

I'm still stymied on this - any ideas?

Thanks.
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 18084

PostPosted: Tue Nov 15, 2005 10:13 pm    Post subject: Reply with quote

A related thread: https://forums.gentoo.org/viewtopic-t-397192.html
_________________
Those who know what's best for us must rise and save us from ourselves.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum