Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Updating Portage cache: 51%
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
joey_knisch
n00b
n00b


Joined: 08 Apr 2004
Posts: 58

PostPosted: Thu Nov 17, 2005 12:28 am    Post subject: Updating Portage cache: 51% Reply with quote

This is kind of bugging me. It's not a problem since I now have croned it but...

Why does 51% - 53% take longer than all other percents combined?

I have two systems and both slow up right there. One is reiserfs and the other is ext3 so I don't think it's a file system issue. Anyways, I couldn't find an answer anywhere but if anyone knows why I am interested to find out.
Back to top
View user's profile Send private message
adsmith
Veteran
Veteran


Joined: 26 Sep 2004
Posts: 1386
Location: NC, USA

PostPosted: Thu Nov 17, 2005 12:42 am    Post subject: Reply with quote

it's only slow when it hits something that needs updating.

Apparently, the first 50% of your portage tree didn't change much.
Back to top
View user's profile Send private message
codergeek42
Bodhisattva
Bodhisattva


Joined: 05 Apr 2004
Posts: 5142
Location: Anaheim, CA (USA)

PostPosted: Thu Nov 17, 2005 12:46 am    Post subject: Reply with quote

Yup. Happens to me too. Portage zips along happily to 51%, then stays there for a few minutes, then zips along happily again to 100%, It's quite odd, to be honest, though nothing seems to be broken. :?
_________________
~~ Peter: Programmer, Mathematician, STEM & Free Software Advocate, Enlightened Agent, Transhumanist, Fedora contributor
Who am I? :: EFF & FSF
Back to top
View user's profile Send private message
yabbadabbadont
Advocate
Advocate


Joined: 14 Mar 2003
Posts: 4791
Location: 2 exits past crazy

PostPosted: Thu Nov 17, 2005 12:53 am    Post subject: Reply with quote

There are numerous posts on this subject in the forums. Most seem to indicate that the slow up is during the processing of the kde split ebuilds. Apparently, if there are no updates to any of the split ebuilds, then the metadata update will be fast. Otherwise it will appear to hang at about the halfway point.
Back to top
View user's profile Send private message
p-static
n00b
n00b


Joined: 10 Oct 2004
Posts: 55

PostPosted: Thu Nov 17, 2005 1:36 am    Post subject: Reply with quote

This doesn't seem to be the case for me; I get major slowdowns at 50-52% regardless of whether kde builds were updated.
Back to top
View user's profile Send private message
omp
Retired Dev
Retired Dev


Joined: 10 Sep 2005
Posts: 1018
Location: Glendale, California

PostPosted: Thu Nov 17, 2005 3:09 am    Post subject: Reply with quote

I've also noticed a slowdown at ~51% but I don't really care because updating my portage cache only takes 15-20 seconds. (don't know why it's so fast)
_________________
meow.
Back to top
View user's profile Send private message
joey_knisch
n00b
n00b


Joined: 08 Apr 2004
Posts: 58

PostPosted: Thu Nov 17, 2005 4:55 am    Post subject: Reply with quote

Yeah. It's no problem. I was just wondering if someone knew why ~51-53%
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3256

PostPosted: Thu Nov 17, 2005 6:09 am    Post subject: Reply with quote

omp wrote:
I've also noticed a slowdown at ~51% but I don't really care because updating my portage cache only takes 15-20 seconds. (don't know why it's so fast)
8O Thats real fast!! Mine takes several minutes :roll:
Back to top
View user's profile Send private message
hensan
l33t
l33t


Joined: 26 Jun 2003
Posts: 868
Location: Sweden

PostPosted: Thu Nov 17, 2005 8:01 am    Post subject: Reply with quote

ppurka wrote:
omp wrote:
I've also noticed a slowdown at ~51% but I don't really care because updating my portage cache only takes 15-20 seconds. (don't know why it's so fast)
8O Thats real fast!! Mine takes several minutes :roll:


Takes like 15-20 minutes here on a P3 600MHz, most of it spent going from 50 to 53%
Back to top
View user's profile Send private message
Cintra
Advocate
Advocate


Joined: 03 Apr 2004
Posts: 2111
Location: Norway

PostPosted: Thu Nov 17, 2005 8:12 am    Post subject: Reply with quote

https://forums.gentoo.org/viewtopic-t-261580-highlight-cache+cdb.html
this helps, a lot...
_________________
"I am not bound to please thee with my answers" W.S.
Back to top
View user's profile Send private message
tomk
Bodhisattva
Bodhisattva


Joined: 23 Sep 2003
Posts: 7221
Location: Sat in front of my computer

PostPosted: Thu Nov 17, 2005 8:39 am    Post subject: Reply with quote

Moved from Gentoo Chat to Duplicate Threads, please see this topic.
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum