Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Erro instalação NVIDIA GeForce 2 gentoo 2005.1
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
helderfsl
n00b
n00b


Joined: 16 Mar 2004
Posts: 39

PostPosted: Mon Nov 21, 2005 10:07 pm    Post subject: Erro instalação NVIDIA GeForce 2 gentoo 2005.1 Reply with quote

Instalei o pacote nvidia-glx conforme orientação do handbook, executei o modprobe nvidia. Alterei o meu xorg.conf e ao executar o startxsurge o seguinte erro:

(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(--) NVIDIA(0): Linear framebuffer at 0xF0000000
(--) NVIDIA(0): MMIO registers at 0xE7000000
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!
(EE) NVIDIA(0): *** Aborting ***
(II) UnloadModule: "nvidia"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

Como faço para resolver este problema
Back to top
View user's profile Send private message
Earthwings
Bodhisattva
Bodhisattva


Joined: 14 Apr 2003
Posts: 7753
Location: Karlsruhe, Germany

PostPosted: Mon Nov 21, 2005 10:13 pm    Post subject: Reply with quote

Moved from Installing Gentoo to Portuguese.
_________________
KDE
Back to top
View user's profile Send private message
RoadRunner
Bodhisattva
Bodhisattva


Joined: 12 Jun 2002
Posts: 490
Location: Coimbra, Portugal

PostPosted: Tue Nov 22, 2005 1:02 am    Post subject: Reply with quote

Só o nvidia-glx? e o nvidia-kernel?
Back to top
View user's profile Send private message
Stolz
Moderator
Moderator


Joined: 19 Oct 2003
Posts: 3016
Location: Hong Kong

PostPosted: Tue Nov 22, 2005 1:11 pm    Post subject: Re: Erro instalação NVIDIA GeForce 2 gentoo 2005.1 Reply with quote

helderfsl wrote:
Erro instalação NVIDIA GeForce 2 gentoo 2005.1


Que modelo do GF2?

ftp://download.nvidia.com/XFree86/Linux-x86/1.0-7676/README.txt
wrote:
__________________________________________________________________________

Appendix A.
__________________________________________________________________________

Supported NVIDIA Graphics Chips

NVIDIA chip name Device PCI ID
------------------------------- -------------------------------
...
GeForce2 MX/MX 400 0x0110
GeForce2 MX 100/200 0x0111
GeForce2 Go 0x0112
...

Below are the legacy GPUs that are no longer supported in the unified driver.
These GPUs will continue to be maintained through the special legacy NVIDIA
GPU driver releases.

NVIDIA chip name Device PCI ID
------------------------------- -------------------------------
...
GeForce2 GTS/GeForce2 Pro 0x0150
GeForce2 Ti 0x0151
GeForce2 Ultra 0x0152

...
Back to top
View user's profile Send private message
helderfsl
n00b
n00b


Joined: 16 Mar 2004
Posts: 39

PostPosted: Tue Nov 22, 2005 7:42 pm    Post subject: Reply with quote

GeForce 2 MX 400. estou usando o gentoo 2005.1 com kernel 2.6.14-gentoo-r2.
Back to top
View user's profile Send private message
Stolz
Moderator
Moderator


Joined: 19 Oct 2003
Posts: 3016
Location: Hong Kong

PostPosted: Tue Nov 22, 2005 8:02 pm    Post subject: Reply with quote

helderfsl wrote:
GeForce 2 MX 400. estou usando o gentoo 2005.1 com kernel 2.6.14-gentoo-r2.
Tente usar a versão mascarada dos drivers (1.0.7676-r1). No forum espanhol alguns povos resolveram o problema com um GF2 de esta maneira
Back to top
View user's profile Send private message
errado
Tux's lil' helper
Tux's lil' helper


Joined: 25 Feb 2005
Posts: 92

PostPosted: Wed Nov 23, 2005 8:26 pm    Post subject: Reply with quote

Stolz wrote:
helderfsl wrote:
GeForce 2 MX 400. estou usando o gentoo 2005.1 com kernel 2.6.14-gentoo-r2.
Tente usar a versão mascarada dos drivers (1.0.7676-r1). No forum espanhol alguns povos resolveram o problema com um GF2 de esta maneira


Já cansei de falar sobre isso no IRC, mas não me ouvem (lêem?) :( Todas (ou quase, já que o estoque não era tããão completo assim) GeForce MX e inferiores não funcionam com o driver marcado como estável no portage (paradoxo? :roll: )

A solução é usar o driver atual (que não é nem um pouco instável).

Code:
echo "media-video/nvidia-kernel ~x86" >> /etc/portage/package.keywords
echo "media-video/nvidia-glx ~x86" >> /etc/portage/package.keywords
echo "app-admin/eselect ~x86" >> /etc/portage/package.keywords
echo "app-admin/eselect-opengl ~x86" >> /etc/portage/package.keywords
emerge nvidia-glx


E, caso não haja problema algum problema com seu Kernel, seja feliz! :wink:
Back to top
View user's profile Send private message
helderfsl
n00b
n00b


Joined: 16 Mar 2004
Posts: 39

PostPosted: Wed Nov 23, 2005 10:29 pm    Post subject: Reply with quote

Valeu pela dica! está funcionando ok!
Back to top
View user's profile Send private message
Vanquirius
Retired Dev
Retired Dev


Joined: 14 Jun 2002
Posts: 1297
Location: Ethereal plains

PostPosted: Thu Nov 24, 2005 12:15 am    Post subject: Reply with quote

Hmmm... Pensei que as Geforces 2 nem eram mais suportadas pelos drivers atuais. Bom saber.
_________________
Hello.
Back to top
View user's profile Send private message
Operador Nabla
Apprentice
Apprentice


Joined: 06 Feb 2004
Posts: 176
Location: Salesópolis - SP - Brasil

PostPosted: Thu Nov 24, 2005 1:34 am    Post subject: Reply with quote

Tenho uma GeForce2 MX 400 e só consigo manter o meu Gentoo "em ordem" quando uso os drivers da versão 1.0-6629 (a única marcada como estável para x86). Com versões mais recentes que esta, meu X trava ao tentar abrir o KDE ou o WMII --- até o meu teclado congela.
Back to top
View user's profile Send private message
MetalGod
Bodhisattva
Bodhisattva


Joined: 10 Mar 2003
Posts: 816
Location: Portugal

PostPosted: Thu Nov 24, 2005 2:35 am    Post subject: Reply with quote

Vanquirius wrote:
Hmmm... Pensei que as Geforces 2 nem eram mais suportadas pelos drivers atuais. Bom saber.


Tambem pensava isso. Mesmo assim o suporte nvidia e' bem melhor que o da ati 8)
_________________
ex: Gentoo Linux Developer: amd64 media-optical sound gnome
ex: Portuguese Moderator
------------------------------------------------------------------------------
God Doesn't Play Dice
Back to top
View user's profile Send private message
Maleita
Apprentice
Apprentice


Joined: 16 Sep 2004
Posts: 246
Location: Brasil -> São Paulo->Campinas

PostPosted: Fri Nov 25, 2005 1:32 pm    Post subject: Reply with quote

tive o mesmo problema ,mas agora ta redondo,a unica diferença é que eu uso uma FX-5200,mas não funcionava ,misteriosamente funcionou......
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum