Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
glibc-2.3.5 wont compile with nptl and without nptlonly
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
softchill
n00b
n00b


Joined: 28 Jun 2003
Posts: 73
Location: Quebec, Canada

PostPosted: Thu Nov 24, 2005 2:28 pm    Post subject: glibc-2.3.5 wont compile with nptl and without nptlonly Reply with quote

Hi, I recently emerged -u system, which updated glibc-2.3.4 to glibc-2.3.5. glibc-2.3.4 was
compiled with USE="ntpl -ntplonly". According to pkg_setup in glibc-2.3.5-r2.ebuild, nptl without
nptlonly is not supported on ppc. So I added ntplonly to my use flags. But now I get weird errors
when compiling other package:

while compiling a tool (xpt_link) in the mozilla-thunderbird package I get a bunch of undefined
symbols `memcpy@@GLIBC_2.0'. But I dont get it in a simple test I wrote (just using memcpy
and compiling). So I'm now downgrading my glibc version to 2.3.4 with linuxthreads/nptl and
wish it'll work.

Anyone know why linuxthreads and nptl "are not supported" in glibc-2.3.5 on ppc ?

Thanks for any feedback.
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Thu Nov 24, 2005 5:19 pm    Post subject: Reply with quote

It's a known bug. Unfortunately it isn't solved yet. So you either use both nptl and nptlonly or don't use either.
The mozilla/thunderbird problem: if that's with the 1.5 release candidates, then that too is a known problem without a solution afaik. Binutils being the suspect here.
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
softchill
n00b
n00b


Joined: 28 Jun 2003
Posts: 73
Location: Quebec, Canada

PostPosted: Thu Nov 24, 2005 5:42 pm    Post subject: Reply with quote

Thanks, I was effectively trying to compile thunderbird-1.5_rc1 as I'm working on an extension so I need the last version. As you can guest, the problem persist with glibc-2.3.4.

I had a look at bugzilla before writting, but coulnt find anything. Thanks for pointing that out !! :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum