Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
libFLAC.so.6 not found
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Horus107
Apprentice
Apprentice


Joined: 29 Mar 2004
Posts: 230

PostPosted: Sun Nov 27, 2005 12:30 pm    Post subject: libFLAC.so.6 not found Reply with quote

Hello,
I've amarok 1.3.6 which refuses to start:

amarokapp: error while loading shared libraries: libFLAC.so.6: cannot open shared object file: No such file or directory
Code:

florian@horus /usr/lib $ ll libFLAC*
-rw-r--r--  1 root root 253484 27. Nov 13:08 libFLAC.a
-rw-r--r--  1 root root 136832 27. Nov 13:08 libFLAC++.a
-rwxr-xr-x  1 root root    790 27. Nov 13:08 libFLAC.la
-rwxr-xr-x  1 root root   1000 27. Nov 13:08 libFLAC++.la
lrwxrwxrwx  1 root root     16 27. Nov 13:08 libFLAC.so -> libFLAC.so.7.0.0
lrwxrwxrwx  1 root root     18 27. Nov 13:08 libFLAC++.so -> libFLAC++.so.5.0.0
lrwxrwxrwx  1 root root     18 27. Nov 13:08 libFLAC++.so.5 -> libFLAC++.so.5.0.                             0
-rwxr-xr-x  1 root root 123220 27. Nov 13:08 libFLAC++.so.5.0.0
lrwxrwxrwx  1 root root     16 27. Nov 13:08 libFLAC.so.7 -> libFLAC.so.7.0.0
-rwxr-xr-x  1 root root 190300 27. Nov 13:08 libFLAC.so.7.0.0


I've reemerged both libFLAC and amarok. Should I just place a symlink from libFLAC.so.6 to libFLAC.so? Or is there a more elegant solution?

Thanks,

Florian
Back to top
View user's profile Send private message
Juffo-Wup
n00b
n00b


Joined: 25 Aug 2005
Posts: 11

PostPosted: Sun Nov 27, 2005 1:01 pm    Post subject: Reply with quote

Emerging tunepimp again fixed this error for me. If this doesn't work try running revdep-rebuild.
Back to top
View user's profile Send private message
kasperhans
Tux's lil' helper
Tux's lil' helper


Joined: 04 Nov 2003
Posts: 90
Location: Hansestadt Bremen - Germany

PostPosted: Sun Nov 27, 2005 2:57 pm    Post subject: Reply with quote

theres another post with exact same topic please use this dont fire up another with same error ...i think the other one got solved btw try forum search
_________________
stay high and life the all day flight
Back to top
View user's profile Send private message
Atko
n00b
n00b


Joined: 27 Dec 2004
Posts: 14
Location: Budapest, Hungary

PostPosted: Sun Nov 27, 2005 10:48 pm    Post subject: totem and flac 1.1.2-r3 Reply with quote

I have exactly the same problem with totem...

This week flac was updated from 1.1.1 to 1.1.2-r3. Since this update totem stopped to work. It complained that do not to find libflac.so.6. I downgraded flac back to 1.1.1, and since this totem runs fine. Any suggestion?
Back to top
View user's profile Send private message
hardcore
l33t
l33t


Joined: 01 Nov 2003
Posts: 626
Location: MSU, MI

PostPosted: Wed Nov 30, 2005 1:23 pm    Post subject: Reply with quote

re-emerging

Code:
gst-plugins-flac
tunepimp
amarok


fixed this issue for me.
_________________
Nothing can stop me now, cuz I just don't care.
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Wed Nov 30, 2005 1:46 pm    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads in favour of Update to libflac and failure of revdep-rebuild...
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum