Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[TIP] Can't access mysql with phpmyadmin after upgrade
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
Nimo
Tux's lil' helper
Tux's lil' helper


Joined: 23 Nov 2003
Posts: 111

PostPosted: Sun Nov 27, 2005 2:34 pm    Post subject: [TIP] Can't access mysql with phpmyadmin after upgrade Reply with quote

After upgrading mysql and phpmyadmin I no longer could access my mysql-database with phpmyadmin. I got this error message:
Quote:
Client does not support authentication protocol requested by server; consider upgrading MySQL client


I've been browsing the gentoo-forums and other sources of information for hours until I finally found the fix. First do:
Code:
$ mysql -u root --password



Then execute this line that solves it all:
Code:
SET PASSWORD FOR user@localhost = OLD_PASSWORD('your_password');


Remember to do it for both the pma and root/admin-user. I found this explanation to the problem in the mysql manual:
This problem is generally caused by using MySQL version 4.1 or newer. MySQL changed the authentication hash and your PHP is trying to use the old method.

_________________
//Nimo
Back to top
View user's profile Send private message
Enigma_Man
n00b
n00b


Joined: 20 May 2003
Posts: 55
Location: Massachusetts

PostPosted: Fri Dec 09, 2005 3:06 pm    Post subject: Reply with quote

Something I just ran into, not quite sure why. I upgraded phpmyadmin, and when trying to access the phpmyadmin page, it complained about not having sessions available. I had to recompile php with the "session" use flag. I don't think I had upgraded php lately, but I'm not the best at paying attention.

Hope it helps someone.

-Jesse
Back to top
View user's profile Send private message
Peach
Advocate
Advocate


Joined: 08 Mar 2003
Posts: 3686
Location: London, UK

PostPosted: Tue Dec 13, 2005 12:05 am    Post subject: Re: [TIP] Can't access mysql with phpmyadmin after upgrade Reply with quote

Nimo wrote:
Then execute this line that solves it all:
Code:
SET PASSWORD FOR user@localhost = OLD_PASSWORD('your_password');


Remember to do it for both the pma and root/admin-user.

I would add: the pma password to be re-set is found in config.inc.php in the phpmyadmin dir.
Just because I'm dumb.
_________________
Gentoo user since 2004.
"It's all fun and games, until someone loses an eye" - mom
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum