Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Native Airport Extreme Drivers
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 5, 6, 7 ... 40, 41, 42  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
SickBoy
n00b
n00b


Joined: 25 Aug 2003
Posts: 67
Location: mpls, mn

PostPosted: Sat Dec 17, 2005 9:02 pm    Post subject: Reply with quote

Is there a schedule for creating ebuilds for any of this and creating official documentation on it?
_________________
Audioslave--Asus K8V SE Deluxe--Athlon64 3200+--2 GB PC3200 - 6600GT
Soundgarden--MSI K8MM-V--Sempron64 2600+--1.5 GB PC3200 - FX5200
Alice-- Dell Poweredge 2300 - haven't powered it up in probably 2 years.
Macbook Pro 15" (no Gentoo)
Back to top
View user's profile Send private message
kp1975
n00b
n00b


Joined: 18 Dec 2005
Posts: 1

PostPosted: Sun Dec 18, 2005 1:24 pm    Post subject: anyone succeded to make it work under debian macmini? Reply with quote

- installed linux-2.6.15-rc5
- downloaded softmac patchlevel 192
- compiled fine and loaded the module
- loaded firmware_class
- extracted from /System/Library/Extensions/AppleAirPort2.kext/Contents/MacOS/AppleAirPort2 with fwcutter the firmware
- make installfw
- downloaded and compiled bcm43xx fine and loaded it

now iwconfig prompts nothing :/

a thing: lspci doesn't list airport device, any clues? thanks!

PS: I have put firmware under /lib/firmware and /usr/lib/hotplug/firmware
Back to top
View user's profile Send private message
e-ipi
Apprentice
Apprentice


Joined: 23 Aug 2005
Posts: 192

PostPosted: Wed Dec 21, 2005 2:53 am    Post subject: Reply with quote

In the absence of the other security features, I enabled MAC address filtering on my linksys router (WRT54G). However, I can't seem to use the router when I have it enabled. I can associate and things look fine up to the point where I try to use the network, at which point my machine freezes up.

I've already double-checked and triple-checked to make sure I have the MAC address right. Is there anything else I'm forgetting?
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Wed Dec 21, 2005 3:05 am    Post subject: Reply with quote

Sickboy:
No, no ebuilds until it's more stable. This is the official documentation.

kp1975:
Not all Mac Mini's come with the AE, are you sure yours has one? If it doesn't show up in lspci, I doubt it does.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
e-ipi
Apprentice
Apprentice


Joined: 23 Aug 2005
Posts: 192

PostPosted: Wed Dec 21, 2005 5:51 am    Post subject: Reply with quote

e-ipi wrote:
In the absence of the other security features, I enabled MAC address filtering on my linksys router (WRT54G). However, I can't seem to use the router when I have it enabled. I can associate and things look fine up to the point where I try to use the network, at which point my machine freezes up.

I've already double-checked and triple-checked to make sure I have the MAC address right. Is there anything else I'm forgetting?


Yes, there is. The linux drivers really don't like it when you switch from no filtering to filtering in midstream. It works fine if you start off withthe MAC address filtering enabled.
Back to top
View user's profile Send private message
Jimmers
Tux's lil' helper
Tux's lil' helper


Joined: 02 Feb 2005
Posts: 145

PostPosted: Wed Dec 21, 2005 4:16 pm    Post subject: Reply with quote

I also have WRT54G router, and it works in MAC-filter mode. I did have to enter the default gateway manually using route:

Code:
route add default gw <ap_local_ip>
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Wed Dec 21, 2005 5:16 pm    Post subject: Reply with quote

I forgot to put a post here, if you need WPA or WEP support, please check the first page again, I've added a link to using the devicescape stack with the bcm43xx driver.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
quaestor
n00b
n00b


Joined: 02 Jul 2005
Posts: 13

PostPosted: Wed Dec 21, 2005 7:17 pm    Post subject: Reply with quote

strange but on my girlfriend's ibook (same hardware, same kernel +config, same services, same package versions) it works for a small time (ping reply stops like AliasN described), but not on mine...
Back to top
View user's profile Send private message
e-ipi
Apprentice
Apprentice


Joined: 23 Aug 2005
Posts: 192

PostPosted: Wed Dec 21, 2005 8:17 pm    Post subject: Reply with quote

Jimmers wrote:
I also have WRT54G router, and it works in MAC-filter mode. I did have to enter the default gateway manually using route:

Code:
route add default gw <ap_local_ip>



Yeah, I was doing that, too. It's really not that big of a problem considering that it does work as long you don't switch from non-filtering to filtering while you are using the wireless and most people having functioning ethernet ports. (But not me -- :cry: ) One shouldn't have to set up the filtering too often, either.
Back to top
View user's profile Send private message
mizty
n00b
n00b


Joined: 17 Dec 2005
Posts: 7

PostPosted: Thu Dec 22, 2005 8:59 pm    Post subject: Reply with quote

Hey

I am wondering if it is possible to compile this driver on other distributions than Gentoo? Recently, I tried compiling it on a Debian machine, but it came up with some strange error I can't really remember right now. So is it possible on other dists? And if yes, what is needed to compile it? Which libraries etc?

- Mizty
Back to top
View user's profile Send private message
fuoco
Guru
Guru


Joined: 23 May 2004
Posts: 386
Location: Israel

PostPosted: Thu Dec 22, 2005 9:02 pm    Post subject: Reply with quote

Does anyone still have problems associating with their AP ? The timeout problem from few days/week ago ?
Is it better to use SoftMAC or that alternative implementation ?
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Fri Dec 23, 2005 6:04 am    Post subject: Reply with quote

mizty:
You need a 2.6.15 kernel (and source), and the development tools required to build the kernel.

fuoco:
Use devicescape, it's far more complete than SoftMAC ever will be.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
fuoco
Guru
Guru


Joined: 23 May 2004
Posts: 386
Location: Israel

PostPosted: Fri Dec 23, 2005 5:36 pm    Post subject: Reply with quote

I just want to understand. SoftMAC development has stopped in favor of dscape ? dscape is an alternative to the stack already in kernel ? Is it a replacement that at some point will go in kernel or something like that ?
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Sat Dec 24, 2005 3:07 pm    Post subject: Reply with quote

The time required to add the features supported in devicescape to SoftMAC would be time wasted. SoftMAC served its purpose as a quick layer to test the driver code. Right now, we're working on fixing issues with devicescape so that it can be merged upstream in favor of the ieee80211 stack currently in the kernel. This includes porting dirvers currently using the ieee8011 code to the devicescape stack.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
fuoco
Guru
Guru


Joined: 23 May 2004
Posts: 386
Location: Israel

PostPosted: Sat Dec 24, 2005 4:06 pm    Post subject: Reply with quote

I tried to patch the kernel with dscape patches, but I had some problems. I was using 2.6.15-rc6 - is that OK ?
There are more than one patch in there - in what order should they be merged ?
Back to top
View user's profile Send private message
darklesi
n00b
n00b


Joined: 23 Jul 2004
Posts: 12
Location: Portugal

PostPosted: Sat Dec 24, 2005 8:12 pm    Post subject: Reply with quote

fuoco wrote:
I tried to patch the kernel with dscape patches, but I had some problems. I was using 2.6.15-rc6 - is that OK ?
There are more than one patch in there - in what order should they be merged ?


Hi there

I'm using yhat kernel version to and when trying to patch i have also a lot of problems ... As this is still in develop i will keep an eye on this ;)

Sorry the english :D
Cheers
Back to top
View user's profile Send private message
blixel
Guru
Guru


Joined: 19 Jul 2004
Posts: 403
Location: Central, Florida

PostPosted: Sun Dec 25, 2005 1:27 am    Post subject: Reply with quote

I would really like to get this working on my G4 Apple iBook. I have never installed Linux on a Mac before. I've been using Linux on x86 machines for years, and I've never had any problem compiling a kernel. But I'm having a hard time with it on this iBook. I'm sure it's just something dumb I'm doing (or not doing). Typically, on my x86 Desktop, I will:

  • Download the latest kernel source from kernel.org
  • Unpack it into /usr/src
  • Create a soft link from /usr/src/linux-[version] /usr/src/linux
  • cd into /usr/src/linux
  • copy my previous .config over to /usr/src/linux/.config
  • run "make oldconfig" - then possibly run "make menuconfig" to make some changes
  • then I run "make && make modules_install && make install"
  • then I mount /boot and update /boot/grub/grub.conf
  • then I'll unmount /boot, and reboot

This procedure works just fine for my x86 systems. When I was sitll on the 2.4 kernel, I had to manually copy /usr/src/linux/arch/i386/boot/bzImage to /boot because "make install" didn't exist then (or if it did, I just wasn't aware of it).

Anyway - this process doesn't work with the iBook and I'm not sure where I'm going wrong. I've looked in /usr/src/linux/arc/ppc/boot for a kernel image, but I don't see one. I instead copied over the uncompressed /usr/src/linux/vmlinux to /boot and modified /etc/yaboot.conf to use it, but then I get a kernel panic when the system boots.

Does someone have a 12" G4 iBook with a .config file I can take a look at?
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Sun Dec 25, 2005 1:37 am    Post subject: Reply with quote

Please read the handbook, the install procedure is slightly different on PPC than on x86, we use yaboot instead of grub for instance. Here's a link to the kernel setup instructions.

http://www.gentoo.org/doc/en/handbook/handbook-ppc.xml?part=1&chap=7
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
bz31
Tux's lil' helper
Tux's lil' helper


Joined: 20 Apr 2005
Posts: 108

PostPosted: Sun Dec 25, 2005 4:20 pm    Post subject: Reply with quote

JoseJX wrote:
I forgot to put a post here, if you need WPA or WEP support, please check the first page again, I've added a link to using the devicescape stack with the bcm43xx driver.
Thanks. WPA woks for me now.
Back to top
View user's profile Send private message
blixel
Guru
Guru


Joined: 19 Jul 2004
Posts: 403
Location: Central, Florida

PostPosted: Sun Dec 25, 2005 5:25 pm    Post subject: Reply with quote

OK - everything is going well up to Step 5. I don't have OSX installed on my iBook. I'm installing Linux because I can't stand OSX. Is there a way to pull the AppleAirport2 file off my OSX Panther CD?
Back to top
View user's profile Send private message
blixel
Guru
Guru


Joined: 19 Jul 2004
Posts: 403
Location: Central, Florida

PostPosted: Sun Dec 25, 2005 11:12 pm    Post subject: Reply with quote

I have to be close...

OK - since I didn't have the AppleAirPort2 file, I tar'ed up my entire Gentoo install onto an external drive I had. I then re-installed OSX Panther onto my iBook. I decided to create a 20GB partition for it ... and leave it installed in case I needed something else from it.

Then I booted the Gentoo minimal Live CD, re-partitioned the remaining space, untar'ed my Gentoo install, fixed the fstab, re-ran yabootconfig and rebooted back to Gentoo.

Then I was able to mount osx and copy over the AppleAirPort2 file which got me past step 5.

Now ... when I type iwconfig, I get this:

Code:
archangel david # iwconfig
eth0      no wireless extensions.

lo        no wireless extensions.

eth1      IEEE 802.11b/g  ESSID:"FreeWiFi"  Nickname:"Broadcom 4306"
          Mode:Managed  Bit Rate:1 Mb/s   Tx-Power=off   
          RTS thr:off   Fragment thr:off
          Encryption key:off


Looks good there. But when I try to assign an IP address to the interface, it fails.

Code:
archangel david # ifconfig eth1 172.16.1.14 netmask 255.255.255.0
SIOCSIFFLAGS: No such file or directory


If I try dhcp, it fails as well. No error comes back, it just doesn't work.

I've worked so hard on this ... have come so far ... I'm not giving up now. But what can I do now?
Back to top
View user's profile Send private message
boudewijn
Apprentice
Apprentice


Joined: 11 Jan 2005
Posts: 257
Location: Netherlands

PostPosted: Sun Dec 25, 2005 11:35 pm    Post subject: Reply with quote

hey, the svn is down.

Anybody knows where I can get an alternative repository?
_________________
Mijn Nederlandstalige Gentoo forum:
http://www.gentoo-forum.nl
Back to top
View user's profile Send private message
bz31
Tux's lil' helper
Tux's lil' helper


Joined: 20 Apr 2005
Posts: 108

PostPosted: Sun Dec 25, 2005 11:38 pm    Post subject: Reply with quote

ftp://ftp.berlios.de/pub/bcm43xx/snapshots/
Back to top
View user's profile Send private message
boudewijn
Apprentice
Apprentice


Joined: 11 Jan 2005
Posts: 257
Location: Netherlands

PostPosted: Mon Dec 26, 2005 12:52 am    Post subject: Reply with quote

do I need all three?

I don't know the contents of the trunk from svn huh :wink:
_________________
Mijn Nederlandstalige Gentoo forum:
http://www.gentoo-forum.nl
Back to top
View user's profile Send private message
blixel
Guru
Guru


Joined: 19 Jul 2004
Posts: 403
Location: Central, Florida

PostPosted: Mon Dec 26, 2005 3:19 am    Post subject: Reply with quote

blixel wrote:
Code:
archangel david # ifconfig eth1 172.16.1.14 netmask 255.255.255.0
SIOCSIFFLAGS: No such file or directory


OK - I deleted everything and started over. I'm no longer getting the above error, but it's still not working. I can statically assign an IP address, but dhcp fails (though the directions say it might - so I'm OK with that.) But even statically assigned, the card acts like it's not connected. The system log doesn't indicate any problems. At least none that I can see.

Code:
Dec 25 21:55:44 [kernel] SoftMAC: Start scanning with channel: 1
Dec 25 21:55:44 [kernel] SoftMAC: Flags for channel 2: 0000
Dec 25 21:55:45 [kernel] SoftMAC: Flags for channel 3: 0000
Dec 25 21:55:45 [kernel] SoftMAC: Flags for channel 4: 0000
Dec 25 21:55:46 [kernel] SoftMAC: Flags for channel 5: 0000
Dec 25 21:55:46 [kernel] SoftMAC: Flags for channel 6: 0000
Dec 25 21:55:47 [kernel] SoftMAC: Flags for channel 7: 0000
Dec 25 21:55:47 [kernel] SoftMAC: Flags for channel 8: 0000
Dec 25 21:55:48 [kernel] SoftMAC: Flags for channel 9: 0000
Dec 25 21:55:48 [kernel] SoftMAC: Flags for channel 10: 0000
Dec 25 21:55:49 [kernel] SoftMAC: Flags for channel 11: 0000
Dec 25 21:55:49 [kernel] SoftMAC: Scanning finished
Dec 25 21:57:59 [kernel] bcm43xx: PHY connected
Dec 25 21:58:00 [kernel] bcm43xx: InitVals written
Dec 25 21:58:26 [kernel] bcm43xx: Radio turned off
Dec 25 21:59:32 [kernel] ieee80211: 802.11 data/management/control stack, git-1.1.7
Dec 25 21:59:33 [kernel] bcm43xx driver 0.0.1
Dec 25 21:59:33 [kernel] bcm43xx: Chip ID 0x4306, rev 0x3
Dec 25 21:59:34 [kernel] bcm43xx: PHY connected
Dec 25 21:59:35 [kernel] bcm43xx: InitVals written
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Goto page Previous  1, 2, 3 ... 5, 6, 7 ... 40, 41, 42  Next
Page 6 of 42

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum