Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Native Airport Extreme Drivers
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 19, 20, 21 ... 40, 41, 42  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
slithy
Guru
Guru


Joined: 26 Nov 2005
Posts: 321
Location: Kansas

PostPosted: Tue Mar 07, 2006 3:09 am    Post subject: Reply with quote

I have been following the guide on the first post to get my Dell 1450 wifi card working (it uses the bcm43xx chipset), anyways. I have bcm43xx version 0.0.1-r20006125 and ieee80211softmac version 0.1-20060125. The firmware is installed correctly also. I originally didn't have the stack pactch and was able to do everything but use DHCPCD.

Now I have the patch installed and under my kernel option, I have Soft MAC add-on to the IEEE 802.11 networking stack integragted into the kernel and the Generic IEEE 802.11 Networking Stack integrated also. The problems is when I do ifconfig eth1 up, the kernel panics. BTW I am on kerenl 2.6.15-gentoo-r7. I didn't read all 17 pages, cause I am pressed for time, but then again I didn't see anything like what I just experienced in the 10 or so pages I read. Do I need to include more options in the kernel? Anyone know why the kernel would panic?

EDIT: Ok I think I just realized the the updated stack is included in the ebuild and I already had it and that's why including it in the kernel caused a panic. Anyone know what's going on with dhcpcd though?

EDIT 2: When the dhcpcd fails dmesg gets clogged up with all this:
Code:
SoftMAC: Authentication response received from 00:90:96:b4:95:c0 but no queue item exists.
SoftMAC: Authentication response received from 00:90:96:b4:95:c0 but no queue item exists.
SoftMAC: Authentication response received from 00:90:96:b4:95:c0 but no queue item exists.
SoftMAC: Authentication response received from 00:90:96:b4:95:c0 but no queue item exists.
SoftMAC: Authentication response received from 00:90:96:b4:95:c0 but no queue item exists.
SoftMAC: Authentication response received from 00:90:96:b4:95:c0 but no queue item exists.
printk: 21 messages suppressed.
SoftMAC: Authentication response received from 00:14:1c:16:41:10 but no queue item exists.
SoftMAC: Authentication response received from 00:14:1c:16:41:10 but no queue item exists.


What does the no queue mean?
Back to top
View user's profile Send private message
dashnu
l33t
l33t


Joined: 21 Jul 2004
Posts: 703
Location: Casco Maine

PostPosted: Tue Mar 07, 2006 5:12 pm    Post subject: Reply with quote

fuoco wrote:
Anyone got it to work with NetworkManager ? (from gentopia)


I just got networkmanager working for my wired card. Cool app but I fail to see WPA-PSK or any WPA options for that matter.
_________________
write quit bang
Back to top
View user's profile Send private message
atomik
n00b
n00b


Joined: 08 Jun 2003
Posts: 54
Location: Catania - Italy

PostPosted: Thu Mar 09, 2006 8:53 pm    Post subject: Reply with quote

My airport extreme when i resume my powerbook from stop doesn't work.

Need to kill wpa_supplicant, shut down eth1 interface and repeat entire procedure for put wifi up..


I have 2.6.16-rc5, latest bcm43xx all-in-one patch and latest wpa_supplicant..

This is a known problem, or only my configuration problem?

Thanks!
_________________
At0m|K
Back to top
View user's profile Send private message
MattJD
n00b
n00b


Joined: 10 Mar 2006
Posts: 5

PostPosted: Fri Mar 10, 2006 1:31 am    Post subject: Reply with quote

I have a Broadcom 4306 internal card. I successfully use ndiswrapper to connect, and wish to swtih to an open source driver. I use the latest ebuild, and I have tried different firmware, using the driver that I used for ndiswrapper, a linksys driver, and one from this forum post. It starts, an tries to connect to the dlink router I have. I use a shared WEP key system, and the driver won't use this. Is this a know problem, or is it just something I am doing. I tried both ndiswrapper with a config that works with a dlink card and ndiswrapper and wireless tools. I have tried using the latest snapshot, but it doesn't work either. Any help is appreciated
Back to top
View user's profile Send private message
KeyserZero
n00b
n00b


Joined: 21 Mar 2005
Posts: 68

PostPosted: Fri Mar 10, 2006 8:00 am    Post subject: Reply with quote

atomik:

I also have problems with sleep and bcm43xx! I think the only workaround is to unload the bcm43xx module!

Or has anybody a better solution?

Greetz
_________________
www.ruby-lang.org
Back to top
View user's profile Send private message
addeman
Apprentice
Apprentice


Joined: 04 Nov 2004
Posts: 181
Location: Stockholm, Sweden

PostPosted: Fri Mar 10, 2006 12:53 pm    Post subject: Reply with quote

Hello,

i'm trying to get the bcm43xx to work with my bcm4318 internal card, but no go. Untill now i used ndiswrapper, but i can't do that any longer since i now have > 1gb ram (computer freeze when i try to load ndiswrapper). My hardware: HP nx6125 ml-40 1.5gb ram. I use kernel 2.6.15-gentoo-r7.

I'm trying the ebuild-method as that does not require a 2.6.16 kernel, and when trying to start the wireless gives
Code:
nx6125 ~ # iwconfig
eth0      no wireless extensions.

lo        no wireless extensions.

sit0      no wireless extensions.

ip6tnl0   no wireless extensions.

eth1      no wireless extensions.

eth2      IEEE 802.11b/g  ESSID:off/any  Nickname:"Broadcom 4318"
          Mode:Managed  Access Point: Invalid   Bit Rate=1 Mb/s
          Tx-Power=off
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

nx6125 ~ # ifconfig eth2 up
SIOCSIFFLAGS: No such file or directory
nx6125 ~ #dmesg tail
...
bcm43xx: Error: Microcode "bcm43xx_microcode5.fw" not available or load failed.
nx6125 ~ # ls /lib/firmware/
bcm43xx_initval01.fw  bcm43xx_initval04.fw  bcm43xx_initval07.fw  bcm43xx_initval10.fw   bcm43xx_microcode5.fw
bcm43xx_initval02.fw  bcm43xx_initval05.fw  bcm43xx_initval08.fw  bcm43xx_microcode2.fw  bcm43xx_pcm4.fw
bcm43xx_initval03.fw  bcm43xx_initval06.fw  bcm43xx_initval09.fw  bcm43xx_microcode4.fw  bcm43xx_pcm5.fw

I'm using the firmware from acer 64-bit driver.

Any ideas?
Best regards
addeman
Back to top
View user's profile Send private message
thedopefishlives
Tux's lil' helper
Tux's lil' helper


Joined: 23 Nov 2005
Posts: 84

PostPosted: Fri Mar 10, 2006 1:13 pm    Post subject: Reply with quote

I have a problem with the kernel panicking with the snapshots. Perhaps I should try the full kernel tree, but I'd like an ebuild for that :? Anyhow, the kernel panics under two circumstances: 1) I kill wpa_supplicant without bringing the interface back up afterward (i.e. killall wpa_supplicant && ifconfig eth0 up does work), or 2) removing the bcm43xx module from the kernel after the interface has been in use. Anyone else have my problem using the snapshots, and does upgrading to the latest version help anything?
Back to top
View user's profile Send private message
srpape
n00b
n00b


Joined: 25 Jun 2004
Posts: 11

PostPosted: Mon Mar 20, 2006 1:23 am    Post subject: Reply with quote

slithy wrote:

EDIT 2: When the dhcpcd fails dmesg gets clogged up with all this:
Code:
SoftMAC: Authentication response received from 00:90:96:b4:95:c0 but no queue item exists.
SoftMAC: Authentication response received from 00:90:96:b4:95:c0 but no queue item exists.
SoftMAC: Authentication response received from 00:90:96:b4:95:c0 but no queue item exists.
SoftMAC: Authentication response received from 00:90:96:b4:95:c0 but no queue item exists.
SoftMAC: Authentication response received from 00:90:96:b4:95:c0 but no queue item exists.
SoftMAC: Authentication response received from 00:90:96:b4:95:c0 but no queue item exists.
printk: 21 messages suppressed.
SoftMAC: Authentication response received from 00:14:1c:16:41:10 but no queue item exists.
SoftMAC: Authentication response received from 00:14:1c:16:41:10 but no queue item exists.


What does the no queue mean?


I have the same error when it tries to associate with my access point. It works ok with the ebuild, except I have a lot of packet loss (I don't if I use ndiswrapper). I thought I'd try a 2.6.16 kernel and the latest softmac/bcm43xx drivers to see if this helped. I can use kismet fine, I can capture packets and use iwlist to see available networks, but I can't associate, dmesg just has that error. :(
Back to top
View user's profile Send private message
qleak
n00b
n00b


Joined: 17 Jun 2005
Posts: 67

PostPosted: Thu Mar 30, 2006 6:16 am    Post subject: bcm43xx Oops Reply with quote

On the newer ebuilds I am getting a kernel opps when I do ifconfig eth1 up

currently

bcm43xx-0.0.1-r20060329
ieee80211softmac-0.1-r20060329
firmware: wl_apsta 3.130.20.0
kernel: 2.6.15-gentoo-r1
card: Broadcom 4306

the command line says Bus Error
and my dmesg looks like:

Code:

 Machine check in kernel mode.
 Caused by (from SRR1=141030): Transfer error ack signal
 Oops: machine check, sig: 7 [#1]
 NIP: F43C14A8 LR: F43C5570 SP: E2DD7CB0 REGS: e2dd7c00 TRAP: 0200    Not tainted
 MSR: 00141030 EE: 0 PR: 0 FP: 0 ME: 1 IR/DR: 11
 TASK = e4ff7270[9235] 'ifconfig' THREAD: e2dd6000
 Last syscall: 54
 GPR00: F40C43FC E2DD7CB0 E4FF7270 00000D00 00000429 00008018 00000000 00000000
 GPR08: 00000002 F40C4000 F40C4000 F40C4000 44002482 10026ABC 1001E5A8 10020000
 GPR16: 1001E53C 00000000 10020000 10020000 E054EDBC FFFF8914 00000000 E054ED8C
 GPR24: E054ED98 00000000 E054EDBC 7F916E70 E054ED98 00009032 E054ED98 E054EC20
 NIP [f43c14a8] bcm43xx_phy_read+0x20/0x34 [bcm43xx]
 LR [f43c5570] bcm43xx_phy_initg+0xc1c/0xc5c [bcm43xx]
 Call trace:
 [f43c554c] bcm43xx_phy_initg+0xbf8/0xc5c [bcm43xx]
 [f43c5628] bcm43xx_phy_calibrate+0x78/0xa8 [bcm43xx]
 [f43b8e94] bcm43xx_init_board+0x264/0x11ec [bcm43xx]
 [c0245910] dev_open+0x64/0xd0
 [c0246fb8] dev_change_flags+0x6c/0x13c
 [c0285fd0] devinet_ioctl+0x2ec/0x718
 [c028744c] inet_ioctl+0xb4/0x100
 [c023b6e4] sock_ioctl+0x2ac/0x2c8
 [c007f164] do_ioctl+0x38/0x88
 [c007f580] vfs_ioctl+0x3cc/0x3f0
 [c007f5e4] sys_ioctl+0x40/0x70
 [c000473c] ret_from_syscall+0x0/0x44


I've previously had bcm43xx working (with the same firmware) on the following version:

net-wireless/bcm43xx-0.0.1-r20060125
net-wireless/ieee80211softmac-0.1-r20060125

but had similar problems with the 20060309 snapshots

all the best,

-Q
_________________
(\ /)
(O.o)
(> <)
This is Frank. He made me flood the school.
Back to top
View user's profile Send private message
prometheanfire
Developer
Developer


Joined: 21 Apr 2005
Posts: 87
Location: San Antonio, TX USA

PostPosted: Mon Apr 03, 2006 5:53 pm    Post subject: Reply with quote

Has anyone tried the newest snapshot in portage (the march 29th version)?
_________________
-- Matthew Thode (prometheanfire)
Back to top
View user's profile Send private message
e-ipi
Apprentice
Apprentice


Joined: 23 Aug 2005
Posts: 192

PostPosted: Tue Apr 04, 2006 12:17 am    Post subject: Reply with quote

mthode wrote:
Has anyone tried the newest snapshot in portage (the march 29th version)?


I haven't, but I noticed from reading the changelog on 2.6.17-rc1 that bcm43xx & softmac are now in the linux kernel sources.
Back to top
View user's profile Send private message
straks
n00b
n00b


Joined: 09 May 2004
Posts: 50

PostPosted: Tue Apr 04, 2006 12:30 am    Post subject: Reply with quote

Hey,

I followed the guide perfectly. Did every command and i'm using the latest ebuilds of bcm43xx and softmac. I also used the recommend firmware, did that command. But when i doe modprobe bcm43xx, i get this output (ooh and yes, ieee80211 is disabled in the kernel).

Quote:

bcm43xx driver
ACPI: PCI Interrupt 0000:02:03.0[A] -> GSI 17 (level, low) -> IRQ 18
Unable to handle kernel NULL pointer dereference at virtual address 00000144
printing eip:
fa3673a3
*pde = 00000000
Oops: 0002 [#1]
SMP
Modules linked in: bcm43xx ieee80211softmac ieee80211 ieee80211_crypt snd_pcm_oss snd_mixer_oss snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device snd_intel8x0 snd_ac97_codec snd_ac97_bus snd_pcm snd_timer snd snd_page_alloc b44
CPU: 1
EIP: 0060:[<fa3673a3>] Not tainted VLI
EFLAGS: 00010296 (2.6.16-gentoo #3)
EIP is at ieee80211_set_geo+0x22/0x99 [ieee80211]
eax: 00005858 ebx: eac779b8 ecx: 0000000f edx: 00000000
esi: eac779c0 edi: 0000014c ebp: 00000001 esp: eac7799c
ds: 007b es: 007b ss: 0068
Process modprobe (pid: 12069, threadinfo=eac76000 task=dfeb2070)
Stack: <0>0000004b eac779b8 eac77a30 fa39b06d 00000000 eac779b8 fa3b36f3 00205858
0000c90e 0000096c 00000001 00000971 00000002 00000976 00000003 0000097b
00000004 00000980 00000005 00000985 00000006 0000098a 00000007 0000098f
Call Trace:
[<fa39b06d>] bcm43xx_geo_init+0x104/0x119 [bcm43xx]
[<fa39f58b>] bcm43xx_init_one+0x8b/0x101 [bcm43xx]
[<c0269e91>] pci_device_probe+0x4/0x4d
[<c02edf97>] device_attach+0xd/0x71
[<c02ee09b>] driver_attach+0x19/0x2a
[<c02ed9a6>] bus_add_driver+0x5d/0xc0
[<c026a1aa>] pci_bus_match+0x18/0x29
Code: 0b 66 00 00 7b 36 fa eb 83 83 ec 0c 89 1c 24 89 74 24 04 89 7c 24 08 8b 5c 24 14 8b 54 24 10 0f b7 03 8d ba 4c 01 00 00 8d 73 08 <66> 89 82 44 01 00 00 0f b6 43 02 c6 82 47 01 00 00 00 88 82 46


Kernel version: Gentoo-sources-2.6.16
ieee80211softmac-0.1-r20060329
bcm43xx-0.0.1-r20060329
card (from lspci):
02:03.0 Network controller: Broadcom Corporation BCM4309 802.11a/b/g (rev 02)

Does anybody know how i can get it working?
Back to top
View user's profile Send private message
ibbumpin
n00b
n00b


Joined: 05 Mar 2005
Posts: 22
Location: Chicago

PostPosted: Tue Apr 04, 2006 12:41 am    Post subject: WEP Encryption issue Reply with quote

Hi All,

I'm on a 15" powerbook G4 1.6Ghz.
kernel: gentoo-sources 2.6.15-r1

I have bc43xx working with softmac for non-WEP connections but I when I try to set a WEP key through iwconfig or via /etc/conf.d/wireless I get the error:
Code:

Error for wireless request "Set Encode" (8B2A) :
     SET failed on device eth2 ; Operation not supported.


I used bcm34xx-fwcutter on the Airport driver that cam with my Mac. I tried other drivers with even more problems. Is there another driver that I should try or kernel options that I need? I noticed now that in my kernel ieee80211 support is disabled and I figure that is correct since bcm43xx is replacing that. I have had this issue with the past 3 released portage packages. As of today I am using:
Code:

net-wireless/bcm43xx 0.0.1-r20060329
net-wirelss/ieee80211softmac 0.1-r20060329


I have only seen one other person with this issue and nobody answered his question...that I saw.

If you can think of anything for me to try, any help is appreciated :)

Thanks,

Matt
_________________
"I don't wanna large farva! I want a God damn liter'a'cola!" - R. Farva
Back to top
View user's profile Send private message
g_kos
n00b
n00b


Joined: 04 Apr 2006
Posts: 1

PostPosted: Tue Apr 04, 2006 11:31 pm    Post subject: weird tranfer rates on G Reply with quote

Hi List,

my first post, and a request for help.

have succesfully connected to the WPA-PSK network using
bcm43xx-0.0.1-r20060329
ieee80211softmac-0.1-r20060329

Great work and big thanks to the developers, but there is problem.

Whenever I a file transfer starts (ftp,sftp, nfs) the bandwidth does not go higher than 32Kb, wehich is really frustrating.
If I change the rate to 11M the connection drops completely. However, if you lower it gradually, say rate 48M, then wait several seconds, then rate 36 etc untill 11M, it is possible to get a stable and working 640 Kb transfer rate.

I've tried it in several different configurations: NOWEP, WEP, WPA-PSK and the result is the same.

Any suggestions?
Back to top
View user's profile Send private message
e-ipi
Apprentice
Apprentice


Joined: 23 Aug 2005
Posts: 192

PostPosted: Wed Apr 05, 2006 12:23 am    Post subject: Reply with quote

e-ipi wrote:

I haven't, but I noticed from reading the changelog on 2.6.17-rc1 that bcm43xx & softmac are now in the linux kernel sources.


Unfortunately, 2.6.17-rc1 doesn't boot here [Powerbook6,8.]
Back to top
View user's profile Send private message
Grexe
n00b
n00b


Joined: 26 Oct 2005
Posts: 29
Location: Vienna

PostPosted: Thu Apr 06, 2006 7:05 pm    Post subject: 2.6.17-rc1 does not boot Reply with quote

e-ipi wrote:
Unfortunately, 2.6.17-rc1 doesn't boot here [Powerbook6,8.]

Here neither, freezes right after loading the kernel image.
I have a Powerbook G4 Titanium@500MHz, 2.6.15 boots fine.

BTW is it necessary to have a System.map on ppc? It gets compiled but as it was never mentioned, I did not include it in my yaboot.conf and Linux boots just fine without it...
_________________
There are two states of gentoo boxes: compiling and turned off...
Back to top
View user's profile Send private message
KeyserZero
n00b
n00b


Joined: 21 Mar 2005
Posts: 68

PostPosted: Fri Apr 07, 2006 7:02 am    Post subject: Reply with quote

Hey!

Grexe:

No it is not necessary to have a System.map. When you build a kernel the makfile will create a System.map automatically.

Greetz
_________________
www.ruby-lang.org
Back to top
View user's profile Send private message
Grexe
n00b
n00b


Joined: 26 Oct 2005
Posts: 29
Location: Vienna

PostPosted: Fri Apr 07, 2006 7:47 am    Post subject: [slightly OT] System.map on PPC Reply with quote

KeyserZero wrote:
When you build a kernel the makfile will create a System.map automatically.

Just to go sure: The System.map is created, but I wonder if I need to copy it to /boot and reference it via "sysmap=..." in my yaboot.conf - I tried both with and without, using kernel 2.6.17, and it did not work, so I suspect some driver is broken.

As for the bcm43xx-driver, is it the same if I apply the latest patch to e.g. kernel 2.6.16, or is the driver in 2.6.17 any different?
Thanks for any clearification, I'm currently stuck with a "working" BCM4306-PC-Card that can connect but stays offline (times out on authentication)... will try a different firmware today (Apple Airport2)
_________________
There are two states of gentoo boxes: compiling and turned off...
Back to top
View user's profile Send private message
nelz
n00b
n00b


Joined: 24 Apr 2003
Posts: 19
Location: Warrington, UK

PostPosted: Fri Apr 07, 2006 8:40 am    Post subject: Re: weird tranfer rates on G Reply with quote

g_kos wrote:
Whenever I a file transfer starts (ftp,sftp, nfs) the bandwidth does not go higher than 32Kb,


I see the same here. With the 20060125 drivers I get around 2.5MB/s but with 20060329 I get around 28KB/s.
Back to top
View user's profile Send private message
fuoco
Guru
Guru


Joined: 23 May 2004
Posts: 386
Location: Israel

PostPosted: Sat Apr 08, 2006 8:02 am    Post subject: Reply with quote

bcm43xx is indeed included in 2.6.17-rc1, but that kernel has a problem and won't boot on G4 machines. So for now I stick with 2.6.16.1 with the all-in-one patch. I haven't used the ebuilds.

I still have no success using bcm43xx with networkmanager, did anyone get it working ?
It seems fedora made fixes for that, but I was unable to find out exactly what these are...
Back to top
View user's profile Send private message
agm650
n00b
n00b


Joined: 25 Sep 2004
Posts: 47
Location: France

PostPosted: Sat Apr 08, 2006 3:36 pm    Post subject: Reply with quote

e-ipi wrote:
e-ipi wrote:

I haven't, but I noticed from reading the changelog on 2.6.17-rc1 that bcm43xx & softmac are now in the linux kernel sources.


Unfortunately, 2.6.17-rc1 doesn't boot here [Powerbook6,8.]


on an another forum a user ( bz31 ) found this patch:
http://lists.debian.org/debian-powerpc/2006/04/msg00085.html

he have been able to use the 2.6.17 kernel with it :)

i'm going to try it as soos as possible :)
Back to top
View user's profile Send private message
fuoco
Guru
Guru


Joined: 23 May 2004
Posts: 386
Location: Israel

PostPosted: Sat Apr 08, 2006 3:39 pm    Post subject: Reply with quote

I tried it already but although the kernel boots, i have tons of other problems. bcm43xx didn't load well, drm modules don't compile against it and sound stopped working :(
Back to top
View user's profile Send private message
Grexe
n00b
n00b


Joined: 26 Oct 2005
Posts: 29
Location: Vienna

PostPosted: Sun Apr 09, 2006 10:54 am    Post subject: Can't boot even 2.6.16.1 Reply with quote

fuoco wrote:
bcm43xx is indeed included in 2.6.17-rc1, but that kernel has a problem and won't boot on G4 machines. So for now I stick with 2.6.16.1 with the all-in-one patch.

I even cannot boot 2.6.16.1 on my TiBook G4 500MHz. Used same config and updated through "make oldconfig", but the kernel stops at the initial screen that shows the version and other kernel-info...
How to I get more debugging-output to find out what the problem is?
Any ideas?
Does 2.6.15+devicescape work?
_________________
There are two states of gentoo boxes: compiling and turned off...
Back to top
View user's profile Send private message
e-ipi
Apprentice
Apprentice


Joined: 23 Aug 2005
Posts: 192

PostPosted: Mon Apr 10, 2006 2:11 am    Post subject: Reply with quote

agm650 wrote:


on an another forum a user ( bz31 ) found this patch:
http://lists.debian.org/debian-powerpc/2006/04/msg00085.html

he have been able to use the 2.6.17 kernel with it :)

i'm going to try it as soos as possible :)


Paul Mackerras' patch works here. However, as also reported on the Debian-PPC list, sound doesn't work even with the patch. Fortunately, at least bcm43xx and softmac work fine.
Back to top
View user's profile Send private message
sceptiq
Tux's lil' helper
Tux's lil' helper


Joined: 29 Nov 2004
Posts: 103

PostPosted: Mon Apr 10, 2006 12:26 pm    Post subject: Reply with quote

I tried to build the kernel, but i cant find the menu entry vor bcm

Location:
-> Device Drivers
-> Network device support
-> Wireless LAN (non-hamradio)
-> BCM43xx data transfer mode (<choice> [=n])

but there is no bcm stuff
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Goto page Previous  1, 2, 3 ... 19, 20, 21 ... 40, 41, 42  Next
Page 20 of 42

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum