Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Native Airport Extreme Drivers
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 32, 33, 34 ... 40, 41, 42  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
koprimer
n00b
n00b


Joined: 29 Feb 2004
Posts: 64

PostPosted: Mon Sep 25, 2006 8:03 am    Post subject: Reply with quote

I have a Broadcom 4318 that I finally got working. I posted some tips here if anyone wants to read them. It's mainly just a list of things I had to do to get it working, looking forward to the next release of the driver.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2773

PostPosted: Mon Sep 25, 2006 7:49 pm    Post subject: Reply with quote

Hi, ALL,
I have problem installing the firmware. Could somebody check it, please:

Code:

localhost igor # bcm43xx-fwcutter -w /lib/firmware wl_apsta.o
Sorry, the input file is either wrong or not supported by bcm43xx-fwcutter.
I can't find the MD5sum b616ebb615ef696f9b7dc5c53c4e9173 :(
localhost igor #


This is on DELL E1505 using DELL 1390 Mini-PCI card. But I don't think it's releavant here... :)
The file is freshly downloaded from http://jak.kvalitne.cz/pub/puma.habrova.jarov.czf/~jaha2x/wl500/wl_apsta.o...

Thank you.

[EDIT]
P.S.: I also have 2 questions to JoseJX:
1. Is 10-piece patchset already implemented?
2. Do you need someone with DELL 1390 card for developmental/testing purposes? I can offer my DELL E1505 if you are still intereseted...
[/EDIT]


Last edited by ONEEYEMAN on Mon Sep 25, 2006 9:03 pm; edited 1 time in total
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Mon Sep 25, 2006 8:48 pm    Post subject: Reply with quote

I've tried to download that file a number of times now and it keeps canceling part of the way through the transfer. You should find another place to download it from.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2773

PostPosted: Mon Sep 25, 2006 9:08 pm    Post subject: Reply with quote

Jose,
fwcutter mention only 3 places to get the file. One is unaccessible, one is unavailable and this is third.
Mybe the second one is your case?

I also modified the original post with the 2 questions to you...

Thank you.
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Mon Sep 25, 2006 9:23 pm    Post subject: Reply with quote

Searching google will quickly find a working wl_apsta.o, for instance this one:
http://drinus.net/airport/wl_apsta.o

As for your questions:
1. If you're asking about the 0x4311/0x4312 patches, yes it is, but not in mainline. It's in wireless dev.
2. One of the driver developers might want to use it, ask on the bcm43xx-dev mailing list on berlios please!
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2773

PostPosted: Mon Sep 25, 2006 11:20 pm    Post subject: Reply with quote

JoseJX wrote:

As for your questions:
1. If you're asking about the 0x4311/0x4312 patches, yes it is, but not in mainline. It's in wireless dev.


You mean it is in the unstable gentoo-sources? Which one?


JoseJX wrote:

2. One of the driver developers might want to use it, ask on the bcm43xx-dev mailing list on berlios please!


Posted there/

Thank you.

[EDIT]
P.S.: Also, this is from the fist page:

Quote:

7. Make sure that you have hotplug installed for firmware loading support, wireless-tools for the iwconfig tool and wpa_supplicant if you require WPA support


Is this a kernel option or I need to install something else? I am talking about the hotplug, I have wireless-tools installed...
[/EDIT]

[EDIT2]
P.P.S.: In my kernel I have this:

Code:

#PCI HotPlug Support
#
# CONFIG_HOTPLUG_PCI is not set


Is that what it is?
[/EDIT2]
Back to top
View user's profile Send private message
timotheus25
Apprentice
Apprentice


Joined: 27 Dec 2005
Posts: 162
Location: *upstate* New York, USA

PostPosted: Tue Sep 26, 2006 2:16 am    Post subject: Reply with quote

"wireless dev" is an experimental kernel branch that you can 'git' at:

git://git.kernel.org/pub/scm/linux/kernel/git/linville/wireless-dev.git

If you don't know what that is, then you can:
Code:

emerge -av dev-util/git


And look at:
http://kernel.org/pub/software/scm/git/docs/

Good luck...
_________________
http://tstotts.net/linux/gentoopb.html
http://tstotts.net/linux/gentooinsp640m.html
Back to top
View user's profile Send private message
all-inc.
Tux's lil' helper
Tux's lil' helper


Joined: 03 Jul 2004
Posts: 138
Location: Darmstadt.Germany.EU

PostPosted: Wed Sep 27, 2006 11:54 pm    Post subject: Reply with quote

you don't need hotplug anymore for fw loading, your kernel does it if you compiled it with CONFIG_FW_LOADER=y
you also don't neet pci hotplugging, this has nothing to do with firmware loading :)

sebastian
_________________
# make config; not war
registered linux user # 265707
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Thu Sep 28, 2006 12:50 am    Post subject: Reply with quote

all-inc.:
Sort of. :) Hotplug still handles firmware loading if you're using udev-094 or older. If you're using udev-096 or newer, udev handles the firmware loading.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
mwallace
n00b
n00b


Joined: 08 Jul 2006
Posts: 52
Location: Frankfurt/Germany

PostPosted: Sat Sep 30, 2006 11:51 am    Post subject: Reply with quote

Hi,

I'm still trying to get my 4318 chip working. I installed the 2.6.18 kernel and patched it with patch_2.6.18_to_wireless-2.6.bz2 from ftp://lwfinger.dynalias.org

When I try to associate, I get an error:
SoftMAC: association failed (reason: 0x13) !

Is there a way to solve this?
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Sat Sep 30, 2006 3:22 pm    Post subject: Reply with quote

Are you sure you're using 2.6.18? That error means that the STA (the bcm43xx driver) doesn't support the Short Preamble option. We fixed that a while ago in SoftMAC and the fix is definitely in 2.6.18 (line 185 in ieee80211softmac_io.c, the SHORT_PREABLE capability bit is set).
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
mwallace
n00b
n00b


Joined: 08 Jul 2006
Posts: 52
Location: Frankfurt/Germany

PostPosted: Sat Sep 30, 2006 5:32 pm    Post subject: Reply with quote

Yes, I'm absolutely sure. I used the 2.6.18 gentoo-sources. But that should not be a problem, right? Very strange...
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Sat Sep 30, 2006 8:50 pm    Post subject: Reply with quote

No, it shouldn't be a problem, the fix is in all 2.6.18 kernels. Make sure that uname -a shows the right kernel. I've got no other suggestions, I've had nobody else report this problem since we changed SoftMAC early in the 2.6.18 cycle. :p
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
mwallace
n00b
n00b


Joined: 08 Jul 2006
Posts: 52
Location: Frankfurt/Germany

PostPosted: Sat Sep 30, 2006 10:05 pm    Post subject: Reply with quote

I got it working! The problem was a setting in my AP to only accept G-mode wlan devices. That caused the 0x13 error. Now I can even use WPA. Ok, the distance where it works is not so big, but I would estimate approx. 5 meters.
Oh, and I changed the channel from 6 to 8 on my AP since there are too many networks here using 6. Maybe that helped as well...
Really good work guys. If you need some more testing you can ask me. I am glad to help.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2773

PostPosted: Sun Oct 01, 2006 5:45 am    Post subject: Reply with quote

Hi, JoseJX,
I applied the 10-pcs patch to my 2.6.17-r7 gentoo-sources kernel, and it now recognizes the card.
However the code in the 2.6.17-r7 does not work properly. Here is the patch from the bcm43xx people:

Index: wireless-2.6/drivers/net/wireless/bcm43xx/bcm43xx_main.c
===================================================================
--- wireless-2.6.orig/drivers/net/wireless/bcm43xx/bcm43xx_main.c
+++ wireless-2.6/drivers/net/wireless/bcm43xx/bcm43xx_main.c
@@ -2607,8 +2607,10 @@ static int bcm43xx_probe_cores(struct bc
/* fetch sb_id_hi from core information registers */
sb_id_hi = bcm43xx_read32(bcm, BCM43xx_CIR_SB_ID_HI);

+ printk(KERN_INFO PFX "sb_id_hi: 0x%8x\n", sb_id_hi);
core_id = (sb_id_hi & 0x8FF0) >> 4;
- core_rev = (sb_id_hi & 0x7000) >> 8;
+ core_rev = (sb_id_hi & 0x7000) >> 8;
+ core_rev |= (sb_id_hi & 0xF);
core_vendor = (sb_id_hi & 0xFFFF0000) >> 16;

/* if present, chipcommon is always core 0; read the chipid from it */

Also, what is the best choice for it to work: wireless-tools or wpa-supplicant?

Thank you.
Back to top
View user's profile Send private message
saintpa
Tux's lil' helper
Tux's lil' helper


Joined: 04 Dec 2004
Posts: 77

PostPosted: Tue Oct 03, 2006 8:41 pm    Post subject: Reply with quote

JoseJX wrote:
Searching google will quickly find a working wl_apsta.o, for instance this one:
http://drinus.net/airport/wl_apsta.o

As for your questions:
1. If you're asking about the 0x4311/0x4312 patches, yes it is, but not in mainline. It's in wireless dev.
2. One of the driver developers might want to use it, ask on the bcm43xx-dev mailing list on berlios please!


JoseJX, I'm currently using the ndiswrapper method to bring up my bcm4311 device. I'm wondering when would be the planned inclusion date/kernel-version for the wireless dev (dscape) into the main kernel tree. I'm anxiously waiting so that I don't have to recompile ndiswrapper on kernele upgrades. Thanks.
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Tue Oct 03, 2006 10:33 pm    Post subject: Reply with quote

ONEEYEMAN:
We suggest using the git repository now, those patches are extremely out of date. Larry's ftp (linked above) has patches for 2.6.18 to add in this support.

saintpa:
Not before 2.6.20 (so at least 6 months away). Devicescape currently has major issues with locking, so it's useless on SMP. Until those issues are fixed, there is no chance of it getting merged upstream.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
saintpa
Tux's lil' helper
Tux's lil' helper


Joined: 04 Dec 2004
Posts: 77

PostPosted: Tue Oct 03, 2006 11:54 pm    Post subject: Reply with quote

JoseJX wrote:
saintpa:
Not before 2.6.20 (so at least 6 months away). Devicescape currently has major issues with locking, so it's useless on SMP. Until those issues are fixed, there is no chance of it getting merged upstream.


I have a dual-core yonah cpu. So that means that even if I build from git repository, I still can't get the 4311 card to work, right? I will wait for it to stablize then.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2773

PostPosted: Wed Oct 04, 2006 12:38 am    Post subject: Reply with quote

JoseJX wrote:

ONEEYEMAN:
We suggest using the git repository now, those patches are extremely out of date. Larry's ftp (linked above) has patches for 2.6.18 to add in this support.


Yes, I talked to Larry. He said that he's patches are for 2.6.18. However, I have 2.6.17-r7 gentoo-sources, and there is a bug currently open for upgrade. Which means, that I will have a hard time going upstream with the driver....

Also, he said that his patches won't apply to 2.6.17... :(

I guess, all I need is to wait until 2.6.18 becomes stable, or at least the bug will be resolved.

Thank you.

P.S.: What are the suggested steps to use the repository? Is there a HOW-TO? about kernel options and everything....
Back to top
View user's profile Send private message
nesl247
Veteran
Veteran


Joined: 15 Jun 2004
Posts: 1614
Location: Florida

PostPosted: Fri Oct 06, 2006 8:58 pm    Post subject: Reply with quote

Has anyone gotten 4311 to work? I searched the first page or two but didn't feel like browsing 33 pages. Not sure if it matters but I have a dual core turion x2 (some things don't work with smp is why I mention it).
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Fri Oct 06, 2006 10:02 pm    Post subject: Reply with quote

Devicescape has severe locking issues, so isn't really usable on SMP. Larry Finger has some patches that will work for SoftMAC, but they have not been integrated yet, and at this point, they may not at all. The patches have been listed a few times already in this thread, read backwards next time, usually the first few pages in long threads aren't current. :p

Good luck.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
nesl247
Veteran
Veteran


Joined: 15 Jun 2004
Posts: 1614
Location: Florida

PostPosted: Fri Oct 06, 2006 10:05 pm    Post subject: Reply with quote

Ugh I just give up with this for now. I really am hating this laptop right now, but oh well.
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Fri Oct 06, 2006 10:28 pm    Post subject: Reply with quote

Sorry, I didn't mean that to be harsh, it's just that none of the devs on this project have this card. Work is being done to support it, but there's nothing I can point you at and say: "This is what you need."

Sorry. :p
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
nesl247
Veteran
Veteran


Joined: 15 Jun 2004
Posts: 1614
Location: Florida

PostPosted: Fri Oct 06, 2006 10:31 pm    Post subject: Reply with quote

Didn't think you were harsh, just pissed that I got STUCK with this card (Had a very limited selection of laptops for the lemon deal at best buy).
Back to top
View user's profile Send private message
Bigun
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 2155

PostPosted: Sat Oct 07, 2006 3:10 pm    Post subject: Reply with quote

Has anyone tried this new driver with 2.6.19-rc1?
_________________
"It's ok, they might have guns but we have flowers." - Perpetual Victim
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Goto page Previous  1, 2, 3 ... 32, 33, 34 ... 40, 41, 42  Next
Page 33 of 42

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum