Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
I'm retarded and can't figure out what this means
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Vermis
n00b
n00b


Joined: 17 Nov 2005
Posts: 7

PostPosted: Sat Dec 10, 2005 11:34 am    Post subject: I'm retarded and can't figure out what this means Reply with quote

checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool

!!! Please attach the config.log to your bug report:
!!! /var/tmp/portage/gnome-themes-extras-0.8.1/work/gnome-themes-extras-0.8.1/config.log

!!! ERROR: x11-themes/gnome-themes-extras-0.8.1 failed.
!!! Function econf, Line 485, Exitcode 0
!!! econf failed
!!! If you need support, post the topmost build error, NOT this status message.


Help...?
Back to top
View user's profile Send private message
UncleOwen
Veteran
Veteran


Joined: 27 Feb 2003
Posts: 1493
Location: Germany, Hamburg

PostPosted: Sat Dec 10, 2005 11:43 am    Post subject: Reply with quote

Do you have dev-perl/XML-Parser installed?
Back to top
View user's profile Send private message
Vermis
n00b
n00b


Joined: 17 Nov 2005
Posts: 7

PostPosted: Sun Dec 11, 2005 1:38 am    Post subject: Reply with quote

As I said, I'm retarded. Thanks much ^^
Back to top
View user's profile Send private message
scoon
l33t
l33t


Joined: 23 Aug 2003
Posts: 747
Location: Philadelphia, PA

PostPosted: Sun Dec 11, 2005 2:56 am    Post subject: Reply with quote

Ok.. Well that error means that you DO NOT HAVE IT INSTALLED.
_________________
Hope this helps........
Back to top
View user's profile Send private message
yngwin
Retired Dev
Retired Dev


Joined: 19 Dec 2002
Posts: 4572
Location: Suzhou, China

PostPosted: Sun Dec 11, 2005 12:19 pm    Post subject: Reply with quote

Which would be a bug in the ebuild. That package then needs to be in the depend list...
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 10289
Location: Somewhere over Atlanta, Georgia

PostPosted: Tue Dec 27, 2005 3:59 pm    Post subject: Ghosts in the Machine Reply with quote

Well, not exactly.

I was having the same problem while building openoffice.

I checked the dependecies in the intltool ebuild and, sure enough, XML-Parser was listed as a dependency of intltool.

I then checked with equery to see if, for some reason, the XML-Parser had not been built and found out that it had been built (!), just as it should have been.

My best guess is that I caused this problem myself, however this is only a guess. Last week I rebuilt Perl after adding the ithreads USE flag. I did not rebuild the packages that depended on Perl, which, incidentally, include intltool.

My solution was to remerge intltool:
Code:
emerge intltool

Thereafter, the problem with the original build disappeared.

Vermis, does that sound like something you might have done? Remerging Perl, that is?

- John
Back to top
View user's profile Send private message
scoon
l33t
l33t


Joined: 23 Aug 2003
Posts: 747
Location: Philadelphia, PA

PostPosted: Tue Dec 27, 2005 5:19 pm    Post subject: Reply with quote

Hey there,

Wouldn't the --newuse flag for emerge helped you to find anything that needs to be rebuilt if you started changing flags ?

Just thinking out loud there: It may not have if the new use var was added using /etc/portage/package.use.

regards,
scoon
_________________
Hope this helps........
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 10289
Location: Somewhere over Atlanta, Georgia

PostPosted: Tue Dec 27, 2005 7:08 pm    Post subject: Reply with quote

Yes, I believe that that was my fundamental mistake.

- John
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4923
Location: Gothenburg, Sweden

PostPosted: Tue Dec 27, 2005 8:32 pm    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads in favour of topic 197754.
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum