Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Trying to Install Gentoo on OldWorld Beige G3 with Quik
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message

Joined: 30 Dec 2005
Posts: 12

PostPosted: Fri Dec 30, 2005 4:20 am    Post subject: Trying to Install Gentoo on OldWorld Beige G3 with Quik Reply with quote

Here's my hardware...

Power Macintosh G3 (Beige)
266 MHz PowerPC G3 Processor
768 MB PC66 Memory
6 GB IDE Hard Disk (Primary Master)
24x IDE CD-ROM (Secondary Master)
100MB SCSI Zip100 Drive (ID 5)
Floppy Drive

Here's what I've done so far...

Installed and configured BootX in the current MacOS 9.x installation.
Booted from the Gentoo PPC 2005.1-r1 Universal Install CD.
Used the following partition scheme:
/dev/hda1    n/a        32k    Apple_partition_map
/dev/hda2    ext2      32MB    Boot
/dev/hda3    (swap)   512MB    Swap
/dev/hda4    ext3     5.5GB    Root

Followed the rest of the PPC Handbook to the best of my abilities.
Emerged quik and configured quik.conf to match my kernel and volume structure.
Used nvsetenv to set Open Firmware boot variables.
Ran "quik -v -C /boot/quik.conf".

And nothing came up. No video signal, no response from the keyboard (no caps lock light), no network activity, etc. All I got was a startup chime and a black screen.

I rebooted and zapped the PRAM to clear the OF variables. I was then able to boot from a MacOS 9.x CD. I enabled AppleTalk on my network adapter and connected to an AFP share on another box. From there, I fired up bootvars and tried changing some OF variables. I wrote the new values and rebooted...

And nothing came up. Over and over again I tried different settings, but to no avail. It always get a chime and black screen, and have to zap the PRAM again.

Here's some of the Open Firmware boot variables I've tried...



/boot/kernel-2.6.14 root=/dev/hda4





My best guess is that these settings are incorrect because my box goes comatose every time I reboot. Has anyone successfully used Quik as a bootloader and knows the right settings?

Since I wiped out the HFS+ partition that had my MacOS 9.x installation, I can't easily try using BootX to bring it up the new Gentoo installation. Nor can I use BootX to fire up the Install CD and chroot back in. I suppose one of the next logical steps would be burn a custom CD or use a Zip disk with MacOS 9.x and BootX. Is there anything I should know before attempting this?

As nice as it would be to just go through the entire install routine again, I'd really rather not. This box isn't the fastest in the world, and takes quite a while to sync Portage and compile the kernel. As comfortable as I am with installing Gentoo on x86, this is my first attempt on PPC. I'm sure it's possible that I could've screwed something up. But because the box doesn't seem to even try accessing the hard disk, I'm skeptical that the current problem is the fault of my Gentoo installation.

Any ideas?
Back to top
View user's profile Send private message
Retired Dev
Retired Dev

Joined: 28 Apr 2002
Posts: 2774

PostPosted: Fri Dec 30, 2005 1:45 pm    Post subject: Reply with quote

My best guess is that you've set the load base wrong, if check with the quirks page again linked from the handbook and make sure that you're using the correct values for your system. You can probably still boot into open firmware by pressing apple+option+O+F, which would let you override this so you wouldn't have to reinstall every time.
Gentoo PPC FAQ:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum