Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Emerge Question
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
jeffgman
n00b
n00b


Joined: 05 Jun 2004
Posts: 40

PostPosted: Sat Dec 17, 2005 4:33 pm    Post subject: Emerge Question Reply with quote

I just did an emerge -uaD and got the following output:

These are the packages that I would merge, in order:

Calculating world dependencies ...done!
[ebuild U ] sys-apps/man-pages-2.16 [2.15]
[ebuild U ] net-misc/curl-7.15.1 [7.15.0]
[ebuild NS ] sys-kernel/gentoo-sources-2.6.14-r5
[ebuild N ] x11-apps/ttmkfdir-3.0.9-r3
[ebuild N ] x11-base/opengl-update-2.2.1
[ebuild N ] media-libs/fontconfig-2.2.3
[ebuild N ] x11-base/xorg-x11-6.8.2-r6
[ebuild N ] virtual/x11-6.8
[ebuild N ] app-arch/rpm2targz-9.0-r3
[ebuild N ] sys-apps/utempter-0.5.5.6
[ebuild N ] x11-terms/xterm-204
[ebuild N ] x11-libs/openmotif-2.2.3-r3
[ebuild N ] app-text/xpdf-3.01-r3
[ebuild U ] net-print/cups-1.1.23-r4 [1.1.23-r1]


How do I find out what is trying to install the X-11 and xorg programs? I am running a server, and do not want any gui type programs installed if I don't have to.

Thanks,
Jeff
Back to top
View user's profile Send private message
Sujao
l33t
l33t


Joined: 25 Sep 2004
Posts: 677
Location: Germany

PostPosted: Sat Dec 17, 2005 4:52 pm    Post subject: Reply with quote

Cups now depends on xpdf and this depends on X

Look here:
https://forums.gentoo.org/viewtopic-t-412964-highlight-xpdf.html
Back to top
View user's profile Send private message
startail
n00b
n00b


Joined: 25 Sep 2005
Posts: 71

PostPosted: Sat Dec 17, 2005 4:52 pm    Post subject: Reply with quote

You can try to add x11 to your portage.mask file to prevent it to install.
Then it will show an error for the ebuild that needs it.

You can also, if you haven't already, add -x11 to make.conf
Back to top
View user's profile Send private message
jeffgman
n00b
n00b


Joined: 05 Jun 2004
Posts: 40

PostPosted: Sat Dec 17, 2005 5:05 pm    Post subject: Reply with quote

Sujao wrote:
Cups now depends on xpdf and this depends on X

Look here:
https://forums.gentoo.org/viewtopic-t-412964-highlight-xpdf.html


Thanks for the info. That article helped.
Back to top
View user's profile Send private message
jeffgman
n00b
n00b


Joined: 05 Jun 2004
Posts: 40

PostPosted: Sat Dec 17, 2005 5:06 pm    Post subject: Reply with quote

startail wrote:
You can try to add x11 to your portage.mask file to prevent it to install.
Then it will show an error for the ebuild that needs it.

You can also, if you haven't already, add -x11 to make.conf


I already have -x11 to my make.conf. I had to add -motif to get it to not install the x11 deps.

Thanks for the help.

Jeff
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum