Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Error when update world
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
chy168
n00b
n00b


Joined: 12 Mar 2005
Posts: 70

PostPosted: Tue Dec 20, 2005 1:04 pm    Post subject: Error when update world Reply with quote

Hi,
I try to update my world. (emerge world -U)

But I got some error message.
Code:
/bin/sh ../libtool --silent --mode=link --tag=CXX i686-pc-linux-gnu-g++  -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -Wall -W -Wpointer-arith -DNDEBUG -DNO_DEBUG -O2 -O2 -pipe -march=pentium4 -Wformat-security -Wmissing-format-attribute -Wno-non-virtual-dtor -fno-exceptions -fno-check-new -fno-common  -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION    -o libkio.la -rpath /usr/kde/3.4/lib -version-info 6:0:2 -no-undefined -Wl,--no-undefined -Wl,--allow-shlib-undefined -L/usr/kde/3.4/lib -L/usr/qt/3/lib -L/usr/lib     dummy.lo kssl/libkssl.la kio/libkiocore.la kio/libksycoca.la bookmarks/libkbookmarks.la kfile/libkfile.la ../kdeui/libkdeui.la ../kdesu/libkdesu.la ../kwallet/client/libkwalletclient.la -lz -lfam
grep: /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.6/libstdc++.la: No such file or directory
/bin/sed: can't read /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.6/libstdc++.la: No such file or directory
libtool: link: `/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.6/libstdc++.la' is not a valid libtool archive
make[3]: *** [libkio.la] Error 1
make[3]: Leaving directory `/var/tmp/portage/kdelibs-3.4.3/work/kdelibs-3.4.3/kio'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/kdelibs-3.4.3/work/kdelibs-3.4.3/kio'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/kdelibs-3.4.3/work/kdelibs-3.4.3'
make: *** [all] Error 2

!!! ERROR: kde-base/kdelibs-3.4.3 failed.
!!! Function kde_src_compile, Line 173, Exitcode 2
!!! died running emake, kde_src_compile:make
!!! If you need support, post the topmost build error, NOT this status message.


My WM is 'Gnome'

but the message has something about kde.
It think it's kde-base/kopete I installed before.
But I've remove kopete now.

How can I solve this problem?


thank you very much.
Back to top
View user's profile Send private message
boogerman
Apprentice
Apprentice


Joined: 10 Dec 2004
Posts: 253
Location: Tennessee

PostPosted: Tue Dec 20, 2005 2:05 pm    Post subject: Reply with quote

see if this works for you:
Code:
USE="-kde" emerge -uD world
Best of luck.
Back to top
View user's profile Send private message
Grimmlin
n00b
n00b


Joined: 15 Mar 2005
Posts: 32

PostPosted: Tue Dec 20, 2005 9:16 pm    Post subject: Reply with quote

First, try to do

Code:
emerge gentoolkit
revdep-rebuild -pv


and look if you have broken dependencies.

HTH

Grimm'
_________________
http://www.pentoo.ch
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 18154

PostPosted: Tue Dec 20, 2005 9:28 pm    Post subject: Reply with quote

Moved from Other Things Gentoo
_________________
Those who know what's best for us must rise and save us from ourselves.
Back to top
View user's profile Send private message
chy168
n00b
n00b


Joined: 12 Mar 2005
Posts: 70

PostPosted: Wed Dec 21, 2005 6:16 am    Post subject: Reply with quote

Hi, I've try
Code:
USE="-kde" emerge -uD world


and try revdep-rebuild -pv

but it still cannot update completely.

Code:

revdep-rebuild -pv

Checking reverse dependencies...
Packages containing binaries and libraries broken by any package update,
will be recompiled.

Collecting system binaries and libraries... done.
  (/root/.revdep-rebuild.1_files)

Collecting complete LD_LIBRARY_PATH... done.
  (/root/.revdep-rebuild.2_ldpath)

Checking dynamic linking consistency...
 done.
  (/root/.revdep-rebuild.3_rebuild)

Assigning files to ebuilds... Nothing to rebuild

Evaluating package order... done.
  (/root/.revdep-rebuild.5_order)

Dynamic linking on your system is consistent... All done.
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Wed Dec 21, 2005 6:30 am    Post subject: Reply with quote

I think this is one of the 1,5 millions of threads regarding libtool/libstdc++ problem.
Code:

../kdesu/libkdesu.la ../kwallet/client/libkwalletclient.la -lz -lfam
 grep: /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.6/libstdc++.la: No such file or directory
 /bin/sed: can't read /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.6/libstdc++.la: No such file or directory
 libtool: link: `/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.6/libstdc++.la' is not a valid libtool archive

Search the forums for libtool and/or libstdc++ and you will get thousands of posts.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
chy168
n00b
n00b


Joined: 12 Mar 2005
Posts: 70

PostPosted: Wed Dec 21, 2005 2:19 pm    Post subject: Reply with quote

6thpink wrote:
I think this is one of the 1,5 millions of threads regarding libtool/libstdc++ problem.
Code:

../kdesu/libkdesu.la ../kwallet/client/libkwalletclient.la -lz -lfam
 grep: /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.6/libstdc++.la: No such file or directory
 /bin/sed: can't read /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.6/libstdc++.la: No such file or directory
 libtool: link: `/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.6/libstdc++.la' is not a valid libtool archive

Search the forums for libtool and/or libstdc++ and you will get thousands of posts.


thank you for give the direction to solve my problem.

I've searched some keyword about that.

https://forums.gentoo.org/viewtopic-t-279020.html
https://forums.gentoo.org/viewtopic-t-318790.html

I try
Code:
fix_libtool_files.sh <old_version> --oldarch <incorrect_CHOST>


But, I meet a problem.


How can I know my old gcc version ?


thank you :)
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Wed Dec 21, 2005 2:23 pm    Post subject: Reply with quote

It's in the path of the missing library - 3.3.6 in your case. Please follow up to one of the threads you found if you have any more problems.

Moved from Portage & Programming to Duplicate Threads.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum