Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Missing ebuilds - gnome-device-manager & skype after --sync
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
golding
Apprentice
Apprentice


Joined: 07 Jun 2005
Posts: 230
Location: Adelaide / South Australia

PostPosted: Thu Dec 22, 2005 2:15 am    Post subject: Missing ebuilds - gnome-device-manager & skype after --s Reply with quote

I ran
Code:
emerge --sync

At the end it said new portage available so I ran
Code:
emerge -av portage

and then ran
Code:
etc-update
for the two files listed.

Then went to run
Code:
emerge -avuD world
and was told there are problems in my world file and to run
Code:
emaint --check world

It returned
Code:
rob rob # emaint --check world
Checking world for problems

'net-im/skype' has no ebuilds available
'gnome-extra/hal-device-manager' has no ebuilds available


Finished

I don't think either of those packages has been removed from the system.

Any ideas?

[EDIT]
I tried to re-run --sync but the timestamp didn't allow me to.
_________________
Regards, Robert

..... Some people can tell what time it is by looking at the sun, but I have never been able to make out the numbers.
Back to top
View user's profile Send private message
blue666man
n00b
n00b


Joined: 01 Mar 2005
Posts: 15

PostPosted: Thu Dec 22, 2005 6:53 am    Post subject: Reply with quote

Since both of those packages are in the tree, it is likely that the rsync mirror you are using does not have the most uptodate portage snapshot, or is otherwise hosed. This is a bug and has been reported, but to check if it's true for your case try switching mirror-groups (I used to use namerica, but had to switch back to the default mirror group due to this bug)

In /etc/make.conf:

SYNC="rsync://rsync.gentoo.org/gentoo-portage"

Try using the above mirror or switch to a different region (rsync://namerica.rsync.gentoo.org or something like that)

The bug report is available @ https://bugs.gentoo.org/show_bug.cgi?id=102571. Please post something if this has happened to you.
Back to top
View user's profile Send private message
Paapaa
l33t
l33t


Joined: 14 Aug 2005
Posts: 955
Location: Finland

PostPosted: Thu Dec 22, 2005 9:04 am    Post subject: Re: Missing ebuilds - gnome-device-manager & skype after Reply with quote

golding wrote:

Code:
'net-im/skype' has no ebuilds available
'gnome-extra/hal-device-manager' has no ebuilds available

I don't think either of those packages has been removed from the system..


Both packages are in ~x86, not in stable. Are you using stable? It might be that when you first installed them, they ware in stable, but not anymore. And the new portage is complaining. Just use "emaint --fix" to correct it. I had the same issue with Conky.
Back to top
View user's profile Send private message
tomk
Bodhisattva
Bodhisattva


Joined: 23 Sep 2003
Posts: 7221
Location: Sat in front of my computer

PostPosted: Thu Dec 22, 2005 1:21 pm    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads, please see this topic.
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum