Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Black screen when exiting Xorg
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
akiross
Veteran
Veteran


Joined: 02 Mar 2003
Posts: 1170
Location: Mostly on google.

PostPosted: Fri Dec 23, 2005 8:02 pm    Post subject: Black screen when exiting Xorg Reply with quote

Hello anyone,

Well, i just installed gentoo on my iBook, and i've a problem with Xorg: i start Xorg from the shell and it works, but when i try to switch to a shell (ctrl+alt+F1/2/3/4), the screen is black, without prompt on it.
I can return to xorg with Ctrl+Alt+F7.

If i exit Xorg, the problem persists: all the consoles are black, not usable - but the computer still works (since i use and reboot it via ssh).

Any idea?

Thanks very much
Bye
_________________
Libera scienza in libero stato.
Horizon of Events
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Fri Dec 23, 2005 8:18 pm    Post subject: Reply with quote

Does typing 'reset' followed by hitting the enter key help?
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
akiross
Veteran
Veteran


Joined: 02 Mar 2003
Posts: 1170
Location: Mostly on google.

PostPosted: Fri Dec 23, 2005 9:52 pm    Post subject: Reply with quote

Nope, this seems (i think) a fb-related problem :\

Thanks anyway

APPEND:
Reset doesn't work.
I tried to connect using ssh and launching startx, and this works: X is loaded properly, but the problem of switching/exiting with black screen still remains.
_________________
Libera scienza in libero stato.
Horizon of Events
Back to top
View user's profile Send private message
akiross
Veteran
Veteran


Joined: 02 Mar 2003
Posts: 1170
Location: Mostly on google.

PostPosted: Tue Dec 27, 2005 1:48 am    Post subject: Reply with quote

All the system now works correctly - all configured - but this issue still remains :(

Any idea?

Thanks
_________________
Libera scienza in libero stato.
Horizon of Events
Back to top
View user's profile Send private message
tzutolin
n00b
n00b


Joined: 09 Apr 2005
Posts: 4
Location: Taiwan

PostPosted: Thu Mar 16, 2006 11:03 pm    Post subject: Reply with quote

I have the same problem and I'm using a NVIDIA card :(
Back to top
View user's profile Send private message
truc
Advocate
Advocate


Joined: 25 Jul 2005
Posts: 3199

PostPosted: Thu Mar 16, 2006 11:39 pm    Post subject: Reply with quote

almost same here too, (since modular xorg):

It doesn't always happen, but sometimes, when exiting X or switching VT, the screen just goes black, and as akiross said, computer is still usable (I also issue (an other)startx via ssh and it works again), but it's kind of annoying (have to boot the other computer just for that :( )

I don't think it's FB related since I don't use frame buffer at all.

Sometimes I also have white vertical lines one this black screen...

EDIT: NVIDIA Ti 4200 (who knows...)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum