Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Xorg to emerge all of a sudden
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
elestedt
Guru
Guru


Joined: 13 Mar 2005
Posts: 383

PostPosted: Tue Dec 27, 2005 2:14 pm    Post subject: [SOLVED] Xorg to emerge all of a sudden Reply with quote

After an emerge --sync a week or so ago running emerge -uDvaN1 world all of a sudden returned this:
Code:
# emerge -uDvpN1 world

These are the packages that I would merge, in order:

Calculating world dependencies ...done!
[ebuild  N    ] media-libs/freetype-2.1.9-r1  -bindist -doc +zlib 969 kB
[ebuild  N    ] x11-apps/ttmkfdir-3.0.9-r3  19 kB
[ebuild  N    ] x11-base/opengl-update-2.2.1  0 kB
[ebuild  N    ] media-libs/fontconfig-2.2.3  732 kB
[ebuild  N    ] x11-base/xorg-x11-6.8.2-r6  (-3dfx) (-3dnow) +bitmap-fonts -cjk -debug -dlloader -dmx -doc -font-server -insecure-drivers +ipv6 -minimal (-mmx) +nls -nocxx +opengl +pam -sdk (-sse) -static +truetype-fonts +type1-fonts (-uclibc) -xprint +xv 45,134 kB
[ebuild  N    ] virtual/x11-6.8  0 kB
[ebuild  N    ] media-libs/gd-2.0.33  -fontconfig +jpeg +png -truetype +xpm 573 kB
[ebuild  N    ] app-arch/rpm2targz-9.0-r3  2 kB
[ebuild  N    ] sys-apps/utempter-0.5.5.6  20 kB
[ebuild  N    ] x11-terms/xterm-205  -Xaw3d -doc -toolbar -truetype +unicode 718 kB

Total size of downloads: 48,172 kB

With this info
Code:
Portage 2.0.53 (default-linux/amd64/2005.1, gcc-3.4.4, glibc-2.3.5-r2, 2.6.14.2 x86_64)
=================================================================
System uname: 2.6.14.2 x86_64 AMD Athlon(tm) 64 Processor 3200+
Gentoo Base System version 1.6.13
dev-lang/python:     2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.20
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O3 -march=athlon64 -fforce-address -momit-leaf-frame-pointer -fomit-frame-pointer -ftracer -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -march=athlon64 -fforce-address -momit-leaf-frame-pointer -fomit-frame-pointer -ftracer -pipe -fvisibility-inlines-hidden"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://ftp.du.se/pub/os/gentoo http://ds.thn.htu.se/linux/gentoo http://mirror.pudas.net/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="amd64 alsa apache2 authdaemond avi berkdb bitmap-fonts bzip2 crypt curl eds emboss encode expat foomaticdb fortran gdbm gif glibc-compat20 gmp gpm gstreamer idn imap imlib ipv6 jpeg ldap libwww lzw lzw-tiff maildir mp3 mpeg mysql ncurses nls nptl opengl pam pam-mysql pcre pdflib perl png python quicktime readline samba sasl sdl spell ssl tcpd tiff truetype-fonts type1-fonts udev unicode usb userlocales utf8 valias vhosts xml2 xpm xv zlib userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS

Anyone know what did this and/or how I can find out what did - and ultimatly fix it?
This is a server machine which is not supposed to have any connected screen - except maybe console, but certainly no X-server (as you can see the X-use flag is not set...).

Thanks


Last edited by elestedt on Tue Dec 27, 2005 3:08 pm; edited 1 time in total
Back to top
View user's profile Send private message
arkaine
n00b
n00b


Joined: 23 Jun 2004
Posts: 62
Location: Ohio

PostPosted: Tue Dec 27, 2005 3:02 pm    Post subject: Reply with quote

Just because USE="-X" is set does not necessarily mean programs won't/don't depend on Xorg. Would running emerge -uNDavt world maybe show what program thought it was a dependency?
Back to top
View user's profile Send private message
fvant
Guru
Guru


Joined: 08 Jun 2003
Posts: 328
Location: Leiden, The Netherlands

PostPosted: Tue Dec 27, 2005 3:03 pm    Post subject: Reply with quote

use the -t flag on your emerge world to see the dependency tree, showing you which installed package requires X11. Or the -d flag to get a verbose explanation.

But some gfx packages use the X11 libraries even if you don't display anything on that machine, it's not so strange.
Back to top
View user's profile Send private message
elestedt
Guru
Guru


Joined: 13 Mar 2005
Posts: 383

PostPosted: Tue Dec 27, 2005 3:07 pm    Post subject: Reply with quote

Thanks - running with the f flag it indicated that net-analyzer/mrtg for some reason had media-libs/gd-2.0.33 as a fixed dependency (which in turn had virtual/x11).
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Wed Jan 04, 2006 5:05 pm    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads in favour of GF8: Why is <y> getting pulled in when I emerge <x>?
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum