Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xpdf blocking poppler
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
patrickkidd
n00b
n00b


Joined: 09 Dec 2005
Posts: 14
Location: Alaska

PostPosted: Fri Dec 30, 2005 8:22 pm    Post subject: xpdf blocking poppler Reply with quote

When I emerge -uDp world with a current rsync I get an unexplainable block between xpdf-3.01-r4 and poppler-0.4.3-r1. Neither is installed, and the portage documentation says "It is also possible that two packages that are yet to be installed are blocking each other. In this rare case, you should find out why you need to install both." They are both dependencies of kdegraphics somehow, but I can't see how. Help?

Code:
Calculating world dependencies ...done!
[blocks B     ] <app-text/xpdf-3.01-r4 (is blocking app-text/poppler-0.4.3-r1)
[nomerge      ] kde-base/kde-3.5.0
[ebuild  N    ]  kde-base/kdegraphics-3.5.0-r4
[ebuild  N    ]   app-text/poppler-0.4.3-r1
[nomerge      ] media-plugins/gst-plugins-alsa-0.8.10
[nomerge      ]   kde-base/kdepim-3.5.0-r3
[nomerge      ]    app-crypt/gpgme-1.0.2
[nomerge      ]     app-crypt/gnupg-1.4.2-r3
[nomerge      ]      dev-libs/libusb-0.1.10a
[ebuild  NS   ]       app-text/docbook-sgml-dtd-4.2-r2
[nomerge      ] dev-python/docutils-0.3.3-r1
[nomerge      ]  dev-lang/python-2.3.5-r2
[ebuild  NS   ]   dev-python/python-docs-2.3.5
[nomerge      ] media-plugins/alsa-jack-1.0.10_rc1
[nomerge      ]  media-libs/alsa-lib-1.0.10
[nomerge      ]   sys-kernel/gentoo-sources-2.6.14-r5
[nomerge      ]    app-text/docbook-sgml-utils-0.6.12
[ebuild  NS   ]     app-text/docbook-xml-dtd-4.3
[nomerge      ] net-fs/samba-3.0.14a-r2
[nomerge      ]  dev-libs/popt-1.7-r1
[nomerge      ]    app-text/ghostscript-7.07.1-r8
[nomerge      ]     net-print/cups-1.1.23-r4
[ebuild  N    ]      app-text/xpdf-3.01-r3
tulkas pkg # 
Back to top
View user's profile Send private message
Hagar
Guru
Guru


Joined: 11 Feb 2003
Posts: 445

PostPosted: Fri Dec 30, 2005 8:28 pm    Post subject: Reply with quote

poppler is the library component of xpdf.
You probably want poppler and not xpdf.

It seems cups still depends on xpdf on your system, this is incorrect and fixed in the portage tree.
So `emerge sync` first and the block should go away.
Back to top
View user's profile Send private message
jasm
Tux's lil' helper
Tux's lil' helper


Joined: 10 Sep 2003
Posts: 80
Location: Belgium

PostPosted: Fri Dec 30, 2005 8:45 pm    Post subject: Reply with quote

Hi there,

I experienced the same problem yesterday. I managed to figure out that I was using an unstable version of poppler (due to installing kde-3.5.0) toghether with the stable version of xpdf. Things got solved by using the unstable version for both poppler and xpdf.

Jan
Back to top
View user's profile Send private message
bladus
Apprentice
Apprentice


Joined: 27 Jul 2005
Posts: 233

PostPosted: Fri Dec 30, 2005 8:57 pm    Post subject: Reply with quote

If you don't want to have xpdf on your system just emerge cups-1.1.23-r7
Back to top
View user's profile Send private message
firephoto
Veteran
Veteran


Joined: 29 Oct 2003
Posts: 1604
Location: +48° 5' 23.40", -119° 48' 30.00"

PostPosted: Fri Dec 30, 2005 9:51 pm    Post subject: Reply with quote

Just unmerge xpdf then emerge world and you should be ok. The new version of xpdf will get pulled in if your system still needs it.
_________________
#gentoo-kde on freenode
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Sat Dec 31, 2005 1:13 am    Post subject: Reply with quote

Duplicate of https://forums.gentoo.org/viewtopic-t-417036.html
_________________
www.gentoo.org.au || #gentoo-au
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum