Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Libflac [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
jjasghar
Guru
Guru


Joined: 07 Mar 2004
Posts: 342
Location: $HOME=/usa/tx/austin

PostPosted: Tue Jan 03, 2006 4:18 pm    Post subject: Libflac [SOLVED] Reply with quote

I'm attempting to build libflac from src, without using emerge. I get a nasty error build doing it...

Code:

/usr/bin/ld -r -o .libs/libFLAC.la-5.o .libs/file_decoder.o .libs/libFLAC.la-4.o
/usr/bin/ld -r -o .libs/libFLAC.la-6.o .libs/file_encoder.o .libs/libFLAC.la-5.o
/usr/bin/ld -r -o .libs/libFLAC.la-7.o .libs/fixed.o .libs/libFLAC.la-6.o
/usr/bin/ld -r -o .libs/libFLAC.la-8.o .libs/float.o .libs/libFLAC.la-7.o
/usr/bin/ld -r -o .libs/libFLAC.la-9.o .libs/format.o .libs/libFLAC.la-8.o
/usr/bin/ld -r -o .libs/libFLAC.la-10.o .libs/lpc.o .libs/libFLAC.la-9.o
/usr/bin/ld -r -o .libs/libFLAC.la-11.o .libs/md5.o .libs/libFLAC.la-10.o
/usr/bin/ld -r -o .libs/libFLAC.la-12.o .libs/memory.o .libs/libFLAC.la-11.o
/usr/bin/ld -r -o .libs/libFLAC.la-13.o .libs/metadata_iterators.o .libs/libFLAC.la-12.o
/usr/bin/ld -r -o .libs/libFLAC.la-14.o .libs/metadata_object.o .libs/libFLAC.la-13.o
/usr/bin/ld -r -o .libs/libFLAC.la-15.o .libs/seekable_stream_decoder.o .libs/libFLAC.la-14.o
/usr/bin/ld -r -o .libs/libFLAC.la-16.o .libs/seekable_stream_encoder.o .libs/libFLAC.la-15.o
/usr/bin/ld -r -o .libs/libFLAC.la-17.o .libs/stream_decoder.o .libs/libFLAC.la-16.o
/usr/bin/ld -r -o .libs/libFLAC.la-18.o .libs/stream_encoder.o .libs/libFLAC.la-17.o
/usr/bin/ld -r -o .libs/libFLAC.la-19.o .libs/stream_encoder_framing.o .libs/libFLAC.la-18.o
gcc -shared .libs/libFLAC.la-19.o  -lm  -maltivec -mabi=altivec -mcpu=powerpc -Wl,-read_only_relocs -Wl,warning -Wl,-soname -Wl,libFLAC.so.7 -o .libs/libFLAC.so.7.0.0
/usr/bin/ld: bad -rpath option
collect2: ld returned 1 exit status
make[4]: *** [libFLAC.la] Error 1
make[4]: Leaving directory `/usr/ports/opt/flac/work/src/flac-1.1.2/src/libFLAC'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/usr/ports/opt/flac/work/src/flac-1.1.2/src/libFLAC'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/usr/ports/opt/flac/work/src/flac-1.1.2/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/ports/opt/flac/work/src/flac-1.1.2'
make: *** [all] Error 2


any ideas?

thanks.
_________________
#include <LinuxUser #324070>
main()
{
printf("and i'm sorry my spellign sucs.");
}


Last edited by jjasghar on Wed Jan 04, 2006 3:51 pm; edited 1 time in total
Back to top
View user's profile Send private message
zeekec
n00b
n00b


Joined: 24 Feb 2004
Posts: 56
Location: Athens, GA, USA

PostPosted: Tue Jan 03, 2006 8:35 pm    Post subject: Reply with quote

You might check what patches the ebuild applies.

Erik
_________________
Against stupidity the very gods
Themselves contend in vain.
-Johann Christoph Friedrich von Schiller (1801)
Back to top
View user's profile Send private message
jjasghar
Guru
Guru


Joined: 07 Mar 2004
Posts: 342
Location: $HOME=/usa/tx/austin

PostPosted: Wed Jan 04, 2006 3:50 pm    Post subject: Reply with quote

turns out i got it fixed through another forum/ML all i needed to do was
Code:

./configure --disable-asm-optimizations


crazy ass asm.
_________________
#include <LinuxUser #324070>
main()
{
printf("and i'm sorry my spellign sucs.");
}
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum