Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Some blocking problems... [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
jomputin
n00b
n00b


Joined: 26 Nov 2005
Posts: 21
Location: Finland

PostPosted: Thu Jan 05, 2006 7:44 pm    Post subject: Some blocking problems... [SOLVED] Reply with quote

I did emerge -uDva world and it complained the following:

Code:
[blocks B     ] >=sys-apps/dbus-0.60 (is blocking net-wireless/bluez-utils-2.19)
[blocks B     ] <app-text/xpdf-3.01-r4 (is blocking app-text/poppler-0.4.3-r4)


I installed bluez-utils a couple of days ago (and even got bluetooth working), do I really have to unmerge it to have dbus updated?
About that xpdf, I unmerged it, does it still think of existing on my box?

Any help is appreciated.


Last edited by jomputin on Fri Jan 06, 2006 7:14 pm; edited 1 time in total
Back to top
View user's profile Send private message
_loki_
l33t
l33t


Joined: 18 Dec 2003
Posts: 680
Location: in the shell

PostPosted: Thu Jan 05, 2006 11:42 pm    Post subject: Reply with quote

poppler is a replacement for xpdf which is obsolete with that.. Run
Code:

emerge -p depclean

to see what I mean.. run a depclean when there is nothing else you need, or unmerge xpdf manually..

I also had the same problem with dbus and bluez-utils and just edited the bluez-utils ebuild for solving that, as I guessed that it can't be true that a programm works with a 0.6 version, but not with 0.6-rx.. Anyway as I had a look on the lastest ebuild (did a sync just now) it looks like the following
Code:

 dbus? ( >=sys-apps/dbus-0.31 )

so I guess that it works if you just do another sync..
Back to top
View user's profile Send private message
jomputin
n00b
n00b


Joined: 26 Nov 2005
Posts: 21
Location: Finland

PostPosted: Fri Jan 06, 2006 10:36 am    Post subject: Reply with quote

depclean doesn't find xpdf, because I unmerged it... I synced and now portage wants to emerge both xpdf and poppler-bindings! So xpdf seems to have remained in my world file, right?
Syncing didn't help with this dbus-bluez thing. It still whines about blocking...
Back to top
View user's profile Send private message
Andrew
n00b
n00b


Joined: 14 Jan 2003
Posts: 23

PostPosted: Fri Jan 06, 2006 11:36 am    Post subject: Reply with quote

jomputin wrote:
depclean doesn't find xpdf, because I unmerged it... I synced and now portage wants to emerge both xpdf and poppler-bindings! So xpdf seems to have remained in my world file, right?
Syncing didn't help with this dbus-bluez thing. It still whines about blocking...


Hi,

I am having the same trouble with a differenece that I have bluez-utils 0.22. Does anybody dig into that?
Back to top
View user's profile Send private message
_loki_
l33t
l33t


Joined: 18 Dec 2003
Posts: 680
Location: in the shell

PostPosted: Fri Jan 06, 2006 12:15 pm    Post subject: Reply with quote

If you unmerged xpdf it should not be in world anymore..- anyway just take a look on it (I think it's in /var/lib/portage/world).. It makes no sence to have them both on the system- and as told before for me depclean wanted to get rid of it; anyway if you unmerged it, it shouldn't be a problem anymore..
Regarding bluez-utils and dbus: 2.19 is marked as stable, 2.22-r1 as ~x86 that'd explain the diferences in your packages, have a look in the ebuilds and see how and on which versions they depend on dbus. You could try to extend the dependancy and see if it still works afterwards, if the r3 release really mess up something regarding bluez, what I think is unlikely you'll have to mask the newer dbus version manually in /etc/portage/package.mask..
Back to top
View user's profile Send private message
jomputin
n00b
n00b


Joined: 26 Nov 2005
Posts: 21
Location: Finland

PostPosted: Fri Jan 06, 2006 3:16 pm    Post subject: Reply with quote

Hmm.. This is interesting:

Code:
munki1 ~ # emerge -vta bluez-utils

These are the packages that I would merge, in reverse order:

Calculating dependencies ...done!
[ebuild     U ] net-wireless/bluez-utils-2.22-r1 [2.19] +alsa +cups +dbus -gtk -pcmcia 532 kB
[ebuild  N    ]  net-print/cups-1.1.23-r4  -cjk -gnutls +nls +pam +samba -slp +ssl 0 kB
[ebuild  N    ]   app-text/xpdf-3.01-r3  +X -motif 0 kB
[ebuild     U ]  net-wireless/bluez-libs-2.22 [2.19] 0 kB
[ebuild  N    ]  sys-apps/dbus-0.60-r3  +X -debug -doc -gcj -gtk (-mono) +python +qt (-selinux) +xml2 0 kB


So doing that with USE="-cups" solved the problem!
Back to top
View user's profile Send private message
tomk
Bodhisattva
Bodhisattva


Joined: 23 Sep 2003
Posts: 7221
Location: Sat in front of my computer

PostPosted: Sat Jan 14, 2006 8:08 pm    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads, please see this topic.
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum