Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
I broke emerge [null]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
XenoTerraCide
Veteran
Veteran


Joined: 18 Jan 2004
Posts: 1418
Location: MI, USA

PostPosted: Sun Jan 08, 2006 10:16 am    Post subject: I broke emerge [null] Reply with quote

I was starting to upgrad to gcc-3.4.4 on a fresh insall of 2005.1 I noticed my chost was wrong so I changed it. figuring I was about to do an emerge -e soon anyway. then I re-emerged -e gcc. after that I tried to do an emerge and it complained /usr/bin/python missing... I was able to copy that off my other gentoo box which currently has a very similar setup to what I want my laptop to have. now I'm getting this error...
Code:
/usr/bin/python: error while loading shared libraries: libstdc++.so.5: cannot open shared object file: no such file or directory
where is it looking? can I copy that file from this computer? or should I just reinstall, and this time use a network install so I can get a tarball that's for an athlon-xp?

Last edited by XenoTerraCide on Sun Jan 08, 2006 3:59 pm; edited 1 time in total
Back to top
View user's profile Send private message
BoNd60
n00b
n00b


Joined: 17 Nov 2005
Posts: 73
Location: Paris, France

PostPosted: Sun Jan 08, 2006 11:05 am    Post subject: Reply with quote

For me, libstdc++.so.5 lays in /usr/lib/libstdc++-v3/libstdc++.so.5
If you have compiled libstdc++-v3 on your other PC, it will be ok or if you want, i can send it to you (i'm athlon-xp too)
_________________
Oops, I think I'm not DOS compatible

In every situation, don't forget that the answer is 42
Back to top
View user's profile Send private message
XenoTerraCide
Veteran
Veteran


Joined: 18 Jan 2004
Posts: 1418
Location: MI, USA

PostPosted: Sun Jan 08, 2006 11:13 am    Post subject: Reply with quote

no I have it... I'll see if it works in a few. or if I'm gonna have more probs. I now realise why it wouldn't copy last night. libstdc++.so.5 is a symlink pointing to libstdc++.so.5.0.6 well copying the symlink wasn't gonna work.
Back to top
View user's profile Send private message
BoNd60
n00b
n00b


Joined: 17 Nov 2005
Posts: 73
Location: Paris, France

PostPosted: Sun Jan 08, 2006 11:21 am    Post subject: Reply with quote

That's true, but i didn't know it was a symlink because i just use find to seek it
_________________
Oops, I think I'm not DOS compatible

In every situation, don't forget that the answer is 42
Back to top
View user's profile Send private message
XenoTerraCide
Veteran
Veteran


Joined: 18 Jan 2004
Posts: 1418
Location: MI, USA

PostPosted: Sun Jan 08, 2006 11:26 am    Post subject: Reply with quote

I used locate. and I didn't realise it either until you confirmed the location. then I ls'd that directory (note: i have ls aliased to ls -la --color=auto) and that's when I saw that. I'm trying to get a dhcp server up on this comp so I don't have to set the mac on my laptop to be the same as my desktop so they can both access the internet. so when I have that done I'll try it.
Back to top
View user's profile Send private message
XenoTerraCide
Veteran
Veteran


Joined: 18 Jan 2004
Posts: 1418
Location: MI, USA

PostPosted: Sun Jan 08, 2006 3:16 pm    Post subject: Reply with quote

ug... I'm still getting the same error and I copied all version's of the file on my desktop. to my laptop and created the symlinks that I'm aware of. isn't ther a way to check all the links to the files? I think there is but I don't remember what it is. I think I should start over. chalk it up to experience... and yell at the dev's for f-ing up the athlon-xp stage 3 tarballs and then not including them on the disk.
Back to top
View user's profile Send private message
BoNd60
n00b
n00b


Joined: 17 Nov 2005
Posts: 73
Location: Paris, France

PostPosted: Sun Jan 08, 2006 3:52 pm    Post subject: Reply with quote

have you copy the file /etc/env.d/99libstdc++ ?
_________________
Oops, I think I'm not DOS compatible

In every situation, don't forget that the answer is 42
Back to top
View user's profile Send private message
XenoTerraCide
Veteran
Veteran


Joined: 18 Jan 2004
Posts: 1418
Location: MI, USA

PostPosted: Sun Jan 08, 2006 3:58 pm    Post subject: Reply with quote

no I didn't but it's too late now I wiped it. it's not that big of a deal... I hadn't installed anything past the defaults really. this time I'm doing a network install though.
Back to top
View user's profile Send private message
Sachankara
l33t
l33t


Joined: 11 Jun 2004
Posts: 696
Location: Stockholm, Sweden

PostPosted: Sun Jan 08, 2006 4:22 pm    Post subject: Re: I broke emerge [null] Reply with quote

XenoTerraCide wrote:
I was starting to upgrad to gcc-3.4.4 on a fresh insall of 2005.1 I noticed my chost was wrong so I changed it. figuring I was about to do an emerge -e soon anyway. then I re-emerged -e gcc. after that I tried to do an emerge and it complained /usr/bin/python missing... I was able to copy that off my other gentoo box which currently has a very similar setup to what I want my laptop to have. now I'm getting this error...
Code:
/usr/bin/python: error while loading shared libraries: libstdc++.so.5: cannot open shared object file: no such file or directory
where is it looking? can I copy that file from this computer? or should I just reinstall, and this time use a network install so I can get a tarball that's for an athlon-xp?
This did the trick for me for a few days ago when I had the same problem:
Code:
gcc-config -l
gcc-config <number of your compiler listed previously>

_________________
Gentoo Hardened Linux 2.6.21 + svorak (Swedish dvorak)
Back to top
View user's profile Send private message
XenoTerraCide
Veteran
Veteran


Joined: 18 Jan 2004
Posts: 1418
Location: MI, USA

PostPosted: Sun Jan 08, 2006 4:24 pm    Post subject: Reply with quote

I did that... didn't work emerge was still broken...
Back to top
View user's profile Send private message
hijjt
n00b
n00b


Joined: 15 Oct 2003
Posts: 9

PostPosted: Thu Jan 12, 2006 6:59 am    Post subject: gcc madness Reply with quote

I have had this a few times, I have fixed it in various and probably wrong ways before, usually an ldconfig will re-configure where librarys are going to be correctly. The time that ldconfig didn't work I built python by hand. First I made sure that I had the write gcc selected with gcc-config.Then I used wget to download the latest python version in portage, and proceded to configure with a prefix of I believe /usr/share and made it and installed it. This fixed the emerge thing but there are still going to be problems down the road if you don't fix the parties at fault. Those being python portage and your toolchain. While this solution is rather a pain I find it much quicker to do this than to do the portage recovery.
Back to top
View user's profile Send private message
XenoTerraCide
Veteran
Veteran


Joined: 18 Jan 2004
Posts: 1418
Location: MI, USA

PostPosted: Thu Jan 12, 2006 4:53 pm    Post subject: Reply with quote

yeah I wiped the system... but I thought of doing something like that. but it was a fresh install. I didn't even have X yet so it wasn't worth my time to do that. reinstalling was about just as fast as some of the other solutions.
_________________
I don't hang out here anymore, try asking on http://unix.stackexchange.com/ if you want my help.
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Tue Feb 28, 2006 11:20 pm    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads in favour of this FAQ: Error while loading shared libraries: libstdc++.so.5.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum